I/Q Analyzer
Contents
  • Welcome to the I/Q Analyzer Application
  • Typical Applications for the I/Q Analyzer and I/Q Input
  • Measurement and Result Displays
  • Basics on I/Q Data Acquisition and Processing
  • Configuration
  • Analysis
  • How to Work with I/Q Data
  • Optimizing and Troubleshooting the Measurement
  • Remote Commands to Perform Measurements with I/Q Data
  • List of Commands
Top


Welcome to the I/Q Analyzer Application

I/Q Analyzer > Welcome to the I/Q Analyzer Application
Welcome to the I/Q Analyzer Application

The R&S FSW I/Q Analyzer is a firmware application that adds functionality to perform I/Q data acquisition and analysis to the R&S FSW.

The R&S FSW-I/Q Analyzer features:

  • Acquisition of analog I/Q data
  • Optionally, acquisition of digital I/Q data via the Digital Baseband Interface option (R&S FSW-B17)
  • Optionally, acquisition of analog baseband data via the Analog Baseband Interface option (R&S FSW-B71)
  • Import of stored I/Q data from other applications
  • Spectrum, magnitude, I/Q vector and separate I and Q component analysis of any I/Q data on the instrument
  • Export of I/Q data to other applications
  • Optionally, direct output of digital I/Q data via the Digital Baseband Interface option (R&S FSW-B17)

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

The R&S FSW I/Q Analyzer application is part of the standard base unit and requires no further installation.

The Digital Baseband Interface option (R&S FSW-B17) requires both hardware and firmware installation, which is described in the release notes provided with the option at delivery.

Contents
  • Starting the I/Q Analyzer Application
  • Understanding the Display Information


Starting the I/Q Analyzer Application

I/Q Analyzer > Welcome to the I/Q Analyzer Application > Starting the I/Q Analyzer Application
Starting the I/Q Analyzer Application

The I/Q Analyzer is an application on the standard R&S FSW.

To activate the I/Q Analyzer application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all applications currently available on your R&S FSW.

  2. Select the "I/Q Analyzer" item.

    The R&S FSW opens a new measurement channel for the I/Q Analyzer application.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the I/Q Analyzer "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (as well as the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

I/Q Analyzer > Welcome to the I/Q Analyzer Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during I/Q Analyzer operation. All different information areas are labeled. They are explained in more detail in the following sections.

Screen elements in the I/Q Analyzer application
1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area with marker information
5 = Diagram footer with diagram-specific information, depending on result display
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA/MSRT operating mode

In MSRA and MSRT operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA/MSRT operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Channel bar information

In the I/Q Analyzer application, the R&S FSW shows the following settings:

Information displayed in the channel bar for the I/Q Analyzer application
Ref Level | Reference level
(m.+el.)Att | (Mechanical and electronic) RF attenuation
Ref Offset | Reference level offset
Freq | Center frequency
Meas Time | Measurement time
Rec Length | Defined record length (number of samples to capture)
SRate | Defined sample rate for data acquisition
RBW | (Spectrum evaluation only) Resolution bandwidth calculated from the sample rate and record length
Inp:Dig-IQ | Input source: digital I/Q data from the optional Digital Baseband Interface (R&S FSW-B17)
Inp:Analog <I/Q mode> | Input source: analog baseband data from the optional Analog Baseband Interface (R&S FSW-B71) <I/Q mode>: defines the processing mode (see "I/Q Processing Modes")

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in the I/Q Analyzer application
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector
6 = Trace mode
Diagram footer information

The information in the diagram footer (beneath the diagram) depends on the evaluation:

  • Center frequency
  • Number of sweep points
  • Range per division (x-axis)
  • Span (Spectrum)
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.

For details see "Error Messages".


Typical Applications for the I/Q Analyzer and I/Q Input

I/Q Analyzer > Typical Applications for the I/Q Analyzer and I/Q Input
Typical Applications for the I/Q Analyzer and I/Q Input

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the "in phase" (I) and the "quadrature" (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband. Thus, the I/Q Analyzer is ideal for analyzing I/Q baseband signals.

The optional Digital Baseband Interface (R&S FSW-B17) can be used to capture or output the I/Q data.

The following typical applications use the R&S Digital Baseband Interface:

  • Capturing and evaluating digital I/Q data in the I/Q Analyzer application of the R&S FSW base unit or other (optional) applications, e.g. R&S FSW-K70 (VSA). See also the description of the individual applications.
  • Output of digital I/Q data to a selected receiver, e.g. to implement fading (simulating mobile radio communication participants) using a generator.
  • Capturing and evaluating digital I/Q data from a device with a user-specific interface using an R&S EX-IQ-BOX (see the "R&S®EX-IQ-BOX - External Signal Interface Module Manual").
  • Output of digital I/Q data to a device with a user-specific interface using an R&S EX-IQ-BOX (see the "R&S®EX-IQ-BOX - External Signal Interface Module Manual").
R&S EX-IQ-BOX and R&S DigIConf

The R&S EX-IQ-BOX is a configurable interface module that converts signal properties and the transmission protocol of the R&S instruments into user-defined or standardized signal formats and vice versa.

The latest R&S EX-IQ-BOX (model 1409.5505K04) provides the configuration software R&S DigIConf which can be installed directly on the R&S FSW. The software R&S DigIConf (Digital Interface Configurator for the R&S EX-IQ-BOX, version 2.10 or higher) controls the protocol, data and clock settings of the R&S EX-IQ-BOX independently from the connected R&S instrument. Besides basic functions of the user-defined protocols, this software utility supports the settings for standardized protocols, as e.g. CPRI, OBSAI or DigRF. Note that R&S DigIConf requires a USB connection (not LAN!) to the R&S FSW in addition to the R&S Digital Baseband Interface connection.

Remote control is possible and very simple. Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S EX-IQ-BOX automatically via the USB connection.

A setup file, included in delivery, consists of an installation wizard, the executable program and all necessary program and data files. The latest software versions can be downloaded free of charge from the R&S website: www.rohde-schwarz.com/en/products/test_and_measurement/signal_generation/EX-IQ-Box. Simply execute the Setup file and follow the instructions in the installation wizard.

(Note: When using the EX-IQ-BOX with Digital I/Q Enhanced Mode (see "Digital I/Q enhanced mode"), an R&S EX-IQ-BOX model 1409.5505K04 with a serial number higher than 10200 is required in order to transfer data with up to 200 Msps.)

For details on installation and operation of the R&S DigIConf software, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".


Measurement and Result Displays

I/Q Analyzer > Measurement and Result Displays
Measurement and Result Displays

The I/Q Analyzer can capture I/Q data. The I/Q data that was captured by or imported to the R&S FSW can then be evaluated in various different result displays. Select the result displays using the SmartGrid functions.

As of firmware version 1.60, up to 6 evaluations can be displayed in the I/Q Analyzer at any time, including several graphical diagrams, marker tables or peak lists.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

Measurements in the time and frequency domain

The I/Q Analyzer application (not Master in MSRA mode) can also perform measurements on the captured I/Q data in the time and frequency domain (see also "I/Q Analyzer in MSRA/MSRT Operating Mode"). They are configured using the same settings and provide similar results. In addition, the analysis interval used for the measurement is indicated as in all multistandard applications.

The time and frequency domain measurements and the available results are described in detail in "Measurements" .

Result displays for I/Q data:
└ Magnitude
└ Spectrum
└ I/Q-Vector
└ Real/Imag (I/Q)
└ Marker Table
└ Marker Peak List


Magnitude

I/Q Analyzer > Measurement and Result Displays > Magnitude
Magnitude

Shows the level values in time domain.

Remote command:

LAY:ADD:WIND? '1',RIGH,MAGN, see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?


Spectrum

I/Q Analyzer > Measurement and Result Displays > Spectrum
Spectrum

Displays the frequency spectrum of the captured I/Q samples.

Remote command:

LAY:ADD:WIND? '1',RIGH,FREQ, see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?


I/Q-Vector

I/Q Analyzer > Measurement and Result Displays > I/Q-Vector
I/Q-Vector

Displays the captured samples in an I/Q-plot. The samples are connected by a line.

Note: For the I/Q vector result display, the number of I/Q samples to record ("Record Length") must be identical to the number of trace points to be displayed ("Sweep Points"; for I/Q Analyzer: 1001). For record lengths outside the valid range of sweep points the diagram does not show valid results.

For input from the Analog Baseband Interface (R&S FSW-B71) in real baseband mode, the I/Q vector is a constant line (as one component is 0 for all sweep points).

For more information see "I/Q Processing Modes".

Remote command:

LAY:ADD:WIND? '1',RIGH,VECT, see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?


Real/Imag (I/Q)

I/Q Analyzer > Measurement and Result Displays > Real/Imag (I/Q)
Real/Imag (I/Q)

Displays the I and Q values in separate diagrams.

Note: For analog baseband input in Real Baseband mode, only one diagram is displayed (for the selected component).
For details see "Real baseband mode (I or Q only)".

Remote command:

LAY:ADD:WIND? '1',RIGH,RIM, see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?


Marker Table

I/Q Analyzer > Measurement and Result Displays > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Marker Peak List

I/Q Analyzer > Measurement and Result Displays > Marker Peak List
Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum or time domain. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

Remote command:

LAY:ADD? '1',RIGH, PEAK, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Basics on I/Q Data Acquisition and Processing

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing
Basics on I/Q Data Acquisition and Processing

Some background knowledge on basic terms and principles used when describing I/Q data acquisition on the R&S FSW in general, and in the I/Q Analyzer application in particular, is provided here for a better understanding of the required configuration settings.

The I/Q Analyzer provides various possibilities to acquire the I/Q data to be analyzed:

  • Capturing analog I/Q data from the RF INPUT connector
  • Capturing digital I/Q data from the optional Digital Baseband Interface (R&S FSW-B17)
  • Capturing analog I/Q data from the optional Analog Baseband Interface (R&S FSW-B71), for example from active probes
  • Capturing analog I/Q data from the optional Analog Baseband Interface (R&S FSW-B71) and redirecting it to the RF input path
  • Importing I/Q data from a file

Background information for all these scenarios and more is provided in the following sections.

Contents
  • Processing Analog I/Q Data from RF Input
  • Processing Data from the Digital Baseband Interface (R&S FSW-B17)
  • Processing Data From the Analog Baseband Interface
  • Receiving Data Input and Providing Data Output
  • I/Q Data Import and Export
  • Basics on FFT
  • I/Q Analyzer in MSRA/MSRT Operating Mode
  • Measurements in the Time and Frequency Domain


Processing Analog I/Q Data from RF Input

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Analog I/Q Data from RF Input
Processing Analog I/Q Data from RF Input
Complex baseband data

In the telephone systems of the past, baseband data was transmitted unchanged as an analog signal. In modern phone systems and in radio communication, however, the baseband data is modulated on a carrier frequency, which is then transmitted and must be demodulated by the receiver. When using modern modulation methods (e.g. QPSK, QAM etc.), the baseband signal becomes complex. Complex data (or: I/Q data) consists of an imaginary (I) and a real (Q) component.

Sweep vs sampling

While the standard Spectrum application on the R&S FSW performs frequency sweeps on the input signal and measurements in the frequency and time domain, other applications on the R&S FSW are capable of sampling and processing the individual I and Q components of the complex signal.

I/Q Analyzer - processing complex data from RF input

The I/Q Analyzer, for example, is a standard application used to capture and analyze I/Q data on the R&S FSW. By default, it assumes the I/Q data is modulated on a carrier frequency and input via the RF INPUT connector on the R&S FSW.

The A/D converter samples the IF signal at a rate of 200 MHz. The digital signal is down-converted to the complex baseband, lowpass-filtered, and the sample rate is reduced. An equalizer filter before the resampler compensates for the frequency response of the analyzer's analog filter stages which would otherwise add to the modulation errors. The continuously adjustable sample rates are realized using an optimal decimation filter and subsequent resampling on the set sample rate.

A special memory (capture buffer) is available in the instrument for a maximum of 400 Ms (400*1024*1024) of complex samples (pairs of I and Q data). The number of complex samples to be captured can be defined (for restrictions refer to "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

The block diagram in figure "Block diagram illustrating the R&S FSW signal processing for analog I/Q data (without bandwidth extension options)" shows the analyzer hardware from the IF section to the processor.

Block diagram illustrating the R&S FSW signal processing for analog I/Q data (without bandwidth extension options)
Block diagram illustrating the R&S FSW signal processing for analog I/Q data (with option B160)
Block diagram illustrating the R&S FSW signal processing for analog I/Q data (with option B320)
Block diagram illustrating the R&S FSW signal processing for analog I/Q data (with option B500)
Contents
  • Sample Rate and Maximum Usable I/Q Bandwidth for RF Input


Sample Rate and Maximum Usable I/Q Bandwidth for RF Input

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Analog I/Q Data from RF Input > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Definitions
  • Input sample rate (ISR): the sample rate of the useful data provided by the connected instrument to the R&S FSW input
  • (User, Output) Sample rate (SR): the sample rate that is defined by the user (e.g. in the "Data Aquisition" dialog box in the "I/Q Analyzer" application) and which is used as the basis for analysis or output
  • Usable I/Q (Analysis) bandwidth: the bandwidth range in which the signal remains undistorted in regard to amplitude characteristic and group delay; this range can be used for accurate analysis by the R&S FSW
  • Record length: Number of I/Q samples to capture during the specified measurement time; calculated as the measurement time multiplied by the sample rate

For the I/Q data acquisition, digital decimation filters are used internally. The passband of these digital filters determines the maximum usable I/Q bandwidth. In consequence, signals within the usable I/Q bandwidth (passband) remain unchanged, while signals outside the usable I/Q bandwidth (passband) are suppressed. Usually, the suppressed signals are noise, artifacts, and the second IF side band. If frequencies of interest to you are also suppressed, you should try to increase the output sample rate, since this increases the maximum usable I/Q bandwidth.

Bandwidth extension options

The maximum usable I/Q bandwidth provided by the R&S FSW in the basic installation can be extended by additional options. These options can either be included in the initial installation (B-options) or updated later (U-options). The maximum bandwidth provided by the individual option is indicated by its number, for example, B40 extends the bandwidth to 40 MHz.

Note that the U-options as of U40 always require all lower-bandwidth options as a prerequisite, while the B-options already include them.

Max. usable I/Q BW

Required B-option

Required U-option(s)

10 MHz

-

-

28 MHz

B28

U28

40 MHz

B40

U28+U40 or

B28+U40

80 MHz

B80

U28+U40+U80 or

B28+U40+U80 or

B40+U80

160 MHz

B160

U28+U40+U80+U160 or

B28+U40+U80+U160 or

B40+U80+U160 or

B80+U160

320 MHz

B320*)

U28+U40+U80+U160+U320 or

B28+U40+U80+U160+U320 or

B40+U80+U160+U320 or

B80+U160+U320 or

B160+U320

500 MHz

B500**)

See data sheet

*) The bandwidth extension option R&S FSW-B320/-U320 requires a reference board revision 3.14 or higher.

**) The bandwidth extension option R&S FSW-B500 requires a reference board (1312.8075.06) revision 4.06 or higher and a motherboard 1313.4180.02 or 1313.7698.02.

As a rule, the usable I/Q bandwidth is proportional to the output sample rate. Yet, when the I/Q bandwidth reaches the bandwidth of the analog IF filter (at very high output sample rates), the curve breaks.

Relationship between sample rate, record length and usable I/Q bandwidth

Up to the maximum bandwidth, the following rule applies:

Usable I/Q bandwidth = 0.8 * Output sample rate

Regarding the record length, the following rule applies:

Record length = Measurement time * sample rate

Maximum record length for RF input

The maximum record length, that is, the maximum number of samples that can be captured, depends on the sample rate.

(For activated option B320 or U320 see table "Maximum record length with activated I/Q bandwidth extension option B320 or U320".)

(For activated option B500 see table "Maximum record length with activated I/Q bandwidth extension option B500".)

Maximum record length (without I/Q bandwidth extension options B320/U320/B500)
Sample rate | Maximum record length
100 Hz to 200 MHz | 440 MSamples (precisely: 461373440 (= 440*1024*1024) samples)
200 MHz to 10 GHz (upsampling) | 220 MSamples
MSRA operating mode

In MSRA operating mode, the MSRA Master is restricted to a sample rate of 600 MHz.

Digital Baseband output

If Digital Baseband output is active (see "Digital Baseband Output") the sample rate is restricted to 200 MHz (max. 160 MHz usable I/Q bandwidth).

The figure "Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions" shows the maximum usable I/Q bandwidths depending on the output sample rates.

R&S FSW without additional bandwidth extension options

sample rate: 100 Hz - 10 GHz

maximum I/Q bandwidth: 10 MHz

Maximum I/Q bandwidth
Sample rate | Maximum I/Q bandwidth
100 Hz to 10 MHz | proportional up to maximum 10 MHz
10 MHz to 10 GHz | 10 MHz
R&S FSW with options B28 or U28 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 28 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 35 MHz | proportional up to maximum 28 MHz
35 MHz to 10 GHz | 28 MHz
R&S FSW with option B40 or U40 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 40 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 50 MHz | proportional up to maximum 40 MHz
50 MHz to 10 GHz | 40 MHz
R&S FSW with option B80 or U80 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 80 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 100 MHz | proportional up to maximum 80 MHz
100 MHz to 10 GHz | 80 MHz
R&S FSW with activated option B160 or U160 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 160 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 200 MHz | proportional up to maximum 160 MHz
200 MHz to 10 GHz | 160 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions
Contents
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Analog I/Q Data from RF Input > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Sample rate | Maximum I/Q bandwidth
100 Hz to 400 MHz | proportional up to maximum 320 MHz
400 MHz to 10 GHz | 320 MHz
Digital Baseband output

If Digital Baseband output is active (see "Digital Baseband Output") the sample rate is restricted to 200 MHz (max. 160 MHz usable I/Q bandwidth).

Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B320
Maximum record length with activated I/Q bandwidth extension option B320 or U320
Sample rate | Maximum record length
100 Hz to 200 MHz*) | 440 MSamples
200 MHz to 468 MHz | 470 MSamples * sample rate / 1GHz
468 MHz to 10 GHz | 220 MSamples
*) for sample rates < 200 MHz the I/Q Bandwidth Extension B320 is not used


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Analog I/Q Data from RF Input > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

The bandwidth extension option R&S FSW-B500 provides measurement bandwidths up to 500 MHz.

Digital Baseband output

Digital Baseband output (see "Digital Baseband Output") is not available for an active R&S FSW-B500 bandwidth extension.

Realtime measurements and MSRT operating mode

Realtime measurements, and thus the entire MSRT operating mode, are not available if the R&S FSW-B500 bandwidth extension option is installed.

Sample rate | Maximum I/Q bandwidth
100 Hz to 600 MHz | proportional up to maximum 500 MHz
600 MHz to 10 GHz | 500 MHz
Bandwidths between 480 MHz and 500 MHz

Note the irregular behavior of the sample rate/usable I/Q bandwidth relationship for bandwidths between 480 MHz and 500 MHz, depending on which setting you change.

For compatibility reasons, the relationship of Usable I/Q bandwidth = 0.8 * Output sample rate is maintained for bandwidths ≤480 MHz.

However, in order to make use of the maximum possible sample rate of 600 MHz at the maximum bandwidth of 500 MHz, if you change the bandwidth between 480 MHz and 500 MHz, the sample rate is adapted according to the relationship Output sample rate = Usable I/Q bandwidth/0.833.

On the other hand, if you decrease the sample rate under 600 MHz, the I/Q bandwidth is adapted according to the regular relationship of Usable I/Q bandwidth = 0.8 * Output sample rate.

Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B500
MSRA operating mode

In MSRA operating mode with active B500 bandwidth extension, the MSRA Master is restricted to a sample rate of 600 MHz.

Maximum record length with activated I/Q bandwidth extension option B500
Sample rate | Maximum record length
100 Hz to 10 GHz | 440 MSamples


Processing Data from the Digital Baseband Interface (R&S FSW-B17)

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data from the Digital Baseband Interface (R&S FSW-B17)
Processing Data from the Digital Baseband Interface (R&S FSW-B17)

Alternatively to capturing (analog) I/Q data from the standard RF Input connector on the front panel of the R&S FSW, digital I/Q data can be captured from the optional Digital Baseband Interface (R&S FSW-B17), if installed.

Furthermore, the I/Q data processed by the I/Q Analyzer can also be output to this interface.

The digital input and output cannot be used simultaneously.

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Contents
  • Digital Input
  • Digital Output
  • Sample Rates and Bandwidths for Digital I/Q Data
  • Interface Status Information


Digital Input

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data from the Digital Baseband Interface (R&S FSW-B17) > Digital Input
Digital Input

Digital I/Q data can be used as an alternative data input source for measurements with the R&S FSW.

The digital input and output cannot be used simultaneously.

Connecting the digital input instrument

The instrument that provides digital input must be connected to the R&S Digital Baseband Interface at the rear of the R&S FSW. Information on the detected input instrument is shown in the Digital I/Q Input Source configuration dialog. You can configure the basic connection settings, e.g. the input sample rate.

It is recommended that you use the R&S®SMU-Z6 (1415.0201.02) cable to connect other devices to the Digital Baseband Interface of the R&S FSW.

Processing digital input

The digital I/Q data stream is fed into the analyzer via the connector of the digital baseband interface (R&S FSW-B17 option). There is no need to equalize any IF filter or mix the signal into the complex baseband. The digital hardware just has to ensure that the final I/Q data stored in the record buffer has the correct sample rate.

The digital input signal is brought to the desired sample rate using a downsampling filter and fractional resampling. The word length of the data is 18 bits fixed point for each I and Q. The resulting data can be processed by the selected application (see "Typical Applications for the I/Q Analyzer and I/Q Input"). As illustrated in figure "Signal path using digital input", the usable sample rate for analysis is dependant on the input sample rate.

Signal path using digital input
Full scale level

The "Full Scale Level" defines the level that corresponds to an I/Q sample with the magnitude "1" and can be defined in various units. When converting the measured power into dBm, an impedance of 50 Ω is assumed.

Triggering

The following trigger sources are supported:

  • External (see "External Trigger 1/2/3")
  • BB Power (see "Baseband Power" )
  • Time (see "Time")
  • Digital I/Q general purpose trigger (see "Digital I/Q")

If external triggering is used, the external trigger must be applied via the connector on the rear panel of the instrument (as for analog input).

Gating

Gating is not supported for digital input.


Digital Output

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data from the Digital Baseband Interface (R&S FSW-B17) > Digital Output
Digital Output

Digital output can only be enabled in the I/Q Analyzer or Analog Demodulation applications (see "Digital Baseband Output").

The digital input and output cannot be used simultaneously.

Digital output is not available if the bandwidth extension option R&S FSW-B500 is active.

The only data source that can be used for digital baseband output is RF input.

It is recommended that you use the R&S®SMU-Z6 (1415.0201.02) cable to connect other devices to the Digital Baseband Interface of the R&S FSW.

Processing digital output

Digital output is processed almost identically to RF input in I/Q mode (see "Processing Analog I/Q Data from RF Input"). I/Q data is sampled blockwise, according to the defined sample rate, and stored in the I/Q memory. From the memory, the I/Q data is processed in the I/Q Analyzer mode. Simultaneously, the data is written to the R&S Digital Baseband Interface continuously. Using this interface, the I/Q data can be processed in an external instrument as an alternative to internal processing in the R&S FSW.

Signal path using the digital output

The sample rate at the digital output corresponds to the sample rate defined by the user and which is used as the basis for analysis (see "Sample Rates and Bandwidths for Digital I/Q Data"). The current sample rate is displayed in the Digital I/Q "Output" dialog box (read-only) when the digital output is enabled (see "Output Settings Information"). A maximum sample rate of 200 MHz is allowed for digital output.

For digital output, the full scale level corresponds to the defined reference level (without the reference level offset and transducer).


Sample Rates and Bandwidths for Digital I/Q Data

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data from the Digital Baseband Interface (R&S FSW-B17) > Sample Rates and Bandwidths for Digital I/Q Data
Sample Rates and Bandwidths for Digital I/Q Data
Definitions
  • Clock rate: the rate at which data is physically transmitted between the R&S FSW and the connected instrument; both instruments must be able to process data at this rate; the clock rate of the R&S FSW at the output connector is 142.9 MHz; using the Digital I/Q enhanced mode, a data transfer rate of up to 200 Msps is possible
  • Input sample rate (ISR): the sample rate of the useful data provided by the connected instrument to the digital input
  • (User, Output) Sample rate (SR): the sample rate that is defined by the user (e.g. in the "Data Aquisition" dialog box in the "I/Q Analyzer" application) and which is used as the basis for analysis or sent to the digital output
  • Usable I/Q (Analysis) bandwidth: the bandwidth range in which the signal remains unchanged by the digital decimation filter and thus remains undistorted; this range can be used for accurate analysis by the R&S FSW
SlowI/Q measurements

When captured data is transferred and further processed with a slower rate than the rate with which the signal was sampled, this is referred to as a Slow I/Q measurement.

For example, assume an analog signal is sampled by an oscilloscope with a sample rate of 10 GHz. This data is stored in a memory temporarily and then transferred to the R&S FSW via the Digital I/Q Interface with a sample rate of 100R&S FSWMsps. Then the input sample rate on the R&S FSW must be set to 10 GHz so the signal is displayed correctly.

Digital I/Q enhanced mode

As of firmware version 1.80, an enhanced mode for processing data from the Digital Baseband Interface is available. This enhanced mode enables data transfer via the Digital I/Q interface with a data rate of up to 200 Msps (160 MHz bandwidth, compared to the previous 100 Msps/ 80 MHz bandwidth).

The Digital I/Q enhanced mode is automatically used if the following prerequisites are fulfilled:
  • Digital Input: The connected device must support data transfer rates up to 200 Msps.
  • Digital Output:
    – The R&S FSW must supply the required bandwidth, i.e. the bandwidth extension option R&S FSW-B160 or higher must be installed and active.
    – The connected device must support data transfer rates up to 200 Msps.
Restrictions for digital in- and output

The following table describes the restrictions for digital in- and output:

Restrictions for digital in- and output
Parameter | Minimum | Maximum
Record length | 2 complex samples | 220*1024*1024 complex samples
Input sample rate (ISR) | 100 Hz | 10 GHz
Sample Rate (SR) - Digital input | Max(100 Hz; ISR/8388608) | Min(10 GHz; 2*ISR)
Sample Rate (SR) - Digital output | 100 Hz | 200 MHz
Usable I/Q bandwidth (Digital input and filter active) | Min(0.8*SR; 0.8*ISR)
Unfiltered I/Q data input

The values in table "Restrictions for digital in- and output" apply for the default data processing using the decimation filter and resampler. If the filter is deactivated (see "Omitting the Digital Decimation Filter (No Filter)", the analysis sample rate is identical to the input sample rate. In this case, the usable I/Q bandwidth is not restricted by the R&S FSW.

Bandwidths

Depending on the sample rate, the following bandwidths are available:

Bandwidths depending on sample rate for active digital input


Interface Status Information

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data from the Digital Baseband Interface (R&S FSW-B17) > Interface Status Information
Interface Status Information

When a digitial input or output instrument is connected to the R&S Digital Baseband Interface, the "Input" or "Output" dialog boxes provide information on the status of the connection (see "Connected Instrument", "Connected Instrument", "Output Settings Information").

You can query the information in these dialog boxes using remote commands, see INPut:​DIQ:​CDEVice and OUTPut:​DIQ:​CDEVice.

Status icons

The status of the connection to the Digital Baseband Interface is also indicated as icons in the status bar. The status icons have the following meaning:

Status information for digital baseband connections

Icon

Status

Digital input

Connection setup in progress

Connection established

  • Connection error
  • No cable connected although Digital I/Q input source state = "ON"

-

Digital I/Q input source state = "OFF" and no cable connected

Digital output

Connection setup in progress

Connection established

  • Connection error
  • No cable connected although Digital I/Q output state = "ON"

-

Digital I/Q output source state = "OFF" and no cable connected

Error messages

If an error occurs, a message is displayed in the status bar and a status bit is set in one of the status registers (see "Querying the Status Registers"). For details on the message, select it on the status bar.


Processing Data From the Analog Baseband Interface

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data From the Analog Baseband Interface
Processing Data From the Analog Baseband Interface

Alternatively to capturing (analog) I/Q data from the standard RF INPUT connector on the front panel of the R&S FSW, analog baseband signals can also be captured via the optional Analog Baseband Interface (R&S FSW-B71), if installed.

Contents
  • (Analog) Baseband Input 50 Ω Connectors (optional)
  • Analog Baseband Input
  • I/Q Processing Modes
  • Sample Rates and Bandwidths for Analog Baseband signals
  • Average Power Consumption


(Analog) Baseband Input 50 Ω Connectors (optional)

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data From the Analog Baseband Interface > (Analog) Baseband Input 50 Ω Connectors (optional)
(Analog) Baseband Input 50 Ω Connectors (optional)

The R&S FSW Analog Baseband Interface option (R&S FSW-B71) provides four BASEBAND INPUT BNC connectors on the front panel of the instrument for analog I and Q signals.

The upper BNC connectors BASEBAND INPUT I and BASEBAND INPUT Q are used to input single-ended signals, the positive signal input for differential signals, as well as input from active Rohde & Schwarz probes (R&S RT-ZSxx and differential probes RT-ZDxx).

The lower BNC connectors Ī and Ǭ are used to input the negative signal for differential signals.

For complex signal input (I+jQ), always use two identical cables for the I and Q connectors (same length, same type, same manufacturer). Otherwise, time delay or gain imbalance may occur between the different cables, which cannot be calibrated.

All connectors have a fixed impedance of 50 Ω and may receive a maximum input level of 4 Vpp each.

Risk of instrument damage

Do not overload the BASEBAND INPUT connectors. An input voltage of 4 V must never be exceeded. Noncompliance will destroy the Analog Baseband Interface components.

The device that provides analog baseband input (or the probe) must be connected to the R&S FSW accordingly.

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Input via the Analog Baseband Interface can be enabled in the I/Q Analyzer, the Analog Demodulation application, or in one of the optional applications that process I/Q data (where available).


Analog Baseband Input

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data From the Analog Baseband Interface > Analog Baseband Input
Analog Baseband Input

The Analog Baseband Interface can be used as an alternative data input source for measurements with the R&S FSW. Either an analog baseband signal is input at the BASEBAND INPUT I and BASEBAND INPUT Q connectors and processed from there, or an RF signal is input at the BASEBAND INPUT I connector and redirected from there to the RF input path.

The BASEBAND INPUT I connector cannot be used to input RF signals on the R&S FSW67.

RF signals via the Analog Baseband Interface

For RF signals that are redirected to the RF input path, the signal from the Analog Baseband Interface is processed in the same manner as for other RF input (see "Processing Analog I/Q Data from RF Input"). However, a transducer is activated before the common process to compensate for the additional path of the redirected signal. Additionally, the modulated signals can be converted to any frequency in the analysis bandwidth.

Complex spectrum analysis

However, if the input is already available as a complex baseband signal (I and Q signals), the Analog Baseband Interface allows you to analyze the complex spectrum of the baseband signal. This is useful for measurements in the early stages of signal processing or radio transmission, when the analog baseband signal has not yet been modulated.

Low IF signals

I/Q input that has already been modulated ("Low IF signal") is down-converted digitally.

Data acquisition

The Analog Baseband Interface of the R&S FSW can process both single-ended (unbalanced) and differential (balanced) input. The signal is input to the R&S FSW via the connectors of the Analog Baseband Interface. If necessary, for instance if the connections are mixed up or the data is inverted by the device under test, the I and Q values in the input can be swapped. The A/D converter samples the input at a rate of 200 MHz. As a result, 200 megasamples of I values and 200 megasamples of Q values are obtained per second.

Voltage levels - full scale level

For RF input, the maximum expected voltage level is defined by the reference level. For analog baseband input, the maximum expected voltage level for each component (I or Q) is defined by the full scale level. The full scale level defines the maximum power you can input at the BASEBAND INPUT connector without clipping the signal.

The full scale level can be defined manually or automatically, such that the power of I and Q does not exceed the reference level.

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed voltage.

For details on probes see "Processing Data From the Analog Baseband Interface".

When converting the measured voltage into dBm, an impedance of 50 Ω is assumed.

Triggering

The following trigger sources are supported for analog baseband input (see "Trigger Source"):

  • External
  • Baseband power
  • Time
  • Power sensor
Gating

Gating is not supported for analog baseband input.

Calibration

A special calibration signal is available for analog baseband input and can be activated in the general instrument settings. If activated, an internal DC or AC calibration signal is input to the Analog Baseband Interface.

For details see "Calibration Analog Baseband" .


I/Q Processing Modes

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data From the Analog Baseband Interface > I/Q Processing Modes
I/Q Processing Modes

The Analog Baseband Interface provides different methods of processing the baseband input (I/Q modes), depending on the measurement requirements.

Complex baseband mode (I+jQ)

In the (default) complex baseband mode, the analog input signal is assumed to be a complex baseband signal. There is no need to equalize any IF filter or mix the signal into the complex baseband. The analog hardware just has to ensure that the final I/Q data stored in the capture buffer has the correct sample rate for the application.

The analog baseband input signal is brought to the desired sample rate using a downsampling filter and fractional resampling. No level compensation is necessary. The resulting data can be processed by the selected application.

Spectrum in complex baseband (I+jQ) mode

The complex spectrum of the input signal is displayed. The center frequency does not have to be moved, but it can be, as long as the selected spectrum remains within the maximum analysis bandwidth (see "Sample Rates and Bandwidths for Analog Baseband signals").

Low IF mode (I or Q)

In low IF mode, the real signal from the selected input component (I or Q) is assumed to be a modulated carrier with a specific center frequency. The signal is down-converted to a selected center frequency (= low IF frequency) using an NCO. The center frequency must be higher than 0 Hz so that no part of the negative mirrored spectrum lies within the analysis bandwidth. (The center frequency must be different to 0 Hz, as in this case real baseband mode is assumed, see "Real baseband mode (I or Q only)".) The selected center frequency should also be selected such that the displayed spectrum remains within the maximum analysis bandwidth (see "Sample Rates and Bandwidths for Analog Baseband signals").

Spectrum in low IF mode

Compared to the initial complex baseband signal that was input, the down-converted I or Q component contains only half the spectrum (i.e. one sideband less) after passing the filter. The power is thus reduced by one half (or: -3 dB). This power loss is compensated for by increasing the power of the resulting spectrum by +3 dB.

The digitized data is brought to the desired sample rate using a downsampling filter and fractional resampling.

This processing mode corresponds to the common RF spectrum analysis, applied to the analog baseband input.

Real baseband mode (I or Q only)

As mentioned above, a center frequency of 0 Hz is not allowed for low IF mode. In this case, the input signal is assumed to be a real baseband signal, so no down-conversion is performed. Thus, this mode resembles an oscilloscope. The spectrum result display always starts at 0 and has a maximum span of half the sample rate (half of the captured samples are from the other component, which is not displayed in this mode). The Real/Imag result display shows only one diagram (namely the one for the selected component).

Spectrum in real baseband mode

This mode is useful for pulse measurements, for example.


Sample Rates and Bandwidths for Analog Baseband signals

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data From the Analog Baseband Interface > Sample Rates and Bandwidths for Analog Baseband signals
Sample Rates and Bandwidths for Analog Baseband signals

The analog baseband input is sampled internally by the R&S FSW at a rate of 200 MHz. As a result, 200 megasamples of I values and 200 megasamples of Q values can be obtained per second. The actual sample rate required by the application, however, may be lower, in which case the data is downsampled. Depending on the application used to process the data, the required sample rate is defined by the application itself or by the user. The sample rate also determines the analysis bandwidth, that is, the bandwidth range in which the signal remains undistorted in regard to amplitude characteristic and group delay and can be used for accurate analysis by the R&S FSW. The sample rate and the analysis bandwidth are interdependant and are adapted according to the following formula in the I/Q Analyzer (see also "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input"):

Analysis bandwidth = 0.8 * sample rate

(For I or Q only: Analysis bandwidth = 0.4 * sample rate)

Bandwidth extension options

The standard R&S FSW equipped with the Analog Baseband Interface (R&S FSW-B71) can analyze a maximum bandwidth of 40 MHz input per connector, i.e. an 80 MHz analysis bandwidth for a complex baseband signal.

The bandwidth extension options B28/B40/B80/B160 for RF input have no effect on analog baseband input.

However, a special bandwidth extension option for the Analog Baseband Interface (R&S FSW-B71E) is available, which allows the R&S FSW to analyze a maximum bandwidth of 80 MHz input per connector, i.e. a 160 MHz analysis bandwidth.

Spectrum limits

The analog baseband spectrum to be analyzed depends both on the analysis bandwidth and on the center frequency, which defines the middle of the spectrum. The spectrum should always remain within the span -40 MHz to +40 MHz (without the B71E option) or -80 MHz to +80 MHz (with the B71E option) to avoid effects from unwanted signal components (e.g. mirrored sidebands). Thus, always select the maximum analysis bandwidth and the position of the center frequency such that the spectrum remains within the specified limits. You are not forced by the R&S FSW to do so, but a warning message will be displayed if the limits are exceeded.

Spectrum limits depending on I/Q mode
I/Q Mode | Complex baseband (I+jQ) | Low-IF (I / Q) | Real Baseband (I / Q)
Analysis bandwidth BW | BWmax = +80 MHz (default) BWmax = +160 MHz (with B71E option) -BWmax/2 + BW/2 ≤ fc ≤ BWmax/2 - BW/2 *) | BWmax = +40 MHz (default) BWmax = +80 MHz (with B71E option) -BWmax/2 + BW/2 ≤ fc ≤ BWmax/2 - BW/2 *) | BWmax = +40 MHz (default) BWmax = +80 MHz (with B71E option)
Center frequency fc | -BWmax/2 < fc < BWmax/2 i.e.: -40 MHz to +40 MHz (default) -80 MHz to +80 MHz (with B71E option) | 0 < fc < BWmax i.e.: +10 Hz to +40 MHz (default) +10 Hz to +80 MHz (with B71E option) | fc = 0 Hz
Span | = Sample rate | = Sample rate | = Sample rate / 2
*) not forced by R&S FSW


Average Power Consumption

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Processing Data From the Analog Baseband Interface > Average Power Consumption
Average Power Consumption

The Analog Baseband interface can be used to capture two different signals: one proportional to the voltage and one proportional to the current of a DUT. The average power consumption can then be calculated from the captured I/Q signal. To avoid processing large amounts of I/Q data, the R&S FSW provides an internal calculation of the average power consumption for remote operation according to the following equation:

P(n) = A * V(n) * I(n) - B * V(n) * V(n)

with:

  • V(n): I data of the instrument
  • I(n): Q data of the instrument
  • A: conversion factor A
  • B: conversion factor B
Remote commands:

TRACe:​IQ:​APCon[:​STATe]

TRACe:​IQ:​APCon:​A

TRACe:​IQ:​APCon:​B

TRACe:​IQ:​APCon:​RESult?


Receiving Data Input and Providing Data Output

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output
Receiving Data Input and Providing Data Output

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Contents
  • RF Input Protection
  • RF Input from the Analog Baseband Connector
  • Using Probes
  • Basics on External Generator Control
  • Basics on Input from I/Q Data Files
  • Input from Noise Sources
  • Receiving and Providing Trigger Signals
  • IF and Video Signal Output


RF Input Protection

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > RF Input Protection
RF Input Protection

The RF input connector of the R&S FSW must be protected against signal levels that exceed the ranges specified in the data sheet. Therefore, the R&S FSW is equipped with an overload protection mechanism. This mechanism becomes active as soon as the power at the input mixer exceeds the specified limit. It ensures that the connection between RF input and input mixer is cut off.

When the overload protection is activated, an error message is displayed in the status bar ("INPUT OVLD"), and a message box informs you that the RF Input was disconnected. Furthermore, a status bit (bit 3) in the STAT:QUES:POW status register is set. In this case you must decrease the level at the RF input connector and then close the message box. Then measurement is possible again. Reactivating the RF input is also possible via the remote command INPut:​ATTenuation:​PROTection:​RESet.


RF Input from the Analog Baseband Connector

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > RF Input from the Analog Baseband Connector
RF Input from the Analog Baseband Connector

RF input can not only be taken from the RF INPUT connector on the front panel of the R&S FSW. If the optional Analog Baseband Interface (R&S FSW-B71) is installed and active for input, an RF signal can be input at the BASEBAND INPUT I connector and redirected from there to the RF input path. A transducer is activated to compensate for the additional path of the redirected signal. The signal is then processed as usual in the frequency and time domain as for any other RF input.

This is useful, for example, to perform frequency sweep measurements with (single-ended or differential) active probes, which can also be connected to the BASEBAND INPUT I connector.

Frequency sweep measurements on probe input

You can perform RF measurements (measurements in the time or frequency domain) by connecting a probe to the BASEBAND INPUT I connector and switching the input source to this connector in the RF input configuration (see "Input Connector").

The probe's attenuation is compensated automatically by the R&S FSW using a transducer named "Probe on Baseband Input I". (The probe can only be connected on I, as only input at the I connector can be redirected to the RF path). A comment is assigned that includes the type, name and serial number of the detected probe. The transducer is deleted as soon as the probe is disconnected.

For details on transducers see "Basics on Transducer Factors" .

For more information on using probes for input see "Using Probes".


Using Probes

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Using Probes
Using Probes

As an alternative means of input to the R&S FSW, active probes from Rohde&Schwarz can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband Interface (option R&S FSW-B71) is installed. These probes allow you to perform voltage measurements very flexibly and precisely on all sorts of devices to be tested, without interfering with the signal.

Connecting probes

Probes are automatically detected when you plug them into the upper BASEBAND INPUT connectors on the front panel of the R&S FSW. The detected information on the probe is displayed in the "Probes" tab of the "Input" dialog box, individually for each connector.

Single-ended and differential probes

Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Input Configuration" setting for the "Analog Baseband" input source must be set to "Single-ended" for all probes (see "Input configuration").

Availability of probe input

Analog baseband input from connected probes can only be analyzed in applications that support I/Q data processing and the Analog Baseband Interface (R&S FSW-B71), such as the I/Q Analyzer, the Analog Demodulation application, or one of the optional applications.

Frequency sweep measurements with probes

Probes can also be used as an alternative method of providing RF input to the R&S FSW. In this case, the probe must be connected to the BASEBAND INPUT I connector, and the input is redirected to the RF input path (see "RF Input from the Analog Baseband Connector"). As opposed to common RF input processing, a transducer is activated before the common process to compensate for the additional path of the redirected signal. Probe signals that are redirected to the RF input path can also be analyzed in the Spectrum application of the R&S FSW base unit. Then you can perform RF measurements (measurements in the time or frequency domain) on the input from a probe.

Microbutton action

You can define an action to be performed by the R&S FSW when the probe's microbutton (if available) is pressed. Currently, a single data acquisition via the probe can be performed simply by pressing the microbutton.

Impedance and attenuation

The measured signal from the probe is attenuated internally by the probe's specific attenuation. For probe signals that are redirected to the RF path, the attenuation is compensated using a transducer (see "Frequency sweep measurements on probe input"). The reference level is adjusted automatically.

For analog baseband input, the attenuation is compensated without a transducer. In this case, higher levels are available for the full scale level.

A fixed impedance of 50 Ω is used for all probes to convert voltage values to power levels.

Contents
  • Common Mode Offset


Common Mode Offset

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Using Probes > Common Mode Offset
Common Mode Offset

Common mode offset compensation is available for R&S®RT-ZD10/20/30 probes with serial number ≥ 200 000. It can compensate a common DC voltage applied to both input sockets (referenced to the ground socket). This is particularly helpful for measurements on differential signals with high common mode levels, for example, current measurements using a shunt resistor.

Common mode (CM) offset compensation for a differential measurement

If the input signals fit into the operating voltage window of the R&S®RT-ZD10/20/30, it is not necessary to set a common mode offset compensation.

Clipping effects due to incorrect common mode offset

The R&S®RT-ZD10/20/30 probe measures only differential input signals. Common mode signals are suppressed by the probe. Therefore, the common mode offset compensation is not directly visible in the result display. An incorrect common mode offset compensation can lead to unwanted clipping effects. Measuring the common mode input voltage using the R&S ProbeMeter is a convenient way to detect breaches of the operating voltage window.

For more information on common mode offset see the R&S®RT-ZD10/20/30 User Manual.

A common mode offset is only configurable in remote control, see [SENSe:​]PROBe<ch>:​SETup:​CMOFfset.


Basics on External Generator Control

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control
Basics on External Generator Control

Some background knowledge on basic terms and principles used for external generator control is provided here for a better understanding of the required configuration settings.

External generator control is only available in the Spectrum, I/Q Analyzer, Analog Demodulation and Noise Figure applications.

Contents
  • External Generator Connections
  • Overview of Generators Supported by the R&S FSW-B10 Option
  • Generator Setup Files
  • Calibration Mechanism
  • Normalization
  • Reference Trace, Reference Line and Reference Level
  • Coupling the Frequencies
  • Displayed Information and Errors


External Generator Connections

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > External Generator Connections
External Generator Connections

The external generator is controlled either via a LAN connection or via the EXT. GEN. CONTROL GPIB interface of the R&S FSW supplied with the R&S FSW-B10 option.

For more information on configuring interfaces see "Remote Control Interfaces and Protocols" .

TTL synchronization

In addition, TTL synchronization can be used with some Rohde & Schwarz generators connected via GPIB. The TTL interface is included in the AUX CONTROL connector of the R&S FSW-B10 option.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator. For details see "Coupling the Frequencies".

In figure " TTL connection for an SMU generator" the TTL connection is illustrated using an SMU generator, for example.

TTL connection for an SMU generator

The external generator can be used to calibrate the data source by performing either transmission or reflection measurements.

Transmission Measurement

This measurement yields the transmission characteristics of a two-port network. The external generator is used as a signal source. It is connected to the input connector of the DUT. The input of the R&S FSW is fed from the output of the DUT. A calibration can be carried out to compensate for the effects of the test setup (e.g. frequency response of connecting cables).

Test setup for transmission measurement
Reflection Measurement

Scalar reflection measurements can be carried out using a reflection-coefficient measurement bridge.

Test setup for reflection measurement
Generated signal input

In order to use the functions of the external generator, an appropriate generator must be connected and configured correctly. In particular, the generator output must be connected to the RF input of the R&S FSW.

External reference frequency

In order to enhance measurement accuracy, a common reference frequency should be used for both the R&S FSW and the generator. If no independent 10 MHz reference frequency is available, it is recommended that you connect the reference output of the generator with the reference input of the R&S FSW and that you enable usage of the external reference on the R&S FSW via "SETUP" > "Reference" > "External Reference".

For more information on external references see "Reference Frequency Input" .

Connection errors

If no external generator is connected, if the connection address is not correct, or the generator is not ready for operation, an error message is displayed (e.g."Ext. Generator TCPIP Handshake Error!", see "Displayed Information and Errors").


Overview of Generators Supported by the R&S FSW-B10 Option

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Overview of Generators Supported by the R&S FSW-B10 Option
Overview of Generators Supported by the R&S FSW-B10 Option
Generator type | TTL support | Generator type | TTL support
SGS100A12 | X | SMP02 | X
SMA01A 1) | X | SMP03 | X
SMA100A3 | X | SMP04 | X
SMA100A6 | X | SMP22 | X
SMB100A1 | X | SMR20 | -
SMB100A12 | X | SMR20B11 3) | X
SMB100A2 | X | SMR27 | X
SMB100A20 | X | SMR27B11 3) | X
SMB100A3 | X | SMR30 | X
SMB100A40 | X | SMR30B11 3) | X
SMBV100A3 | X | SMR40 | X
SMBV100A6 | X | SMR40B11 3) | X
SMC100A1 | - | SMR50 | X
SMC100A3 | - | SMR50B11 3) | X
SME02 | X | SMR60 | X
SME03 | X | SMR60B11 3) | X
SME06 | X | SMT02 | -
SMF100A | X | SMT03 | -
SMF22 | X | SMT06 | -
SMF22B2 | X | SMU02 | X
SMF43 | X | SMU02B31 2) | X
SMF43B2 | X | SMU03 2) | X
SMG | - | SMU03B31 2) | X
SMGL | - | SMU04 2) | X
SMGU | - | SMU04B31 2) | X
SMH | - | SMU06 2) | X
SMHU | - | SMU06B31 2) | X
SMIQ02 | X | SMV03 | -
SMIQ02B | X | SMW03 | -
SMIQ02E | - | SMW06 | -
SMIQ03 | X | SMX | -
SMIQ03B | X | SMY01 | -
SMIQ03E | - | SMY02 | -
SMIQ04B | X | HP8254A | -
SMIQ06B | X | HP8257D | -
SMJ03 | X | HP8340A | -
SMJ06 | X | HP8648 | -
SML01 | - | HP ESG-A Series 1000A, 2000A, 3000A, 4000A | -
SML02 | - | HP ESG B Sereies | -
SML03 | - | HP ESG-D SERIES E4432B | -
1) Requires firmware version V2.10.x or higher 2) Requires firmware version V1.10.x or higher 3) Requires the option SMR-B11


Generator Setup Files

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Generator Setup Files
Generator Setup Files

For each signal generator type to be controlled by the R&S FSW a generator setup file must be configured and stored on the R&S FSW. The setup file defines the frequency and power ranges supported by the generator, as well as information required for communication. For the signal generators listed in "Overview of Generators Supported by the R&S FSW-B10 Option", default setup files are provided. If necessary, these files can be edited or duplicated for varying measurement setups or other instruments.

The existing setup files can be displayed in an editor in read-only mode directly from the "External Generator" configuration dialog box. From there, they can be edited and stored under a different name, and are then available on the R&S FSW.

(For details see "To define a new generator setup file" ).


Calibration Mechanism

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Calibration Mechanism
Calibration Mechanism

A common measurement setup includes a signal generator, a device under test (DUT), and a signal and spectrum analyzer. Therefore, it is useful to measure the attenuation or gain caused by the cables and connectors from the signal generator and the signal analyzer in advance. The known level offsets can then be removed from the measurement results in order to obtain accurate information on the DUT.

Calculating the difference between the currently measured power and a reference trace is referred to as calibration. Thus, the measurement results from the controlled external generator - including the inherent distortions - can be used as a reference trace to calibrate the measurement setup.

The inherent frequency and power level distortions can be determined by connecting the R&S FSW to the signal generator. The R&S FSW sends a predefined list of frequencies to the signal generator (see also "Coupling the Frequencies"). The signal generator then sends a signal with the specified level at each frequency in the predefined list. The R&S FSW measures the signal and determines the level offsets to the expected values.

Saving calibration results

A reference dataset for the calibration results is stored internally as a table of value pairs (frequency/level), one for each sweep point. The measured offsets can then be used as calibration factors for subsequent measurement results.

The calibration can be performed using either transmission or reflection measurements. The selected type of measurement used to determine the reference trace is included in the reference dataset.


Normalization

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Normalization
Normalization

Once the measurement setup has been calibrated and the reference trace is available, subsequent measurement results can be corrected according to the calibration factors, if necessary. This is done by subtracting the reference trace from the measurement results. This process is referred to as normalization and can be activated or deactivated as required. If normalization is activated, "NOR" is displayed in the channel bar, next to the indication that an external generator is being used ("Ext.Gen").The normalized trace from the calibration sweep is a constant 0 dB line, as <calibration trace> - <reference trace> = 0.

As long as the same settings are used for measurement as for calibration, the normalized measurement results should not contain any inherent frequency or power distortions. Thus, the measured DUT values are very accurate.

Approximate normalization

As soon as any of the calibration measurement settings are changed, the stored reference trace will no longer be identical to the new measurement results. However, if the measurement settings do not deviate too much, the measurement results can still be normalized approximately using the stored reference trace. This is indicated by the "APX" label in the channel bar (instead of "NOR").

This is the case if one or more of the following values deviate from the calibration settings:
  • coupling (RBW, VBW, SWT)
  • reference level, RF attenuation
  • start or stop frequency
  • output level of external generator
  • detector (max. peak, min. peak, sample, etc.)
  • frequency deviation at a maximum of 1001 points within the set sweep limits (corresponds to a doubling of the span)

Differences in level settings between the reference trace and the current instrument settings are taken into account automatically. If the span is reduced, a linear interpolation of the intermediate values is applied. If the span increases, the values at the left or right border of the reference dataset are extrapolated to the current start or stop frequency, i.e. the reference dataset is extended by constant values.

Thus, the instrument settings can be changed in a wide area without giving up normalization. This reduces the necessity to carry out a new normalization to a minimum.

If approximation becomes too poor, however, normalization is aborted and an error message is displayed (see "Displayed Information and Errors").

The normalized trace in the display

The normalized reference trace is also displayed in the spectrum diagram, by default at the top of the diagram (= 100% of the window height). It is indicated by a red line labeled "NOR", followed by the current reference value. However, it can be shifted vertically to reflect an attenuation or gain caused by the measured DUT (see also "Shifting the reference line (and normalized trace)").

Restoring the calibration settings

If the measurement settings no longer match the instrument settings with which the calibration was performed (indicated by the "APX" or no label next to "Ext.TG" in the channel bar), you can restore the calibration settings, which are stored with the reference dataset on the R&S FSW.

Storing the normalized reference trace as a transducer factor

The (inverse) normalized reference trace can also be stored as a transducer factor for use in other R&S FSW applications that do not support external generator control. The normalized trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under c:\r_s\instr\trd. The frequency points are allocated in equidistant steps between the start and stop frequency.

This is useful, for example, to determine the effects of a particular device component and then remove these effects from a subsequent measurement which includes this component.

For an example see "Coupling the Frequencies".

Note that the normalized measurement data is stored, not the original reference trace! Thus, if you store the normalized trace directly after calibration, without changing any settings, the transducer factor will be 0 dB for the entire span (by definition of the normalized trace).


Reference Trace, Reference Line and Reference Level

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Reference Trace, Reference Line and Reference Level
Reference Trace, Reference Line and Reference Level
Reference trace

The calibration results are stored internally on the R&S FSW as a reference trace. For each measured sweep point the offset to the expected values is determined. If normalization is activated, the offsets in the reference trace are removed from the current measurement results to compensate for the inherent distortions.

Reference line

The reference line is defined by the "Reference Value" and "Reference Position" in the "External Generator" > "Source Calibration" settings. It is similar to the "Reference Level" defined in the "Amplitude" settings. However, as opposed to the reference level, this reference line only affects the y-axis scaling in the diagram, it has no effect on the expected input power level or the hardware settings.

The reference line determines the range and the scaling of the y-axis, just as the reference level does.

The normalized reference trace (0 dB directly after calibration) is displayed on this reference line, indicated by a red line in the diagram. By default, the reference line is displayed at the top of the diagram. If you shift the reference line, the normalized trace is shifted, as well.

Shifting the reference line (and normalized trace)

You can shift the reference line - and thus the normalized trace - in the result display by changing the "Reference Position" or the "Reference Value".

If the DUT inserts a gain or an attenuation in the measurement, this effect can be reflected in the result display on the R&S FSW. To reflect a power offset in the measurement trace, change the "Reference Value".


Coupling the Frequencies

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Coupling the Frequencies
Coupling the Frequencies

As described in "Normalization", normalized measurement results are very accurate as long as the same settings are used as for calibration. Although approximate normalization is possible, it is important to consider the required frequencies for calibration in advance. The frequencies and levels supported by the connected signal generator are provided for reference with the interface configuration.

Two different methods are available to define the frequencies for calibration, that is to couple the frequencies of the R&S FSW with those of the signal generator:

  • Manual coupling: a single frequency is defined
  • Automatic coupling: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW; the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)
Automatic coupling

If automatic coupling is used, the output frequency of the generator (source frequency) is calculated as follows:

Output frequency of the generator

where:

FGenerator = output frequency of the generator

FAnalyzer = current frequency at the RF input of the R&S FSW

Numerator = multiplication factor for the current analyzer frequency

Denominator = division factor for the current analyzer frequency

FOffset = frequency offset for the current analyzer frequency, for example for frequency-converting measurements or harmonics measurements

The value range for the offset depends on the selected generator. The default setting is 0 Hz. Offsets other than 0 Hz are indicated by the "FRQ" label in the channel bar (see also "Displayed Information and Errors").

Swept frequency range

The FAnalyzer values for the calibration sweep start with the start frequency and end with the stop frequency defined in the "Frequency" settings of the R&S FSW. The resulting output frequencies ("Result Frequency Start" and "Result Frequency Stop") are displayed in the "External Generator" > "Measurement Configuration" for reference.

If the resulting frequency range exeeds the allowed ranges of the signal generator, an error message is displayed (see "Displayed Information and Errors") and the "Result Frequency Start" and "Result Frequency Stop" values are corrected to comply with the range limits.

The calibration sweep nevertheless covers the entire span defined by the R&S FSW; however, no input is received from the generator outside the generator's defined limits.

TTL synchronization

Some Rohde & Schwarz signal generators support TTL synchronization when connected via GPIB. The TTL interface is included in the AUX CONTROL connector of the R&S FSW-B10 option.

When pure GPIB connections are used between the R&S FSW and the signal generator, the R&S FSW sets the generator frequency for each frequency point individually via GPIB, and only when the setting procedure is finished, the R&S FSW can measure the next sweep point.

For generators with a TTL interface, the R&S FSW sends a list of the frequencies to be set to the generator before the beginning of the first sweep. Then the R&S FSW starts the sweep and the next frequency point is selected by both the R&S FSW and the generator using the TTL handshake line "TRIGGER". The R&S FSW can only measure a value when the generator signals the end of the setting procedure via the "BLANK" signal.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator.

Reverse sweep

The frequency offset for automatic coupling can be used to sweep in the reverse direction. To do so, define a negative offset in the external generator measurement configuration. (Note that the frequency is defined as the unsigned value of the equation, thus a negative frequency is not possible.)

Example: Example for reverse sweep

FAnalyzerStart= 100 MHz

FAnalyzerStop = 200 MHz

FOffset = -300 MHz

Numerator = Denominator = 1

→FGeneratorStart = 200 MHz

→FGeneratorStop = 100 MHz

If the offset is adjusted so that the sweep of the generator crosses the minimum generator frequency, a message is displayed in the status bar ("Reverse Sweep via min. Ext. Generator Frequency!").

Example: Example for reverse sweep via minimum frequency

FAnalyzerStart= 100 MHz

FAnalyzerStop = 200 MHz

FOffset = -150 MHz

Fmin = 20 MHz

Numerator = Denominator = 1

→FGeneratorStart = 50 MHz

→FGeneratorStop = 50 MHz via Fmin


Displayed Information and Errors

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Displayed Information and Errors
Displayed Information and Errors
Channel bar

If external generator control is active, some additional information is displayed in the channel bar.

Label | Description
EXT TG: <source power> | External generator active; signal sent with <source power> level
LVL | Power Offset (see "Source Offset"
FRQ | Frequency Offset (see "(Automatic) Source Frequency (Numerator/Denominator/Offset)"
NOR | Normalization on; No difference between reference setting and measurement
APX (approximation) | Normalization on; Deviation from the reference setting occurs
- | Aborted normalization or no calibration performed yet
Error and status messages

The following status and error messages may occur during external generator control.

Message | Description
"Ext. Generator GPIB Handshake Error!" / "Ext. Generator TCPIP Handshake Error!" / "Ext. Generator TTL Handshake Error!" | Connection to the generator is not possible, e.g. due to a cable damage or loose connection or wrong address.
"Ext. Generator Limits Exceeded!" | The allowed frequency or power ranges for the generator were exceeded.
"Reverse Sweep via min. Ext. Generator Frequency!" | Reverse sweep is performed; frequencies are reduced to the minimum frequency, then increased again; see " Reverse sweep"
"Ext. Generator File Syntax Error!" | Syntax error in the generator setup file (see "Generator Setup Files"
"Ext. Generator Command Error!" | Missing or wrong command in the generator setup file (see "Generator Setup Files"
"Ext. Generator Visa Error!!" | Error with Visa driver provided with installation (very unlikely)
Overloading

At a reference level of -10 dBm and at a external generator output level of the same value, the R&S FSW operates without overrange reserve. That means the R&S FSW is in danger of being overloaded if a signal is applied whose amplitude is higher than the reference line. In this case, either the message "RF OVLD" for overload or "IF OVLD" for exceeded display range (clipping of the trace at the upper diagram border = overrange) is displayed in the status line.

Overloading can be avoided as follows:
  • Reducing the output level of the external generator ("Source Power" in "External Generator > Measurement Configuration")
  • Increasing the reference level ("Reference Level" in the "Amplitude" menu)


Basics on Input from I/Q Data Files

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Basics on Input from I/Q Data Files
Basics on Input from I/Q Data Files

The I/Q data to be evaluated in a particular R&S FSW application can not only be captured by the application itself, it can also be loaded from a file, provided it has the correct format. The file is then used as the input source for the application.

Currently, this input source is only available in the R&S FSW Pulse application.

For example, you can capture I/Q data using the I/Q Analyzer application, store it to a file, and then analyze the pulse parameters for that data later using the R&S FSW Pulse application.

The I/Q data must be stored in a format with the file extension .iq.tar. For a detailed description see "I/Q Data File Format (iq-tar)".

As opposed to importing data from an I/Q data file using the import functions provided by some R&S FSW applications (e.g. the I/Q Analyzer or the R&S FSW VSA application), the data is not only stored temporarily in the capture buffer, where it overwrites the current measurement data and is in turn overwritten by a new measurement. Instead, the stored I/Q data remains available as input for any number of subsequent measurements. Furthermore, the (temporary) data import requires the current measurement settings in the current application to match the settings that were applied when the measurement results were stored (possibly in a different application). When the data is used as an input source, however, the data acquisition settings in the current application (attenuation, center frequency, measurement bandwidth, sample rate) can be ignored. As a result, these settings cannot be changed in the current application. Only the measurement time can be decreased, in order to perform measurements on an extract of the available data (from the beginning of the file) only.

When using input from an I/Q data file, the RUN SINGLE function starts a single Pulse measurement (i.e. analysis) of the stored I/Q data, while the RUN CONT function repeatedly analyzes the same data from the file.

Sample iq.tar files

If you have the optional R&S FSW VSA application (R&S FSW-K70), some sample iq.tar files are provided in the C:/R_S/Instr/user/vsa/DemoSignals directory on the R&S FSW.

Furthermore, you can create your own iq.tar files in the I/Q Analyzer, see "How to Export and Import I/Q Data".


Input from Noise Sources

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Input from Noise Sources
Input from Noise Sources

The R&S FSW provides a connector (NOISE SOURCE CONTROL) with a voltage supply for an external noise source. By switching the supply voltage for an external noise source on or off in the firmware, you can activate or deactive the device as required.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of an amplifier.

In this case, you can first connect an external noise source (whose noise power level is known in advance) to the R&S FSW and measure the total noise power. From this value you can determine the noise power of the R&S FSW. Then when you measure the power level of the actual DUT, you can deduct the known noise level from the total power to obtain the power level of the DUT.

The noise source is controlled in the "Output" settings, see "Noise Source"


Receiving and Providing Trigger Signals

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > Receiving and Providing Trigger Signals
Receiving and Providing Trigger Signals

Using one of the variable TRIGGER INPUT/OUTPUT connectors of the R&S FSW, the R&S FSW can use a signal from an external reference as a trigger to capture data. Alternatively, the internal trigger signal used by the R&S FSW can be output for use by other connected devices. Using the same trigger on several devices is useful to synchronize the transmitted and received signals within a measurement.

For details on the connectors see the R&S FSW "Getting Started" manual.

External trigger as input

If the trigger signal for the R&S FSW is provided by an external reference, the reference signal source must be connected to the R&S FSW and the trigger source must be defined as "External" on the R&S FSW.

Trigger output

The R&S FSW can provide output to another device either to pass on the internal trigger signal, or to indicate that the R&S FSW itself is ready to trigger.

The trigger signal can be output by the R&S FSW automatically, or manually by the user. If it is provided automatically, a high signal is output when the R&S FSW has triggered due to a sweep start ("Device Triggered"), or when the R&S FSW is ready to receive a trigger signal after a sweep start ("Trigger Armed").

Manual triggering

If the trigger output signal is initiated manually, the length and level (high/low) of the trigger pulse is also user-definable. Note, however, that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is provided.

Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .


IF and Video Signal Output

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Receiving Data Input and Providing Data Output > IF and Video Signal Output
IF and Video Signal Output

The measured IF signal or displayed video signal (i.e. the filtered and detected IF signal) can be provided at the IF/VIDEO/DEMOD or IF OUT output connector.

The video output is a signal of 1 V. It can be used, for example, to control demodulated audio frequencies.

The IF output is a signal of the measured level at a specified frequency.

The IF 2 GHz output is a signal with a bandwidth of 2 GHz at the frequency 2 GHz.

Restrictions

Note the following restrictions for IF output:

  • IF and video output is only available in the time domain (zero span).
  • For I/Q data, only IF output is available.
  • IF output is not available if any of the following conditions apply:
    – The Digital Baseband Interface (R&S FSW-B17) is active (for input or output)
    – MSRA operating mode is active
    – MSRT operating mode is active
    – A wideband extension is used (hardware options R&S FSW-B160/-B320/-B500; used automatically for bandwidths > 80 MHz; in this case use the IF WIDE OUTPUT connector)
    – The sample rate is larger than 200 MHz (upsampling)
IF WIDE OUTPUT

If optional hardware R&S FSW-B160/-B320/-B500 for bandwidth extension is installed and activated (i.e. for bandwidths > 80 MHz), the IF output is not available at the IF/VIDEO/DEMOD output connector, but rather at the additional IF WIDE OUTPUT connector provided by the option.

In this case, the IF output frequency cannot be defined manually, but is determined automatically depending on the center frequency. For details on the used frequencies see the data sheet. The currently used output frequency is indicated in the field otherwise used to define the frequency manually (in the "Output" settings dialog box, see "IF (Wide) Out Frequency").

IF 2 GHz Output

For instrument models R&S FSW43/50/67, the IF output can also be provided at the alternative IF OUT output connector at a frequency of 2 GHz and with a bandwidth of 2 GHz. The IF output can then be analyzed by a different instrument, for example an R&S®RTO oscilloscope. If IF 2 GHZ OUT output is activated, the measured values are no longer available on the display; thus, the trace data currently displayed on the R&S FSW becomes invalid. A message in the status bar indicates this situation. The message also indicates whether the sidebands of the IF spectrum output are in normal or inverted order compared to the RF signal, which depends on the used center frequency.

Prerequisites
Note the following prerequisites for output to the IF OUT connector:
  • Instrument model R&S FSW43/50/67; external mixers can be used
  • Zero span mode, I/Q Analyzer, or VSA (R&S FSW-K70) application
  • Center frequency ≥ 8 GHz


I/Q Data Import and Export

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

For example, you can capture I/Q data using the I/Q Analyzer application and then perform vector signal analysis on that data using the R&S FSW VSA application, if available.

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)".

Export only in MSRA mode

In MSRA mode, I/Q data can only be exported to other applications; I/Q data cannot be imported to the MSRA Master or any MSRA applications.

For details on import and export functions see "Import/Export Functions".


Basics on FFT

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Basics on FFT
Basics on FFT

The I/Q Analyzer measures the power of the signal input over time. In order to convert the time domain signal to a frequency spectrum, an FFT (Fast Fourier Transformation) is performed which converts a vector of input values into a discrete spectrum of frequencies.

Contents
  • Window Functions
  • Overlapping
  • Dependencies Between FFT Parameters
  • Frequency Resolution of FFT Results - RBW
  • FFT Calculation Methods


Window Functions

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Basics on FFT > Window Functions
Window Functions

The Fourier transformation is not performed on the entire captured data in one step. Only a limited number of samples is used to calculate an individual result. This process is called windowing.

After sampling in the time domain, each window is multiplied with a specific window function. Windowing helps minimize the discontinuities at the end of the measured signal interval and thus reduces the effect of spectral leakage, increasing the frequency resolution.

Various different window functions are provided in the R&S FSW to suit different input signals. Each of the window functions has specific characteristics, including some advantages and some trade-offs. These characteristics need to be considered carefully to find the optimum solution for the measurement task.

Ignoring the window function - rectangular window

The regtangular window function is in effect not a function at all, it maintains the original sampled data. This may be useful to minimize the required bandwidth; however, be aware that if the window does not contain exactly one period of your signal, heavy sidelobes may occur, which do not exist in the original signal.

Characteristics of typical FFT window functions
Window type | Frequency resolution | Magnitude resolution | Sidelobe suppression | Measurement recommendation
Rectangular | Best | Worst | Worst | No function applied. Separation of two tones with almost equal amplitudes and a small frequency distance
Blackman-Harris (default) | Good | Good | Good | Harmonic detection and spurious emission detection
Gauss (Alpha = 0.4) | Good | Good | Good | Weak signals and short duration
Flattop | Worst | Best | Good | Accurate single tone measurements
5-Term | Good | Good | Best | Measurements with very high dynamic range


Overlapping

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Basics on FFT > Overlapping
Overlapping

The I/Q Analyzer calculates multiple FFTs per measurement by dividing one captured record into several windows. Furthermore, the I/Q Analyzer allows consecutive windows to overlap. Overlapping "reuses" samples that were already used to calculate the preceding FFT result.

In advanced FFT mode with averaging, the overlapping factor can be set freely. The higher the overlap factor, the more windows are used. This leads to more individual results and improves detection of transient signal effects. However, it also extends the duration of the calculation. The size of the window can be defined manually according to the record length, the overlap factor, and and the FFT length.

With an overlap of the FFTs of 67%, for example, the second data block the R&S FSW performs the FFT on covers the last 67% of the data of the first FFT with only 33% new data. The third data block still covers 33% of the first data block and 67% of the second data block and so on.

Overlapping FFTs

In "Manual" or "Auto" FFT mode, an FFT length of 4096 and a window length of 4096 (or the record length, if shorter) is used to calculate the spectrum.

Combining results - trace detector

If the record length permits, multiple overlapping windows are calculated and combined to create the final spectrum using the selected trace detector. (Note: in previous versions of the R&S FSW, the I/Q Analyzer always used the linear average detector.) If necessary, the trace detector is also used to reduce the number of calculated frequency points (defined by the FFT length) to the defined number of sweep points. By default, the Autopeak trace detector is used.

Due to the fact that the frequency points are reduced to the number of sweep points, using a detector other than Auto Peak and fewer than 4096 sweep points may lead to wrong level results.


Dependencies Between FFT Parameters

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Basics on FFT > Dependencies Between FFT Parameters
Dependencies Between FFT Parameters

FFT analysis in the R&S FSW is highly configurable. Several parameters, including the resolution bandwidth, record length, and FFT length, can be defined according to the user's requirements. Note, however, that several parameters are correlated and not all can be configured independently of the others.

Record Length

Defines the number of I/Q samples to capture. By default, the number of sweep points is used. The record length is calculated as the measurement time multiplied by the sample rate.

If you change the record length, the "Meas Time" is automatically changed, as well.

For FFTs performed using only a single window ("Single" mode), the record length (which is then identical to the FFT length) may not exceed 512k.

FFT Length

Defines the number of frequency points determined by each FFT calculation. The more points are used, the higher the resolution in the spectrum becomes, but the longer the calculation takes.

In "Auto" or "Manual" mode, an FFT length of 4096 is used.

In advanced FFT mode, the FFT length can be defined by the user. If you use the arrow keys or the rotary knob to change the FFT length, the value is incremented or decremented by powers of 2. If you enter the value manually, any integer value from 3 to 524288 is available.

If the FFT length is longer than the "Window Length" the sample data is filled up with zeros up to the FFT length. The FFT is then performed using interpolated frequency points.

For an FFT length that is not a power of 2, a DFT (discrete Fourier transform) is performed, which requires more time for calculation, but avoids the effects of interpolation.

In order to display all calculated frequency points (defined by the FFT length), the number of sweep points is set to the FFT length automatically in advanced FFT mode.

Window Length

Defines the number of samples to be included in a single window in averaging mode. (In single mode, the window length corresponds to the "Record Length".)

Values from 3 to 4096 are available in "Manual" mode; in "Advanced" FFT mode, values from 3 to 524288 are available. However, the window length may not be longer than the "FFT Length".

If the window length is shorter than the "FFT Length", the sample data is filled up with zeros up to the FFT length.

If the window length is longer than the "Record Length" (that is, not enough samples are available), a window length the size of the "Record Length" is used for calculation.

The window length and the "Window Overlap" determine how many FFT calculations must be performed for each record in averaging mode (see "Transformation Algorithm").


Frequency Resolution of FFT Results - RBW

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Basics on FFT > Frequency Resolution of FFT Results - RBW
Frequency Resolution of FFT Results - RBW

The resolution bandwidth defines the minimum frequency separation at which the individual components of a spectrum can be distinguished. Small values result in a high precision, as the distance between two distinguishable frequencies is small. Higher values decrease the precision, but increase measurement speed.

The RBW is determined by the following equation:

Definition of RBW

(Note: The normalized bandwidth is a fixed value that takes the noise bandwidth of the window function into consideration.)

The maximum RBW is restricted by the "Analysis Bandwidth", or by the following equation, whichever is higher:

If a higher spectral resolution is required, the number of samples must be increased by using a higher sample rate or longer record length.

The minimum achievable RBW depends on the sample rate and record length, according to the following equation:

To simplify operation, some parameters are coupled and automatically calculated, such as record length and RBW.

RBW mode

Depending on the selected RBW mode, the resolution bandwidth is either determined automatically or can be defined manually.

Auto mode:

This is the default mode in the I/Q Analyzer. The RBW is determined automatically depending on the "Sample Rate" and "Window Length", where the window length corresponds to the "Record Length", or a maximum of 4096.

If the record length is larger than the window length, multiple windows are combined; the FFT length is 4096.

A Flatop window function is used.

Manual mode:

The RBW can be defined by the user.

The "Window Length" is adapted to comply with equation "Definition of RBW". Since only window lengths with integer values can be employed, the "Sample Rate" is adapted, if necessary, to obtain an integer window length value.

If the record length is larger than the window length, multiple windows are combined; the FFT length is 4096.

A Flatop window function is used.

Advanced FFT mode

The RBW is determined by the advanced FFT parameters, depending on the selected "FFT Calculation Methods" method.


FFT Calculation Methods

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Basics on FFT > FFT Calculation Methods
FFT Calculation Methods

FFT calculation can be performed using different methods.

Single

In single mode, one FFT is calculated for the entire record length, that means the window length is identical to the record length.

If the defined "FFT Length" is larger than the record length, zeros are appended to the captured data to reach the FFT length.

FFT parameters for single FFT calculation
Averaging

In averaging mode, several overlapping FFTs are calculated for each record; the results are combined to determine the final FFT result for the record.

The number of FFTs to be combined is determined by the "Window Overlap" and the "Window Overlap".

FFT parameters for averaged FFT calculation


I/Q Analyzer in MSRA/MSRT Operating Mode

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > I/Q Analyzer in MSRA/MSRT Operating Mode
I/Q Analyzer in MSRA/MSRT Operating Mode

The I/Q Analyzer can also be used in MSRA and MSRT operating mode. The MSRA Master channel is implemented as an I/Q Analyzer application. Only this channel captures data in MSRA mode. Thus, the functions and settings described for data acquisition in the I/Q Analyzer application also apply to the MSRA Master. Furthermore, the I/Q Analyzer can be used to analyze data in MSRA mode. Thus, the result displays and analysis functions provided by the I/Q Analyzer can also be used in MSRA mode.

In MSRT mode, the MSRT Master performs a realtime measurement to capture data.

Note that the available functions and settings for the I/Q Analyzer in MSRA mode vary depending on whether the MSRA Master channel or an I/Q Analyzer application channel is selected. For example, data acquisition settings for an I/Q Analyzer application channel in MSRA mode configure the analysis interval, not an actual data capture from the input signal. And measurements in the time and frequency domain are only available in an I/Q Analyzer application channel in MSRA mode.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .


Measurements in the Time and Frequency Domain

I/Q Analyzer > Basics on I/Q Data Acquisition and Processing > Measurements in the Time and Frequency Domain
Measurements in the Time and Frequency Domain

The I/Q Analyzer application (not Master) in multistandard mode can also perform measurements on the captured I/Q data in the time and frequency domain. In order to do so, the I/Q Analyzer performs an FFT sweep on the captured I/Q data, providing power vs frequency results, or uses the RBW filter to obtain power vs time (zero span) results. This data is then used for the common frequency or time domain measurements provided by the R&S FSW Spectrum application, such as ACLR, SEM or CCDF.

Configuration

Apart from the data capturing process, the measurements are identical in the Spectrum and I/Q Analyzer applications. They are configured using the same settings and provide the same results. The "Magnitude" result display in the I/Q Analyzer, for instance, will principally show the same results as the zero span measurement for the same data. However, while the "Magnitude" evaluation is configured by the I/Q analysis bandwidth and the measurement time, the zero span measurement is configured by the center frequency, RBW and sweep time settings. Internally, these "time domain" settings are converted to the required I/Q settings by the I/Q Analyzer.

The time and frequency domain measurements and the required settings are described in detail in "Measurements" .

Limitations

However, since the data in the I/Q Analyzer application is captured by the Master, independantly of the specific time or frequency measurement requirements concerning the RBW, filter type and number of sweep points in the application, some restrictions may apply to these measurements in the I/Q Analyzer. If not enough samples are available in the captured and converted I/Q data, for example, an error message is displayed in the application.

The maximum span for a frequency sweep on I/Q-based data corresponds to the maximum I/Q bandwidth (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input" and "Sample Rates and Bandwidths for Digital I/Q Data").

The maximum resolution bandwidth (RBW) is 1 MHz.

Furthermore, the following functions are not available for time and frequency domain measurements in multistandard mode:

  • Marker demodulation
  • Frequency counter marker
  • Gated measurement
  • Video trigger


Configuration

I/Q Analyzer > Configuration
Configuration

The I/Q Analyzer is a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you switch to an I/Q Analyzer measurement channel the first time, a set of parameters is passed on from the currently active application (see "Default Settings for I/Q Analyzer measurements"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate a measurement channel for the I/Q Analyzer application, data acquisition from the input signal is started automatically with the default configuration. It can be configured in the I/Q Analyzer "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu.

I/Q Analyzer in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh" /"Refresh All" ).

For details see "Configuring and Performing Measurements in MSRT Mode" .

The main configuration settings and dialog boxes are also available via the "I/Q Analyzer" menu which is displayed when you press the MEAS CONFIG key.

For a description see
  • "Data Acquisition and Bandwidth Settings"
  • "Display Configuration"

The LINES menu is not available. The SPAN and BW keys open the "Bandwidth" dialog box described in "Data Acquisition and Bandwidth Settings".

The remote commands required to perform these tasks are described in "Remote Commands to Perform Measurements with I/Q Data".

Importing and Exporting I/Q Data

The I/Q data to be evaluated in the I/Q Analyzer application can not only be captured by the I/Q Analyzer itself, it can also be imported to the R&S FSW, provided it has the correct format. Furthermore, the captured I/Q data from the I/Q Analyzer can be exported for further analysis in external applications.

For details see "I/Q Data Import and Export".

Contents
  • Default Settings for I/Q Analyzer measurements
  • Configuration Overview
  • Import/Export Functions
  • Data Input and Output Settings
  • Amplitude
  • Frequency Settings
  • Trigger Settings
  • Data Acquisition and Bandwidth Settings
  • Display Configuration
  • Adjusting Settings Automatically
  • Configuring an I/Q Analyzer as an MSRA/MSRT Application


Default Settings for I/Q Analyzer measurements

I/Q Analyzer > Configuration > Default Settings for I/Q Analyzer measurements
Default Settings for I/Q Analyzer measurements

When you switch an I/Q Analyzer measurement channel the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • signal source
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after the R&S FSW has been set to the I/Q Analyzer application for the first time, or after a "Preset Channel":

Default settings for the I/Q Analyzer application
Parameter | Value
Application | I/Q Analyzer (Master)
Sequencer mode | Continuous
Sweep mode | Continuous
Reference level | 0 dBm
Center frequency | 13.25 GHz
Attenuation | 10 dB
Acquisition time | 31.281μs
Record length | 1001 samples
Sample rate | 32.0 MHz
RBW | 36.79375 kHz
Trigger settings | FREE RUN
Evaluation | Window 1: Spectrum


Configuration Overview

I/Q Analyzer > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

The Overview varies depending on the application; for detailed descriptions see the corresponding application User Manual.

The "Overview" for the I/Q Analyzer Master provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Input settings

    See "Data Input and Output Settings"

  2. Amplitude settings

    See "Amplitude"

  3. Frequency settings

    See "Frequency Settings"

  4. Optionally, Trigger/Gate settings

    See "Trigger Settings"

  5. Bandwidth settings

    See "Data Acquisition and Bandwidth Settings"

  6. Optionally, output settings

    See "Output Settings"

  7. Analysis settings and functions

    See "Analysis"

  8. Display configuration

    See "Display Configuration"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

For step-by-step instructions on configuring I/Q Analyzer measurements, see "How to Perform Measurements in the I/Q Analyzer Application".

└ Preset Channel
└ Specifics for


Preset Channel

I/Q Analyzer > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for I/Q Analyzer measurements".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

I/Q Analyzer > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Import/Export Functions

I/Q Analyzer > Configuration > Import/Export Functions
Import/Export Functions

The following import and export functions are available via softkeys in the "Save/Recall" menu which is displayed when you select the "Save" or "Open" icon in the toolbar.

Some functions for particular data types are (also) available via softkeys or dialog boxes in the corresponding menus, e.g. trace data or marker peak lists.

For a description of the other functions in the "Save/Recall" menu see "Data Management" .

└ Import
└ I/Q Import
└ Export
└ I/Q Export


Import

I/Q Analyzer > Configuration > Import/Export Functions > Import
Import

Provides functions to import data.

See "I/Q Import" for more information.

└ I/Q Import


I/Q Import

I/Q Analyzer > Configuration > Import/Export Functions > Import > I/Q Import
I/Q Import

Opens a file selection dialog box to select an import file that contains IQ data. This function is only available in single sweep mode and only in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

Note that the I/Q data must have a specific format as described in "I/Q Data File Format (iq-tar)".

I/Q import is not available in MSRA/MSRT mode.

For details see "Import/Export Functions".

Remote command:

MMEMory:​LOAD:​IQ:​STATe


Export

I/Q Analyzer > Configuration > Import/Export Functions > Export
Export

Opens a submenu to configure data export.

└ I/Q Export


I/Q Export

I/Q Analyzer > Configuration > Import/Export Functions > Export > I/Q Export
I/Q Export

Opens a file selection dialog box to select an export file to which the IQ data will be stored. This function is only available in single sweep mode, and only in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

For details see "I/Q Data Import and Export".

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe:​IQ:​STATe

MMEMory:​STORe:​IQ:​COMMent


Data Input and Output Settings

I/Q Analyzer > Configuration > Data Input and Output Settings
Data Input and Output Settings

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

►

To display this dialog box, do one of the following:

  • Select the "Input" button in the "Overview".
  • Select the INPUT/OUTPUT key.
Contents
  • Input Source Settings
  • Power Sensors
  • Output Settings
  • Digital I/Q Output Settings


Input Source Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

External mixers are not supported in MSRA/MSRT mode.

Contents
  • Radio Frequency Input
  • Settings for Input from I/Q Data Files
  • External Mixer Settings
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings
  • External Generator Control Settings


Radio Frequency Input

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Radio Frequency State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion (see "Reference Level").

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71). For analog baseband input, an impedance of 50 Ω is always used.

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Note:

For the following measurements, the YIG-Preselector is off by default (if available).
  • I/Q Analyzer (and thus in all applications in MSRA operating mode)
  • Realtime (and thus in all applications in MSRT operating mode)
  • Multi-Carrier Group Delay
  • GSM
  • VSA

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface".

Remote command:

INPut:​CONNector


Settings for Input from I/Q Data Files

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Settings for Input from I/Q Data Files
Settings for Input from I/Q Data Files

Settings for input from I/Q data files is configured in the "Input Source" > "IQ file" tab of the "Input/Frontend" dialog box, which is available when you do of the following:

Currently, this input source is only available in the R&S FSW Pulse application and not in MSRA/MSRT operating mode.

  • Press the INPUT/OUTPUT key, then select the "Input Source Config" softkey.
  • Press the MEAS CONFIG key, then select the "Input/Frontend" softkey.
  • From the "Overview", select "Input/Frontend".

For details see "Basics on Input from I/Q Data Files".

└ IQ Input File State
└ Select I/Q Data File


IQ Input File State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Settings for Input from I/Q Data Files > IQ Input File State
IQ Input File State

Activates input from the selected I/Q input file.

If enabled, the R&S FSW I/Q Analyzer application performs measurements on the data from this file. Thus, most measurement settings related to data acquisition (attenuation, center frequency, measurement bandwidth, sample rate) cannot be changed. The measurement time can only be decreased, in order to perform measurements on an extract of the available data only.

For details see "Basics on Input from I/Q Data Files".

Note: Even when the file input is deactivated, the input file remains selected and can be activated again quickly by changing the state.

Remote command:

INPut:​SELect


Select I/Q Data File

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Settings for Input from I/Q Data Files > Select I/Q Data File
Select I/Q Data File

Opens a file selection dialog box to select an input file that contains I/Q data.

Note that the I/Q data must have a specific format (.iq.tar) as described in "I/Q Data File Format (iq-tar)".

The default storage location for I/Q data files is C:\R_S\Instr\user\.

For details see "Basics on Input from I/Q Data Files".

Remote command:

INPut:​FILE:​PATH


External Mixer Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings
External Mixer Settings

The external mixer is configured in the "External Mixer" tab of the "Input" dialog box which is available when you do one of the following, if the R&S FSW-B21 option is installed:

  • Press the INPUT/OUTPUT key, then select the "External Mixer Config" softkey.
  • From the "Overview", select "Input", then switch to the "External Mixer" tab under "Input Source".

Note that external mixers are not supported in MSRA/MSRT mode.

For more information on using external mixers see "External Mixer (Option -B21)" .

Contents
  • Mixer Settings
  • Basic Settings
  • Managing Conversion Loss Tables
  • Creating and Editing Conversion Loss Tables


Mixer Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings
Mixer Settings

In this tab you configure the band and specific mixer settings.

└ External Mixer State
└ RF Start / RF Stop
└ Handover Freq.
└ Band
└ RF Overrange
└ Preset Band
└ Mixer Type
└ Mixer Settings (Harmonics Configuration)
└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


External Mixer State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


RF Start / RF Stop

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > RF Start / RF Stop
RF Start / RF Stop

Displays the start and stop frequency of the selected band (read-only).

The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

For details on available frequency ranges see table " Frequency ranges for pre-defined bands".

Remote command:

[SENSe:​]MIXer:​FREQuency:​STARt?

[SENSe:​]MIXer:​FREQuency:​STOP?


Handover Freq.

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Handover Freq.
Handover Freq.

Defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency can be selected freely within the overlapping frequency range.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​FREQuency:​HANDover


Band

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Band
Band

Defines the waveguide band or user-defined band to be used by the mixer.

The start and stop frequencies of the selected band are displayed in the "RF Start" and "RF Stop" fields.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

The mixer settings for the user-defined band can be selected freely. The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND[:​VALue]


RF Overrange

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > RF Overrange
RF Overrange

If enabled, the frequency range is not restricted by the band limits ("RF Start" and "RF Stop"). In this case, the full LO range of the selected harmonics is used.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​RFOVerrange[:​STATe]


Preset Band

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Preset Band
Preset Band

Restores the presettings for the selected band.

Note: changes to the band and mixer settings are maintained even after using the PRESET function. This function allows you to restore the original band settings.

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND:​PRESet


Mixer Type

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Type
Mixer Type

The R&S FSW option B21 supports the following external mixer types:

(See also "Two-port and Three-port Mixers" )

"2 Port" | LO and IF data use the same port
"3 Port" | LO and IF data use separate ports
Remote command:

[SENSe:​]MIXer:​PORTs


Mixer Settings (Harmonics Configuration)

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration)
Mixer Settings (Harmonics Configuration)

The harmonics configuration determines the frequency range for user-defined bands (see "Band").

See also "Frequency Ranges" .

└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


Harmonic Type

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Type
Harmonic Type

Defines if only even, only odd, or even and odd harmonics can be used for conversion. Depending on this selection, the order of harmonic to be used for conversion changes (see "Harmonic Order"). Which harmonics are supported depends on the mixer type.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​TYPE


Range 1/2

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Range 1/2
Range 1/2

Enables the use of a second harmonic to cover the band's frequency range.

For each range you can define which harmonic to use and how the "Conversion loss" is handled.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​HIGH:​STATe


Harmonic Order

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Order
Harmonic Order

Defines which of the available harmonic orders of the LO is used to cover the frequency range.

By default, the lowest order of the specified harmonic type is selected that allows conversion of input signals in the whole band. If due to the LO frequency the conversion is not possible using one harmonic, the band is split.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 26.5 GHz.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic[:​LOW]

[SENSe:​]MIXer:​HARMonic:​HIGH[:​VALue]


Conversion loss

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Conversion loss
Conversion loss

Defines how the conversion loss is handled. The following methods are available:

"Average"

Defines the average conversion loss for the entire range in dB.

"Table"

Defines the conversion loss via the table selected from the list. Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Imported tables are checked for compatibility with the current settings before being assigned.

Conversion loss tables are configured and managed in the "Managing Conversion Loss Tables" tab.

For details on conversion loss tables, see "Conversion Loss Tables" .

For details on importing tables, see "Import Table".

Remote command:

Average for range 1:

[SENSe:​]MIXer:​LOSS[:​LOW]

Table for range 1:

[SENSe:​]MIXer:​LOSS:​TABLe[:​LOW]

Average for range 2:

[SENSe:​]MIXer:​LOSS:​HIGH

Table for range 2:

[SENSe:​]MIXer:​LOSS:​TABLe:​HIGH


Basic Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings
Basic Settings

The basic settings concern general use of an external mixer. They are only available if the "External Mixer State" is "On".

└ External Mixer State
└ LO Level
└ Signal ID
└ Auto ID
└ Auto ID Threshold
└ Bias Settings
└ Write to <CVL table name>


External Mixer State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


LO Level

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > LO Level
LO Level

Defines the LO level of the external mixer's LO port. Possible values are from 13.0 dBm to 17.0 dBm in 0.1 dB steps. Default value is 15.5 dB.

Remote command:

[SENSe:​]MIXer:​LOPower


Signal ID

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Signal ID
Signal ID

Activates or deactivates visual signal identification. Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

(See also "Automatic Signal Identification" ).

Mathematical functions with traces and trace copy cannot be used with the Signal ID function.

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Auto ID
Auto ID

Activates or deactivates automatic signal identification.

Auto ID basically functions like "Signal ID". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID Threshold

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Auto ID Threshold
Auto ID Threshold

Defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison ("Auto ID" function). The input range is between 0.1 dB and 100 dB. Values of about 10 dB (i.e. default setting) generally yield satisfactory results.

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​THReshold


Bias Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Bias Settings
Bias Settings

Define the bias current for each range, which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

The trace is adapted to the settings immediately so you can check the results. To store the bias setting in the currently selected conversion loss table, select the "Write to <CVL table name>" button.

Remote command:

[SENSe:​]MIXer:​BIAS[:​LOW]

[SENSe:​]MIXer:​BIAS:​HIGH

└ Write to <CVL table name>


Write to <CVL table name>

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Bias Settings > Write to <CVL table name>
Write to <CVL table name>

Stores the bias setting in the currently selected "Conversion loss table" for the range (see "Managing Conversion Loss Tables"). If no conversion loss table is selected yet, this function is not available ("CVL Table not selected").

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Managing Conversion Loss Tables

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables
Managing Conversion Loss Tables

In this tab you configure and manage conversion loss tables. Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. The correction values for frequencies between the reference points are obtained via interpolation.

The currently selected table for each range is displayed at the top of the dialog box. All conversion loss tables found in the instrument's C:\r_s\instr\user\cvl\ directory are listed in the "Modify Tables" list.

└ External Mixer State
└ New Table
└ Edit Table
└ Delete Table
└ Import Table


External Mixer State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


New Table

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > New Table
New Table

Opens the "Edit Conversion loss table" dialog box to configure a new conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Edit Table

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Edit Table
Edit Table

Opens the "Edit Conversion loss table" dialog box to edit the selected conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Delete Table

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Delete Table
Delete Table

Deletes the currently selected conversion loss table after you confirm the action.

Remote command:

[SENSe:​]CORRection:​CVL:​CLEAr


Import Table

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Import Table
Import Table

Imports a stored conversion loss table from any directory and copies it to the instrument's C:\r_s\instr\user\cvl\ directory. It can then be assigned for use for a specific frequency range (see "Conversion loss").

For details see "Conversion Loss Tables" .


Creating and Editing Conversion Loss Tables

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables
Creating and Editing Conversion Loss Tables

Conversion loss tables can be defined and edited in the "Edit conversion loss table" dialog box which is displayed when you select the "New Table" button in the "External Mixer > Conversion loss table" settings.

A preview pane displays the current configuration of the conversion loss function as described by the position/value entries.

└ File Name
└ Comment
└ Band
└ Harmonic Order
└ Bias
└ Mixer Name
└ Mixer S/N
└ Mixer Type
└ Position/Value
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


File Name

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > File Name
File Name

Defines the name under which the table is stored in the C:\r_s\instr\user\cvl\ directory on the instrument. The name of the table is identical with the name of the file (without extension) in which the table is stored. This setting is mandatory. The .ACL extension is automatically appended during storage.

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Comment

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Comment
Comment

An optional comment that describes the conversion loss table. The comment can be freely defined by the user.

Remote command:

[SENSe:​]CORRection:​CVL:​COMMent


Band

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Band
Band

The waveguide or user-defined band for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

Remote command:

[SENSe:​]CORRection:​CVL:​BAND


Harmonic Order

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Harmonic Order
Harmonic Order

The harmonic order of the range for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​HARMonic


Bias

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Bias
Bias

The bias current which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

Tip: You can also define the bias interactively while a preview of the trace with the changed setting is displayed, see "Bias Settings".

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Mixer Name

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Name
Mixer Name

Specifies the name of the external mixer for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​MIXer


Mixer S/N

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer S/N
Mixer S/N

Specifies the serial number of the external mixer for which the table is to be applied.

This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​SNUMber


Mixer Type

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Type
Mixer Type

Specifies whether the external mixer for which the table is to be applied is a two-port or three-port type. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​PORTs


Position/Value

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Position/Value
Position/Value

Each position/value pair defines the correction value for conversion loss for a specific frequency. The reference values must be entered in order of increasing frequencies. A maximum of 50 reference values can be entered. To enter a new value pair, select the "Position/Value" table, or select the "Insert Value" button.

Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value.

(See "Conversion Loss Tables" .)

The current configuration of the conversion loss function as described by the position/value entries is displayed in the preview pane to the right of the table.

Remote command:

[SENSe:​]CORRection:​CVL:​DATA


Insert Value

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Insert Value
Insert Value

Inserts a new position/value entry in the table.

If the table is empty, a new entry at 0 Hz is inserted.

If entries already exist, a new entry is inserted above the selected entry. The position of the new entry is selected such that it divides the span to the previous entry in half.


Delete Value

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Delete Value
Delete Value

Deletes the currently selected position/value entry.


Shift x

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift x
Shift x

Shifts all positions in the table by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the x-axis.


Shift y

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift y
Shift y

Shifts all conversion loss values by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the y-axis.


Save

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Save
Save

The conversion loss table is stored under the specified name in the C:\r_s\instr\user\cvl\ directory of the instrument.


Digital I/Q Input Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (R&S FSW-B17)".

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface".

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes".

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes".

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.
For details on frequency ranges and the analysis bandwidth see "Processing Data From the Analog Baseband Interface".

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes".

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


External Generator Control Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings
External Generator Control Settings

The "External Generator" settings are available in the "Input" dialog box if the R&S FSW External Generator Control option (R&S FSW-B10) is installed. For each measurement channel one external generator can be configured. To switch between different configurations define multiple measurement channels.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

Contents
  • Interface Configuration Settings
  • Measurement Settings
  • Source Calibration Functions


Interface Configuration Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings
Interface Configuration Settings

The interface settings for the connection to the external generator are defined in the "Interface Configuration" subtab of the "External Generator" tab.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

For more information on configuring interfaces see "Remote Control Interfaces and Protocols" .

└ Generator Type
└ Interface
└ TTL Handshake
└ GPIB Address / TCP/IP Address
└ Reference
└ Edit Generator Setup File
└ Frequency Min. / Frequency Max.
└ Level Min. / Level Max.


Generator Type

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Generator Type
Generator Type

Selects the generator type and thus defines the generator setup file to use.

For an overview of supported generators see "Overview of Generators Supported by the R&S FSW-B10 Option". For information on generator setup files see "Generator Setup Files".

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​TYPE


Interface

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Interface
Interface

Type of interface connection used. The following interfaces are currently supported:

  • GPIB
  • TCP/IP (not by all generators)

For details on which signal generators support which interfaces, see the documentation of the corresponding signal generator.

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​INTerface


TTL Handshake

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > TTL Handshake
TTL Handshake

If available for the specified generator type, this option activates TTL synchronization via handshake for GPIB connections.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator.

For more information on TTL synchronization see "TTL synchronization".

For an overview of which generators support TTL synchronization see "Overview of Generators Supported by the R&S FSW-B10 Option".

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​LINK


GPIB Address / TCP/IP Address

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > GPIB Address / TCP/IP Address
GPIB Address / TCP/IP Address

For LAN connections: TCP/IP address of the signal generator

For GPIB connections: GPIB address of the signal generator.

For details on interfaces see "Remote Control Interfaces and Protocols" .

Remote command:

SYSTem:​COMMunicate:​GPIB:​RDEVice:​GENerator:​ADDRess

SYSTem:​COMMunicate:​TCPip:​RDEVice:​GENerator:​ADDRess


Reference

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Reference
Reference

Selects the internal R&S FSW or an external frequency reference to synchronize the R&S FSW with the generator (default: internal).

Remote command:

SOURce:​EXTernal:​ROSCillator[:​SOURce]


Edit Generator Setup File

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Edit Generator Setup File
Edit Generator Setup File

Displays the setup file for the currently selected "Generator Type" in read-only mode in an editor.

Although the existing setup files are displayed in read-only mode in the editor, they can be saved under a different name (using "File > SaveAs").

Be careful, however, to adhere to the required syntax and commands. Errors will only be detected and displayed when you try to use the new generator (see also "Displayed Information and Errors").

For details see "Generator Setup Files".


Frequency Min. / Frequency Max.

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Frequency Min. / Frequency Max.
Frequency Min. / Frequency Max.

For reference only: Lower and upper frequency limit for the generator.


Level Min. / Level Max.

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Level Min. / Level Max.
Level Min. / Level Max.

For reference only: Lower and upper power limit for the generator.


Measurement Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings
Measurement Settings

The measurement settings for external generator control are configured in the "Measurement Configuration" subtab of the "External Generator" tab.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

└ Source State
└ Source Power
└ Source Offset
└ Source Frequency Coupling
└ (Manual) Source Frequency
└ (Automatic) Source Frequency (Numerator/Denominator/Offset)
└ Result Frequency Start
└ Result Frequency Stop


Source State

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source State
Source State

Activates or deactivates control of an external generator.

For more information on external generator control see "Basics on External Generator Control".

Remote command:

SOURce:​EXTernal[:​STATe]


Source Power

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source Power
Source Power

The output power of the external generator. The default output power is -20 dBm. The range is specified in the data sheet.

Remote command:

SOURce:​EXTernal:​POWer[:​LEVel]


Source Offset

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source Offset
Source Offset

Constant level offset for the external generator. Values from -200 dB to +200 dB in 1 dB steps are allowed. The default setting is 0 dB. Offsets are indicated by the "LVL" label in the channel bar (see also "Displayed Information and Errors").

With this offset, attenuators or amplifiers at the output connector of the external generator can be taken into account for the displayed output power values on screen or during data entry, for example. Positive offsets apply to an amplifier and negative offsets to an attenuator subsequent to the external generator.

Remote command:

SOURce:​POWer[:​LEVel][:​IMMediate]:​OFFSet


Source Frequency Coupling

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source Frequency Coupling
Source Frequency Coupling

Defines the frequency coupling mode between the R&S FSW and the generator.

For more information on coupling frequencies see "Coupling the Frequencies".

"Auto" | Default setting: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW (see "(Automatic) Source Frequency (Numerator/Denominator/Offset)"); the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)
"Manual" | The generator uses a single fixed frequency, defined by "(Manual) Source Frequency" which is displayed when you select "Manual" coupling.
Remote command:

SOURce:​EXTernal:​FREQuency:​COUPling[:​STATe]


(Manual) Source Frequency

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > (Manual) Source Frequency
(Manual) Source Frequency

Defines the fixed frequency to be used by the generator.

Remote command:

SOURce:​EXTernal:​FREQuency


(Automatic) Source Frequency (Numerator/Denominator/Offset)

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > (Automatic) Source Frequency (Numerator/Denominator/Offset)
(Automatic) Source Frequency (Numerator/Denominator/Offset)

With automatic frequency coupling, a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW.

However, the frequency used by the generator may differ from the input from the R&S FSW. The RF frequency may be multiplied by a specified factor, or a frequency offset can be added, or both.

Note: The input for the generator frequency is not validated, i.e. you can enter any values. However, if the allowed frequency ranges of the generator are exceeded, an error message is displayed on the R&S FSW and the values for "Result Frequency Start" and "Result Frequency Stop" are corrected to comply with the range limits.

The value range for the offset depends on the selected generator. The default setting is 0 Hz. Offsets <> 0 Hz are indicated by the "FRQ" label in the channel bar. Negative offsets can be used to define reverse sweeps.

For more information on coupling frequencies and reverse sweeps see "Coupling the Frequencies". For more information on error messages and the channel bar see "Displayed Information and Errors".

Remote command:

SOURce:​EXTernal:​FREQuency[:​FACTor]:​DENominator

SOURce:​EXTernal:​FREQuency[:​FACTor]:​NUMerator

SOURce:​EXTernal:​FREQuency:​OFFSet


Result Frequency Start

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Result Frequency Start
Result Frequency Start

For reference only: The start frequency for the generator, calculated from the configured generator frequency and the start value defined for the R&S FSW.


Result Frequency Stop

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Result Frequency Stop
Result Frequency Stop

For reference only: The stop frequency for the generator, calculated from the configured generator frequency and the stop value defined for the R&S FSW.


Source Calibration Functions

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions
Source Calibration Functions

The calibration functions of the external generator are available in the "Source Calibration" subtab of the "External Generator" tab, but only if external generator control is active (see "Source State").

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

└ Calibrate Transmission
└ Calibrate Reflection Short
└ Calibrate Reflection Open
└ Source Calibration Normalize
└ Recall
└ Save As Trd Factor
└ Reference Position
└ Reference Value


Calibrate Transmission

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Calibrate Transmission
Calibrate Transmission

Starts a transmission type measurement to determine a reference trace. This trace is used to calculate the difference for the normalized values.

This function is only available if external generator control is active (see "Source State").

For details see "Calibration Mechanism".

Remote command:

[SENSe:​]CORRection:​METHod


Calibrate Reflection Short

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Calibrate Reflection Short
Calibrate Reflection Short

Starts a short-circuit reflection type measurement to determine a reference trace for calibration.

This function is only available if external generator control is active (see "Source State").

If both calibrations (open circuit, short circuit) are carried out, the calibration trace is calculated by averaging the two measurements. The order of the two calibration measurements is irrelevant.

Remote command:

[SENSe:​]CORRection:​METHod

Selects the reflection method.

[SENSe:​]CORRection:​COLLect[:​ACQuire]

Starts the sweep for short-circuit calibration.


Calibrate Reflection Open

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Calibrate Reflection Open
Calibrate Reflection Open

Starts an open-circuit reflection type measurement to determine a reference trace for calibration.

This function is only available if external generator control is active (see "Source State").

If both reflection-type calibrations (open circuit, short circuit) are carried out, the reference trace is calculated by averaging the two measurements. The order of the two calibration measurements is irrelevant.

Remote command:

[SENSe:​]CORRection:​METHod

Selects the reflection method.

[SENSe:​]CORRection:​COLLect[:​ACQuire]

Starts the sweep for open-circuit calibration.


Source Calibration Normalize

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Source Calibration Normalize
Source Calibration Normalize

Switches the normalization of measurement results on or off. This function is only available if the memory contains a reference trace, that is, after a calibration has been performed.

For details on normalization see "Normalization".

Remote command:

[SENSe:​]CORRection[:​STATe]


Recall

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Recall
Recall

Restores the settings that were used during source calibration. This can be useful if instrument settings were changed after calibration (e.g. center frequency, frequency deviation, reference level, etc).

This function is only available if external generator control is active (see "Source State").

Remote command:

[SENSe:​]CORRection:​RECall


Save As Trd Factor

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Save As Trd Factor
Save As Trd Factor

Uses the normalized measurement data to generate a transducer factor. The trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under "c:\r_s\instr\trd". The frequency points are allocated in equidistant steps between start and stop frequency. The generated transducer factor can be further adapted using the "Transducer" softkey in the SETUP menu.

For more information on transducers see "Basics on Transducer Factors" .

This function is only available if "Source Calibration Normalize" is switched on.

Note: Note that the normalized measurement data is used, not the reference trace! Thus, if you store the normalized trace directly after calibration, without changing any settings, the transducer factor will be 0 dB for the entire span (by definition of the normalized trace).

Remote command:

[SENSe:​]CORRection:​TRANsducer:​GENerator


Reference Position

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Reference Position
Reference Position

Defines the position of the "Result Frequency Stop" in percent of the total y-axis range. The top of the diagram is 100%, the bottom is 0%. By default, the 0 dB line is displayed at the top of the diagram (100%).

This setting is only available if normalization is on (see "Source Calibration Normalize").

The reference line defined by the reference value and reference position is similar to the "Reference Level" defined in the "Amplitude" settings. However, this reference line only affects the y-axis scaling in the diagram, it has no effect on the expected input power level or the hardware settings.

The normalized trace (0 dB directly after calibration) is displayed on this reference line, indicated by a red line in the diagram. If you shift the reference line, the normalized trace is shifted, as well.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Reference Value

I/Q Analyzer > Configuration > Data Input and Output Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Reference Value
Reference Value

Defines the reference value to be displayed at the specified "Result Frequency Start".

This setting can be used to shift the reference line and thus the normalized trace, similar to the "Shifting the Display (Offset)" defined in the "Amplitude" settings shifts the reference level in the display.

Shifting the normalized trace is useful, for example, to reflect an attenuation or gain caused by the measured DUT. If you then zoom into the diagram around the normalized trace, the measured trace still remains fully visible.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


Power Sensors

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors
Power Sensors

The R&S FSW can also analyze data from a connected power sensor.

Contents
  • Basics on Power Sensors
  • Power Sensor Settings
  • How to Work With a Power Sensor


Basics on Power Sensors

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Basics on Power Sensors
Basics on Power Sensors

For precise power measurement up to 4 power sensors can be connected to the instrument via the power sensor interface (on the front panel). Both manual operation and remote control are supported.

Currently, only R&S NRP-Zxy power sensors are supported. For a detailed list of supported sensors see the data sheet.

Power sensors can also be used to trigger a measurement at a specified power level, e.g. from a signal generator (see "Using a Power Sensor as an External Power Trigger").

Power sensor support – standard test setup
Using the power sensor with several applications

The power sensor cannot be used from the R&S FSW firmware and the R&S Power Viewer Plus (virtual power meter for displaying results of the R&S NRP power sensors) simultaneously.

Result display

The results of the power sensor measurements are displayed in the marker table. For each power sensor, a row is inserted. The sensor index is indicated in the "Type" column.

Contents
  • Using a Power Sensor as an External Power Trigger


Using a Power Sensor as an External Power Trigger

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Basics on Power Sensors > Using a Power Sensor as an External Power Trigger
Using a Power Sensor as an External Power Trigger

Power sensors can be used to trigger a measurement at a specified power level, e.g. from a signal generator.

Currently, only the following power sensors are supported as power triggers:

  • R&S NRP-Z81
  • R&S NRP-Z85
  • R&S NRP-Z86

With the R&S FSW, the power sensors can be connected to the "Power Sensor" interface directly, and no further cables are required. They can then be configured as an external power sensor trigger.

Connecting a power sensor using the POWER SENSOR interface

The R&S FSW receives an external trigger signal when the defined trigger level is measured by the power sensor. Power measurement results are provided as usual.

For details see "How to Configure a Power Sensor as an External (PSE) Trigger".


Power Sensor Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings
Power Sensor Settings

Power sensor settings are available in the "Power Sensor" tab of the "Input" dialog box. Each sensor is configured on a separate tab.

└ State
└ Continuous Value Update
└ Select
└ Zeroing Power Sensor
└ Frequency Manual
└ Frequency Coupling
└ Unit/Scale
└ Meas Time/Average
└ Setting the Reference Level from the Measurement (Meas->Ref)
└ Reference Value
└ Use Ref Lev Offset
└ Average Count (Number of Readings)
└ Duty Cycle
└ Using the power sensor as an external trigger
└ External Trigger Level
└ Hysteresis
└ Trigger Holdoff
└ Drop-Out Time
└ Slope


State

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > State
State

Switches the power measurement for all power sensors on or off. Note that in addition to this general setting, each power sensor can be activated or deactivated individually by the "Select" setting on each tab. However, the general setting overrides the individual settings.

Remote command:

[SENSe:​]PMETer<p>[:​STATe]


Continuous Value Update

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Continuous Value Update
Continuous Value Update

If activated, the power sensor data is updated continuously during a sweep with a long sweep time, and even after a single sweep has completed.

This function cannot be activated for individual sensors.

If the power sensor is being used as a trigger (see "Using the power sensor as an external trigger"), continuous update is not possible; this setting is ignored.

Remote command:

[SENSe:​]PMETer<p>:​UPDate[:​STATe]


Select

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Select
Select

Selects the individual power sensor for usage if power measurement is generally activated ("State" function).

The detected serial numbers of the power sensors connected to the instrument are provided in a selection list. For each of the four available power sensor indexes ("Power Sensor 1"..."Power Sensor 4"), which correspond to the tabs in the configuration dialog, one of the detected serial numbers can be assigned. The physical sensor is thus assigned to the configuration setting for the selected power sensor index.

By default, serial numbers not yet assigned are automatically assigned to the next free power sensor index for which "Auto Assignment" is selected.

Alternatively, you can assign the sensors manually by deactivating the "Auto" option and selecting a serial number from the list.

Remote command:

[SENSe:​]PMETer<p>[:​STATe]

SYSTem:​COMMunicate:​RDEVice:​PMETer<p>:​DEFine

SYSTem:​COMMunicate:​RDEVice:​PMETer<p>:​CONFigure:​AUTO[:​STATe]

SYSTem:​COMMunicate:​RDEVice:​PMETer:​COUNt?


Zeroing Power Sensor

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Zeroing Power Sensor
Zeroing Power Sensor

Starts zeroing of the power sensor.

For details on the zeroing process refer to "How to Zero the Power Sensor".

Remote command:

CALibration:​PMETer<p>:​ZERO:​AUTO ONCE


Frequency Manual

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Frequency Manual
Frequency Manual

Defines the frequency of the signal to be measured. The power sensor has a memory with frequency-dependent correction factors. This allows extreme accuracy for signals of a known frequency.

Remote command:

[SENSe:​]PMETer<p>:​FREQuency


Frequency Coupling

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Frequency Coupling
Frequency Coupling

Selects the coupling option. The frequency can be coupled automatically to the center frequency of the instrument or to the frequency of marker 1.

Remote command:

[SENSe:​]PMETer<p>:​FREQuency:​LINK


Unit/Scale

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Unit/Scale
Unit/Scale

Selects the unit with which the measured power is to be displayed. Available units are dBm, dB, W and %.

If dB or % is selected, the display is relative to the reference value that is defined with either the "Meas -> Ref" setting or the "Reference Value" setting.

Remote command:

UNIT<n>:​PMETer<p>:​POWer

UNIT<n>:​PMETer<p>:​POWer:​RATio


Meas Time/Average

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Meas Time/Average
Meas Time/Average

Selects the measurement time or switches to manual averaging mode. In general, results are more precise with longer measurement times. The following settings are recommended for different signal types to obtain stable and precise results:

"Short" | Stationary signals with high power (> -40dBm), because they require only a short measurement time and short measurement time provides the highest repetition rates.
"Normal" | Signals with lower power or modulated signals
"Long" | Signals at the lower end of the measurement range (<-50 dBm) or Signals with lower power to minimize the influence of noise
"Manual" | Manual averaging mode. The average count is set with the "Average Count (Number of Readings)" setting.
Remote command:

[SENSe:​]PMETer<p>:​MTIMe

[SENSe:​]PMETer<p>:​MTIMe:​AVERage[:​STATe]


Setting the Reference Level from the Measurement (Meas->Ref)

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Setting the Reference Level from the Measurement (Meas->Ref)
Setting the Reference Level from the Measurement (Meas->Ref)

Sets the currently measured power as a reference value for the relative display. The reference value can also be set manually via the "Reference Value" setting.

Remote command:

CALCulate<n>:​PMETer<p>:​RELative[:​MAGNitude]:​AUTO ONCE


Reference Value

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Reference Value
Reference Value

Defines the reference value for relative measurements in the unit dBm.

Remote command:

CALCulate<n>:​PMETer<p>:​RELative[:​MAGNitude]


Use Ref Lev Offset

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Use Ref Lev Offset
Use Ref Lev Offset

If activated, takes the reference level offset defined for the analyzer into account for the measured power (see "Shifting the Display (Offset)"). If deactivated, takes no offset into account.

Remote command:

[SENSe:​]PMETer<p>:​ROFFset[:​STATe]


Average Count (Number of Readings)

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Average Count (Number of Readings)
Average Count (Number of Readings)

Defines the number of readings (averages) to be performed after a single sweep has been started. This setting is only available if manual averaging is selected ("Meas Time/Average" setting).

The values for the average count range from 0 to 256 in binary steps (1, 2, 4, 8, …). For average count = 0 or 1, one reading is performed. The general averaging and sweep count for the trace are independent from this setting.

(See"Bandwidth, Filter and Sweep Settings" ).

Results become more stable with extended average, particularly if signals with low power are measured. This setting can be used to minimize the influence of noise in the power sensor measurement.

Remote command:

[SENSe:​]PMETer<p>:​MTIMe:​AVERage:​COUNt


Duty Cycle

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Duty Cycle
Duty Cycle

Sets the duty cycle to a percent value for the correction of pulse-modulated signals and activates the duty cycle correction. With the correction activated, the sensor calculates the signal pulse power from this value and the mean power.

Remote command:

[SENSe:​]PMETer<p>:​DCYCle[:​STATe]

[SENSe:​]PMETer<p>:​DCYCle:​VALue


Using the power sensor as an external trigger

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger
Using the power sensor as an external trigger

If activated, the power sensor creates a trigger signal when a power higher than the defined "External Trigger Level" is measured. This trigger signal can be used as an external power trigger by the R&S FSW.

This setting is only available in conjunction with a compatible power sensor.

Remote command:

[SENSe:​]PMETer<p>:​TRIGger[:​STATe]

TRIG:SOUR PSE, see TRIGger[:​SEQuence]:​SOURce

└ External Trigger Level
└ Hysteresis
└ Trigger Holdoff
└ Drop-Out Time
└ Slope


External Trigger Level

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > External Trigger Level
External Trigger Level

Defines the trigger level for the power sensor trigger.

For details on supported trigger levels, see the data sheet.

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​LEVel


Hysteresis

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Setting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

For more information see "Trigger Hysteresis" .

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​HYSTeresis


Trigger Holdoff

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​HOLDoff


Drop-Out Time

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .


Slope

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Slope
Slope

Defines whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​SLOPe


How to Work With a Power Sensor

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > How to Work With a Power Sensor
How to Work With a Power Sensor

The following step-by-step instructions demonstrate how to set up a power sensor. For details on individual functions and settings see "Power Sensor Settings".

The remote commands required to perform these tasks are described in "Working with Power Sensors".

Power sensors can also be used to trigger a measurement at a specified power level, e.g. from a signal generator. This is described in "How to Configure a Power Sensor as an External (PSE) Trigger".

Contents
  • How to Set Up a Power Sensor
  • How to Zero the Power Sensor
  • How to Configure a Power Sensor as an External (PSE) Trigger


How to Set Up a Power Sensor

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > How to Work With a Power Sensor > How to Set Up a Power Sensor
How to Set Up a Power Sensor

Up to 4 external power sensors can be configured separately and used for precise power measurement, as a trigger, or both. All power sensors can be activated and deactivated individually.

The following procedure describes in detail how to configure and activate power sensors.

  1. To display the "Power Sensor" tab of the "Input" dialog box, do one of the following:

    • Select "Input" from the "Overview".
    • Select the INPUT/OUTPUT key and then the "Power Sensor Config" softkey.

  2. Select the tab for the power sensor index you want to configure, e.g. "Sensor 1".

  3. Press "Select" to analyze the power sensor data according to the current configuration when power measurement is activated.

  4. From the selection list with serial numbers of connected power sensors, select the sensor you want to configure.

    To have newly connected power sensors assigned to a tab automatically (default), select "Auto".

  5. Define the frequency of the signal whose power you want to measure.

    1. To define the frequency manually, select "Frequency Manual" and enter a frequency.

    2. To determine the frequency automatically, select "Frequency Coupling" and then either "Center", to use the center frequency, or "Marker", to use the frequency defined by marker 1.

  6. Select the unit for the power result display.

  7. Select the measurement time for which the average is calculated, or define the number of readings to average. To define the number of readings to be taken into account manually, select "Manual" and enter the number in the "Number of Readings" field.

  8. To activate the duty cycle correction, select "DutyCycle" and enter a percentage as the correction value.

  9. If you selected "dB" or "%" as units (relative display), define a reference value:

    1. To set the currently measured power as a reference value, press the "Meas -> Ref" button.

    2. Alternatively, enter a value manually in the "Reference Value" field.

    3. Optionally, select the "Use Ref Level Offset" option to take the reference level offset set for the analyzer into account for the measured power.

  10. To use the power sensor as an external power trigger, select the "External Power Trigger" option and define the trigger settings.

    For details see "How to Configure a Power Sensor as an External (PSE) Trigger".

  11. If necessary, repeat steps 3-10 for another power sensor.

  12. Set the "Power Sensor State" at the top of the "Power Sensor" tab to "On" to activate power measurement for the selected power sensors.

    The results of the power measurement are displayed in the marker table (Function: "Sensor<1...4>").


How to Zero the Power Sensor

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > How to Work With a Power Sensor > How to Zero the Power Sensor
How to Zero the Power Sensor

  1. To display the "Power Sensor" tab of the "Input" dialog box, do one of the following:

    • Select "Input" from the "Overview".
    • Select the INPUT/OUTPUT key and then the "Power Sensor Config" softkey.

  2. Select the tab that is assigned to the power sensor you want to zero.

  3. Press the "Zeroing Power Sensor" button.

    A dialog box is displayed that prompts you to disconnect all signals from the input of the power sensor.

  4. Disconnect all signals sending input to the power sensor and press ENTER to continue.

  5. Wait until zeroing is complete.

    A corresponding message is displayed.


How to Configure a Power Sensor as an External (PSE) Trigger

I/Q Analyzer > Configuration > Data Input and Output Settings > Power Sensors > How to Work With a Power Sensor > How to Configure a Power Sensor as an External (PSE) Trigger
How to Configure a Power Sensor as an External (PSE) Trigger

The following step-by-step instructions demonstrate how to configure a power sensor to be used as an external power sensor trigger.

To configure a power sensor as an external power sensor (PSE) trigger

  1. Connect a compatible power sensor to the "Power Sensor" interface on the front panel of the R&S FSW. (For details on supported sensors see "Using a Power Sensor as an External Power Trigger").

  2. Set up the power sensor as described in "How to Set Up a Power Sensor".

  3. In the "Power Sensor" tab of the "Input" dialog box, select the "External Power Trigger" option.

  4. Enter the power level at which a trigger signal is to be generated ("External Trigger Level") and the other trigger settings for the power sensor trigger.

  5. Press the TRIG key on the front panel of the instrument and then select "Trigger /Gate Config".

  6. In the "Trigger and Gate" dialog box, select "Signal Source" = "PSE".

    The R&S FSW is configured to trigger when the defined conditions for the power sensor occur. Power measurement results are provided as usual.


Output Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ IF/VIDEO/DEMOD Output
└ IF (Wide) Out Frequency
└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


IF/VIDEO/DEMOD Output

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > IF/VIDEO/DEMOD Output
IF/VIDEO/DEMOD Output

Defines the type of signal available at the IF/VIDEO/DEMOD or IF OUT connector on the rear panel of the R&S FSW.

For restrictions and additional information see "IF and Video Signal Output".

"IF" | The measured IF value is available at the IF/VIDEO/DEMOD output connector. The frequency at which this value is available is defined in "IF (Wide) Out Frequency".
"IF 2 GHz Out" | The measured IF value is available at the IF OUT output connector at a frequency of 2 GHz (with a bandwidth of 2 GHz). This setting is only available for instrument models R&S FSW43/50/67. For further prerequisites see "IF 2 GHz Output".
"VIDEO" | The displayed video signal (i.e. the filtered and detected IF signal) is available at the IF/VIDEO/DEMOD output connector. This setting is required to provide demodulated audio frequencies at the output.
Remote command:

OUTPut:​IF[:​SOURce]

OUTPut:​IF:​SBANd?


IF (Wide) Out Frequency

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > IF (Wide) Out Frequency
IF (Wide) Out Frequency

Defines or indicates the frequency at which the IF signal level is provided at the IF/VIDEO/DEMOD connector if "IF/VIDEO/DEMOD Output" is set to "IF".

Note: The IF output frequency of the IF WIDE OUTPUT connector cannot be defined manually, but is determined automatically depending on the center frequency. It is indicated in this field when the IF WIDE OUTPUT connector is used. For details on the used frequencies see the data sheet.
The IF WIDE OUTPUT connector is used automatically instead of the IF/VIDEO/DEMOD connector if the bandwidth extension (hardware option R&S FSW-B160 / -U160) is activated (i.e. for bandwidths > 80 MHz).
If the IF 2 GHZ OUT output is activated, the measured IF value is provided at a fixed frequency of 2 GHz.

For more information see "IF and Video Signal Output".

Remote command:

OUTPut:​IF:​IFFRequency


Noise Source

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

For details see "Input from Noise Sources"

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered"

(Default) Sends a trigger when the R&S FSW triggers.

"Trigger Armed"

Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state.

This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).

For details see "STATus:OPERation Register" and the R&S FSW Getting Started manual.

"User Defined"

Sends a trigger when user selects "Send Trigger" button.

In this case, further parameters are available for the output signal.

Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

I/Q Analyzer > Configuration > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Digital I/Q Output Settings

I/Q Analyzer > Configuration > Data Input and Output Settings > Digital I/Q Output Settings
Digital I/Q Output Settings

The optional Digital Baseband Interface (R&S FSW-B17) allows you to output I/Q data from any R&S FSW application that processes I/Q data to an external device. The configuration settings for digital I/Q output can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

Digital output is not available if the bandwidth extension option R&S FSW-B500 is active.

For details on digital I/Q output see "Digital Output".

└ Digital Baseband Output
└ Output Settings Information
└ Connected Instrument


Digital Baseband Output

I/Q Analyzer > Configuration > Data Input and Output Settings > Digital I/Q Output Settings > Digital Baseband Output
Digital Baseband Output

Enables or disables a digital output stream to the optional Digital Baseband Interface (R&S FSW-B17), if available.

Note: If digital baseband output is active, the sample rate is restricted to 200 MHz (max. 160 MHz bandwidth).
See also "Digital I/Q enhanced mode".
The only data source that can be used for digital baseband output is RF input.

For details on digital I/Q output see "Digital Output".

Remote command:

OUTPut:​DIQ


Output Settings Information

I/Q Analyzer > Configuration > Data Input and Output Settings > Digital I/Q Output Settings > Output Settings Information
Output Settings Information

Displays information on the settings for output via the Digital Baseband Interface (R&S FSW-B17).

The following information is displayed:

  • Maximum sample rate that can be used to transfer data via the Digital Baseband Interface (i.e. the maximum input sample rate that can be processed by the connected instrument)
  • Sample rate currently used to transfer data via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level")
Remote command:

OUTPut:​DIQ:​CDEVice


Connected Instrument

I/Q Analyzer > Configuration > Data Input and Output Settings > Digital I/Q Output Settings > Connected Instrument
Connected Instrument

Displays information on the instrument connected to the Digital Baseband Interface (R&S FSW-B17), if available.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
Remote command:

OUTPut:​DIQ:​CDEVice


Amplitude

I/Q Analyzer > Configuration > Amplitude
Amplitude

The amplitude is configured in the "Amplitude" dialog box. Amplitude settings are identical to the Spectrum application, except for a new scaling function for I/Q Vector and Real/Imag results (see )"Y-Axis Max").

Contents
  • Amplitude Settings
  • Amplitude Settings for Analog Baseband Input
  • Scaling the Y-Axis


Amplitude Settings

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

Amplitude settings for input from the Analog Baseband interface (R&S FSW-B71) are described in "Amplitude Settings for Analog Baseband Input".

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance
└ Range


Reference Level

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Note that for input from the External Mixer (R&S FSW-B21) the maximum reference level also depends on the conversion loss, see "Reference level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)


Shifting the Display (Offset)

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Unit

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Reference Level > Unit
Unit

The R&S FSW measures the signal voltage at the RF input. In the default state, the level is displayed at a power of 1 mW (= dBm). Via the known input impedance (50 Ω or 75 Ω, see "Impedance"), conversion to other units is possible. The following units are available and directly convertible:

  • dBm
  • dBmV
  • dBμV
  • dBμA
  • dBpW
  • Volt
  • Ampere
  • Watt
Remote command:

INPut:​IMPedance

CALCulate<n>:​UNIT:​POWer


Setting the Reference Level Automatically (Auto Level)

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Reference Level > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


RF Attenuation

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

└ Attenuation Mode / Value


Attenuation Mode / Value

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance
└ Range


Preamplifier (option B24)

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Range

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings > Input Settings > Range
Range

Defines the displayed y-axis range in dB.

The default value is 100 dB.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]


Amplitude Settings for Analog Baseband Input

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings for Analog Baseband Input
Amplitude Settings for Analog Baseband Input

The following settings and functions are available to define amplitude settings for input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the AMPT key or in the "Amplitude" tab of the "Input" dialog box.

The input settings provided here are identical to those in the "Input Source" > "Analog Baseband" tab, see "Analog Baseband Input Settings".

For more information see "Processing Data From the Analog Baseband Interface".

└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ Full Scale Level Mode / Value


Unit

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings for Analog Baseband Input > Reference Level > Unit
Unit

The R&S FSW measures the signal voltage at the RF input. In the default state, the level is displayed at a power of 1 mW (= dBm). Via the known input impedance (50 Ω or 75 Ω, see "Impedance"), conversion to other units is possible. The following units are available and directly convertible:

  • dBm
  • dBmV
  • dBμV
  • dBμA
  • dBpW
  • Volt
  • Ampere
  • Watt
Remote command:

INPut:​IMPedance

CALCulate<n>:​UNIT:​POWer


Full Scale Level Mode / Value

I/Q Analyzer > Configuration > Amplitude > Amplitude Settings for Analog Baseband Input > Full Scale Level Mode / Value
Full Scale Level Mode / Value

The full scale level defines the maximum power you can input at the Baseband Input connector without clipping the signal.

The full scale level can be defined automatically according to the reference level, or manually.

For manual input, the following values can be selected:

  • 0.25 V
  • 0.5 V
  • 1 V
  • 2 V

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

For details on probes see "Processing Data From the Analog Baseband Interface".

Remote command:

INPut:​IQ:​FULLscale:​AUTO

INPut:​IQ:​FULLscale[:​LEVel]


Scaling the Y-Axis

I/Q Analyzer > Configuration > Amplitude > Scaling the Y-Axis
Scaling the Y-Axis

The individual scaling settings that affect the vertical axis are described here.

└ Range
└ Ref Level Position
└ Scaling
└ Y-Axis Max


Ref Level Position

I/Q Analyzer > Configuration > Amplitude > Scaling the Y-Axis > Ref Level Position
Ref Level Position

Defines the reference level position, i.e. the position of the maximum AD converter value on the level axis in %, where 0 % corresponds to the lower and 100 % to the upper limit of the diagram.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Scaling

I/Q Analyzer > Configuration > Amplitude > Scaling the Y-Axis > Scaling
Scaling

Defines the scaling method for the y-axis.

For more information see "Scaling" .

"Logarithmic" | Logarithmic scaling (only available for logarithmic units - dB..., and A, V, Watt)
"Linear Unit" | Linear scaling in the unit of the measured signal
"Linear Percent" | Linear scaling in percentages from 0 to 100
"Absolute" | The labeling of the level lines refers to the absolute value of the reference level (not available for "Linear Percent")
"Relative" | The scaling is in dB, relative to the reference level (only available for logarithmic units - dB...). The upper line of the grid (reference level) is always at 0 dB.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE


Y-Axis Max

I/Q Analyzer > Configuration > Amplitude > Scaling the Y-Axis > Y-Axis Max
Y-Axis Max

Defines the maximum value of the y-axis in the currently selected diagram in either direction (in Volts). Thus, the y-axis scale starts at -<Y-Axis Max> and ends at +<Y-Axis Max>.

The maximum y-axis value depends on the current reference level. If the reference level is changed, the "Y-Axis Max" value is automatically set to the new reference level (in V).

This command is only available if the evaluation mode for the I/Q Analyzer is set to "IQ Vector" or "Real/Imag".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]


Frequency Settings

I/Q Analyzer > Configuration > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

I/Q Analyzer > Configuration > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

I/Q Analyzer > Configuration > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

I/Q Analyzer > Configuration > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Note: In MSRA/MSRT mode, this function is only available for the MSRA/MSRT Master.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Trigger Settings

I/Q Analyzer > Configuration > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

Conventional gating as in the Spectrum application is not available for the I/Q Analyzer; however, a special gating mode is available in remote control, see "Configuring I/Q Gating".

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

For step-by-step instructions on configuring triggered measurements, see the R&S FSW User Manual.

└ Trigger Source
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Video
└ IF Power/BB Power
└ I/Q Power
└ Digital I/Q
└ RF Power
└ Power Sensor
└ Time
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Source

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source
Trigger Source

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Video
└ IF Power/BB Power
└ I/Q Power
└ Digital I/Q
└ RF Power
└ Power Sensor
└ Time
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope


Trigger Source

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

For gated measurements, this setting also defines the gating source.

For more information see "Trigger Source" .

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ Video
└ IF Power/BB Power
└ I/Q Power
└ Digital I/Q
└ RF Power
└ Power Sensor
└ Time


Free Run

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)").

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.
In the I/Q Analyzer application only "External Trigger 1" is supported.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


Video

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > Video
Video

Defines triggering by the video signal, i.e. the filtered and detected version of the input signal (the envelope of the IF signal), as displayed on the screen.

Define a trigger level from 0 % to 100 % of the diagram height. The absolute trigger level is indicated by a horizontal trigger line in the diagram, which you can also move graphically to change the trigger level.

Video mode is only available in the time domain, and not for I/Q-based data.

Remote command:

TRIG:SOUR VID, see TRIGger[:​SEQuence]:​SOURce


IF Power/BB Power

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > IF Power/BB Power
IF Power/BB Power

Depending on the input source type, this softkey defines triggering of the measurement using:

  • the baseband power (for baseband input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)
  • the third intermediate frequency(RF input)
    The R&S FSW is triggered as soon as the trigger threshold is exceeded around the selected frequency (= start frequency in the frequency sweep). The trigger threshold depends on the defined trigger level, as well as on the RF attenuation and preamplification. A reference level offset, if defined, is also considered. The trigger bandwidth at the intermediate frequency depends on the RBW and sweep type. For details on available trigger levels and trigger bandwidths see the data sheet.

Note: Be aware that in auto sweep type mode, due to a possible change in sweep types, the trigger bandwidth may vary considerably for the same RBW setting.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce

TRIG:SOUR BBP, see TRIGger[:​SEQuence]:​SOURce


I/Q Power

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > I/Q Power
I/Q Power

This trigger source is only available in the I/Q Analyzer application and in applications that process I/Q data.

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

The trigger bandwidth corresponds to the bandwidth setting for I/Q data acquisition (see "Analysis Bandwidth").

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


Digital I/Q

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.
(See also "Digital I/Q enhanced mode".)

A "Trigger Offset", and "Slope" can be defined for the Digital IQ trigger to improve the trigger stability, but no hysteresis or holdoff value.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

(For details on the LVDS connector see "Description of the LVDS Connector")

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


RF Power

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

This trigger source is not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71). If the trigger source "RF Power" is selected and digital I/Q or analog baseband input is activated, the trigger source is automatically switched to "Free Run".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


Power Sensor

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > Power Sensor
Power Sensor

Uses an external power sensor as a trigger source. This option is only available if a power sensor is connected and configured.

Note: For R&S power sensors, the "Gate Mode" Lvl is not supported. The signal sent by these sensors merely reflects the instant the level is first exceeded, rather than a time period. However, only time periods can be used for gating in level mode. Thus, the trigger impulse from the sensors is not long enough for a fully gated measurement; the measurement cannot be completed.

Remote command:

TRIG:SOUR PSE, see TRIGger[:​SEQuence]:​SOURce


Time

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Source > Time
Time

Triggers in a specified repetition interval.

Remote command:

TRIG:SOUR TIME, see TRIGger[:​SEQuence]:​SOURce


Trigger Level (Repetition interval)

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Level (Repetition interval)
Trigger Level (Repetition interval)

Defines the trigger level for the specified trigger source. For time triggers, the repetition interval is defined.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel:​IQPower

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

TRIGger[:​SEQuence]:​LEVel:​BBPower

TRIGger[:​SEQuence]:​TIME:​RINTerval


Drop-Out Time

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Note: For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger) Only possible for zero span (e.g. I/Q Analyzer application) and gated trigger switched off Maximum allowed range limited by the sweep time: pretriggermax = sweep time When using the Digital Baseband Interface (R&S FSW-B17), the maximum range is limited by the number of pretrigger samples. (See table "Restrictions for digital in- and output")

Tip: To determine the trigger point in the sample (for "External" or "IF Power" trigger source), use the TRACe:​IQ:​TPISample? command.

For the "Time" trigger source, this function is not available.

Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Slope

I/Q Analyzer > Configuration > Trigger Settings > Trigger Source > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Data Acquisition and Bandwidth Settings

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings
Data Acquisition and Bandwidth Settings

How data is to be acquired is configured in the "Bandwidth" dialog box.

Contents
  • Data Acquisition
  • Sweep Settings


Data Acquisition

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition
Data Acquisition

The data acquisition settings define which parts of the input signal are captured for further evaluation in the applications. They are configured in the "Data Acquisition" tab of the "Bandwidth" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Bandwidth" button in the configuration "Overview"
  • Select the BW key and then the "Data Acquisition" softkey.
  • Select the "Data Acquisition" softkey in the "I/Q Analyzer" menu.
MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for the I/Q Analyzer application in MSRA/MSRT mode define the analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

The remote commands required to perform these tasks are described in "Configuring Data Acquisition".

└ Sample Rate
└ Analysis Bandwidth
└ Maximum Bandwidth
└ Omitting the Digital Decimation Filter (No Filter)
└ Meas Time
└ Record Length
└ Swap I/Q
└ RBW
└ Advanced FFT mode / Basic settings
└ Transformation Algorithm
└ FFT Length
└ Window Function
└ Window Overlap
└ Window Length
└ Capture Offset


Sample Rate

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Sample Rate
Sample Rate

Defines the I/Q data sample rate of the R&S FSW. This value is dependent on the defined "Analysis Bandwidth" and the defined signal source.

Up to the "Maximum Bandwidth", the following rule applies:

sample rate = analysis bandwidth / 0.8

For details on the dependencies see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

In particular, note the irregularity mentioned in "Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500".

This rate may differ from the sample rate of the connected device (see "Input Sample Rate").

If the Digital Baseband Interface (R&S FSW-B17) is active, restrictions to the sample rate apply, see "Sample Rates and Bandwidths for Digital I/Q Data".

Remote command:

TRACe:​IQ:​SRATe


Analysis Bandwidth

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Analysis Bandwidth
Analysis Bandwidth

Defines the flat, usable bandwidth of the final I/Q data. This value is dependent on the defined "Sample Rate" and the defined signal source.

Up to the "Maximum Bandwidth", the following rule applies:

analysis bandwidth = 0.8 * sample rate

For details on the dependencies see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

In particular, note the irregularity mentioned in "Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500".

Note: For input from the Analog Baseband interface (R&S FSW-B71): If the frequency range defined by the analysis bandwidth and the center frequency exceeds the minimum frequency (0 Hz for low IF evaluation) or the maximum frequency (for I+jQ evaluation), an error is displayed. In this case, adjust the center frequency (see "Center Frequency") or the analysis bandwidth to exclude possible unwanted signal components.
For details on frequency ranges and the analysis bandwidth see "Processing Data From the Analog Baseband Interface".

Remote command:

TRACe:​IQ:​BWIDth


Maximum Bandwidth

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Maximum Bandwidth
Maximum Bandwidth

Defines the maximum bandwidth to be used by the R&S FSW for I/Q data acquisition. This setting is only available if the bandwidth extension option R&S FSW-B160/-B320/-B500 is installed. Otherwise the maximum bandwidth is determined automatically.

For details on the maximum bandwidth see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

"Auto"

(Default) All installed bandwidth extension options are activated. The currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

Note that using bandwidth extension options R&S FSW-B160/-B320 may cause more spurious effects (option B500 does not).

Note: If a bandwidth extension > 160 MHz is active, the IF WIDE OUTPUT connector is automatically used to provide IF output.
See "Bandwidth Extension 160 MHz with IF WIDE OUTPUT Connector (-B160)" for details on the connector.

"80 MHz"

Restricts the analysis bandwidth to a maximum of 80 MHz.

The bandwidth extension options R&S FSW-B160/-B320/-B500 are deactivated.

"160 MHz"

Restricts the analysis bandwidth to a maximum of 160 MHz. The bandwidth extension option R&S FSW-B320 is deactivated.

(Not available or required if bandwidth extension option R&S FSW-B500 is installed.)

Remote command:

TRACe:​IQ:​WBANd[:​STATe]

TRACe:​IQ:​WBANd:​MBWIDTH


Omitting the Digital Decimation Filter (No Filter)

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Omitting the Digital Decimation Filter (No Filter)
Omitting the Digital Decimation Filter (No Filter)

This setting is only available when using the Digital Baseband Interface (R&S FSW-B17).

If enabled, no digital decimation filter is used during data acquisition. Thus, the "Analysis Bandwidth" is identical to the input sample rate configured for the Digital I/Q input source (see "Input Sample Rate").

Note, however, that in this case noise, artifacts, and the second IF side band may not be suppressed in the captured I/Q data.

Remote command:

TRACe:​IQ:​DIQFilter


Meas Time

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Meas Time
Meas Time

Defines the I/Q acquisition time. By default, the measurement time is calculated as the number of I/Q samples ("Record Length") divided by the sample rate. If you change the measurement time, the "Record Length" is automatically changed, as well.

For details on the maximum number of samples see also "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Remote command:

[SENSe:​]SWEep:​TIME


Record Length

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Record Length
Record Length

Defines the number of I/Q samples to record. By default, the number of sweep points is used. The record length is calculated as the measurement time multiplied by the sample rate. If you change the record length, the "Meas Time" is automatically changed, as well.

Note: For the I/Q vector result display, the number of I/Q samples to record ("Record Length") must be identical to the number of trace points to be displayed ("Sweep Points"). Thus, the sweep points are not editable for this result display. If the "Record Length" is edited, the sweep points are adapted automatically.
For record lengths outside the valid range of sweep points, i.e. less than 101 points or more than 100001 points, the diagram does not show valid results.

Remote command:

TRACe:​IQ:​RLENgth

TRACe:​IQ:​SET


Swap I/Q

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Swap I/Q
Swap I/Q

Activates or deactivates the inverted I/Q modulation. If the I and Q parts of the signal from the DUT are interchanged, the R&S FSW can do the same to compensate for it.

On | I and Q signals are interchanged Inverted sideband, Q+j*I
Off | I and Q signals are not interchanged Normal sideband, I+j*Q
Remote command:

[SENSe:​]SWAPiq


RBW

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > RBW
RBW

Defines the resolution bandwidth. The available RBW values depend on the sample rate and record length.

(See "Frequency Resolution of FFT Results - RBW").

Depending on the selected RBW mode, the value is either determined automatically or can be defined manually. As soon as you enter a value in the input field, the RBW mode is changed to "Manual".

If the "Advanced Fourier Transformation Params" option is enabled, advanced FFT mode is selected and the RBW cannot be defined directly.

Note that the RBW is correlated with the "Sample Rate" and "Record Length" (and possibly the "Window Function" and "Window Length"). Changing any one of these parameters may cause a change to one or more of the other parameters.

For more information see "Basics on FFT".

"Auto mode" | (Default) The RBW is determined automatically depending on the "Sample Rate" and "Record Length".
"Manual mode" | The RBW can be defined by the user. The user-defined RBW is used and the "Window Length" (and possibly "Sample Rate") are adapted accordingly.
"Advanced FFT mode" | This mode is used if the "Advanced Fourier Transformation Params" option is enabled. The RBW is determined by the advanced FFT parameters.
Remote command:

[SENSe:​]IQ:​BANDwidth|BWIDth:​MODE

[SENSe:​]IQ:​BANDwidth|BWIDth:​RESolution


Advanced FFT mode / Basic settings

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings
Advanced FFT mode / Basic settings

Shows or hides the "Advanced Fourier Transformation" parameters in the "Data Acquisition" dialog box. These parameters are only available and required for the advanced FFT mode.

For more information see "Basics on FFT".

└ Transformation Algorithm
└ FFT Length
└ Window Function
└ Window Overlap
└ Window Length


Transformation Algorithm

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Transformation Algorithm
Transformation Algorithm

Defines the FFT calculation method.

For more information see "Basics on FFT".

"Single" | One FFT is calculated for the entire record length; if the "FFT Length" is larger than the record length, zeros are appended to the captured data.
"Averaging" | Several overlapping FFTs are calculated for each record; the results are combined to determine the final FFT result for the record. The number of FFTs to be averaged is determined by the "Window Overlap" and the "Window Overlap".
Remote command:

[SENSe:​]IQ:​FFT:​ALGorithm


FFT Length

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > FFT Length
FFT Length

Defines the number of frequency points determined by each FFT calculation. The more points are used, the higher the resolution in the spectrum becomes, but the longer the calculation takes.

In advanced FFT mode, the number of sweep points is set to the FFT length automatically.

Note: If you use the arrow keys or the rotary knob to change the FFT length, the value is incremented or decremented by powers of 2.
If you enter the value manually, any integer value from 3 to 524288 is available.

For more information see "Basics on FFT".

Remote command:

[SENSe:​]IQ:​FFT:​LENGth


Window Function

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Window Function
Window Function

In the I/Q analyzer you can select one of several FFT window types.

For details on the effects of FFT windowing functions see "Basics on FFT".

The following window types are available:
  • Blackman-Harris
  • Flattop
  • Gauss
  • Rectangular
  • 5-Term
Remote command:

[SENSe:​]IQ:​FFT:​WINDow:​TYPE


Window Overlap

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Window Overlap
Window Overlap

Defines the part of a single FFT window that is re-calculated by the next FFT calculation when using multiple FFT windows.

For more information see "Basics on FFT".

Remote command:

[SENSe:​]IQ:​FFT:​WINDow:​OVERlap


Window Length

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Advanced FFT mode / Basic settings > Window Length
Window Length

Defines the number of samples to be included in a single FFT window in averaging mode. (In single mode, the window length corresponds to the "Record Length".)

Values from 3 to 4096 are available in "Manual" mode; in "Advanced" FFT mode, values from 3 to 524288 are available.

However, the window length may not be longer than the "FFT Length".

For more information see "Basics on FFT".

Remote command:

[SENSe:​]IQ:​FFT:​WINDow:​LENGth


Capture Offset

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Data Acquisition > Capture Offset
Capture Offset

This setting is only available for applications in MSRA or MSRT operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

In MSRT mode, the offset may be negative if a pretrigger time is defined.

For details on the MSRA operating mode see "Applications and Operating Modes" .

For details on the MSRT operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet

[SENSe:​]RTMS:​CAPTure:​OFFSet


Sweep Settings

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings
Sweep Settings

The sweep settings are configured via the SWEEP key or in the "Sweep" tab of the "Bandwidth" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Bandwidth" button in the configuration "Overview" and switch to the "Sweep" tab.
  • Select the SWEEP key and then the "Sweep Config" softkey.
└ Sweep Points
└ Sweep/Average Count
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Meas Time


Sweep Points

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Sweep Points
Sweep Points

In the I/Q Analyzer application, a specific frequency bandwidth is swept for a specified measurement time. During this time, a defined number of samples (= "Record Length") are captured. These samples are then evaluated by the applications. Therefore, in this case the number of sweep points does not define the amount of data to be acquired, but rather the number of trace points that are evaluated and displayed in the result diagrams.

Note: As opposed to previous versions of the I/Q Analyzer, the sweep settings are now window-specific. For some result displays, the sweep points may not be editable as they are determined automatically, or restrictions may apply.
For the I/Q vector result display, the number of I/Q samples to record ("Record Length") must be identical to the number of trace points to be displayed ("Sweep Points"). Thus, the sweep points are not editable for this result display. If the "Record Length" is edited, the sweep points are adapted automatically. For record lengths outside the valid range of sweep points, i.e. less than 101 points or more than 32001 points, the diagram does not show valid results.
Using fewer than 4096 sweep points with a detector other than Auto Peak may lead to wrong level results. For details see "Combining results - trace detector".

Remote command:

[SENSe:​]SWEep:​POINts


Sweep/Average Count

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

The sweep count is applied to all the traces in all diagrams.

If the trace modes "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt

[SENSe:​]AVERage:​COUNt


Continuous Sweep/RUN CONT

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
If the Sequencer is active in MSRT mode, the "Continuous Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, trace averaging is performed.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts the number of sweeps set in "Sweep Count". The measurement stops after the defined number of sweeps has been performed.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
If the Sequencer is active in MSRT mode, the "Single Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, no trace averaging is performed.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of sweeps set in "Sweep Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Meas Time

I/Q Analyzer > Configuration > Data Acquisition and Bandwidth Settings > Sweep Settings > Meas Time
Meas Time

Defines the I/Q acquisition time. By default, the measurement time is calculated as the number of I/Q samples ("Record Length") divided by the sample rate. If you change the measurement time, the "Record Length" is automatically changed, as well.

For details on the maximum number of samples see also "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Remote command:

[SENSe:​]SWEep:​TIME


Display Configuration

I/Q Analyzer > Configuration > Display Configuration
Display Configuration

The captured signal can be displayed using various evaluation methods. All evaluation methods available for the current application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • Select the "Display Config" softkey in the main application menu.

For a description of the available evaluation methods see "Measurement and Result Displays".

As of firmware version 1.60, up to 6 evaluations can be displayed in the I/Q Analyzer at any time, including several graphical diagrams, marker tables or peak lists.

The selected evaluation method not only affects the result display in a window, but also the results of the trace data query in remote control (see TRACe<n>[:​DATA]?).


Adjusting Settings Automatically

I/Q Analyzer > Configuration > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

MSRA/MSRT operating mode

In MSRA and MSRT operating mode, settings related to data acquisition can only be adjusted automatically for the MSRA/MSRT Master, not the applications.

Adjusting settings automatically during triggered measurements

When you select an auto adjust function a measurement is performed to determine the optimal settings. If you select an auto adjust funtion for a triggered measurement, you are asked how the R&S FSW should behave:

  • (default:) The measurement for adjustment waits for the next trigger
  • The measurement for adjustment is performed without waiting for a trigger.
    The trigger source is temporarily set to "Free Run". After the measurement is completed, the original trigger source is restored. The trigger level is adjusted as follows:
    – For IF Power and RF Power triggers:
    Trigger Level = Reference Level - 15 dB
    – For Video trigger:
    Trigger Level = 85 %

Remote command:

[SENSe:​]ADJust:​CONFigure:​TRIG

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Adjusting the Center Frequency Automatically (Auto Freq)
└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Adjusting all Determinable Settings Automatically (Auto All)

I/Q Analyzer > Configuration > Adjusting Settings Automatically > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Frequency
  • Auto Level

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​ALL


Adjusting the Center Frequency Automatically (Auto Freq)

I/Q Analyzer > Configuration > Adjusting Settings Automatically > Adjusting the Center Frequency Automatically (Auto Freq)
Adjusting the Center Frequency Automatically (Auto Freq)

This function adjusts the center frequency automatically.

The optimum center frequency is the frequency with the highest S/N ratio in the frequency span. As this function uses the signal counter, it is intended for use with sinusoidal signals.

(See "Performing a Highly Accurate Frequency Measurement (Signal Count)" )

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Remote command:

[SENSe:​]ADJust:​FREQuency


Resetting the Automatic Measurement Time (Meastime Auto)

I/Q Analyzer > Configuration > Adjusting Settings Automatically > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically".

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

I/Q Analyzer > Configuration > Adjusting Settings Automatically > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically".

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

I/Q Analyzer > Configuration > Adjusting Settings Automatically > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

I/Q Analyzer > Configuration > Adjusting Settings Automatically > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


Configuring an I/Q Analyzer as an MSRA/MSRT Application

I/Q Analyzer > Configuration > Configuring an I/Q Analyzer as an MSRA/MSRT Application
Configuring an I/Q Analyzer as an MSRA/MSRT Application

In principle, the I/Q Analyzer in MSRA/MSRT mode is configured as in Signal and Spectrum Analyzer mode.

However, the I/Q Analyzer application (not Master) in MSRA/MSRT mode can also perform measurements on the captured I/Q data in the time and frequency domain (see also "I/Q Analyzer in MSRA/MSRT Operating Mode"). Which type of measurement is to be performed - conventional I/Q data analysis or a time or frequency domain measurement - is selected in the "Select Measurement" dialog box, which is now displayed when you do one of the following:

  • In the "I/Q Analyzer" menu, select the "Select Meas" softkey.
  • Press the MEAS key.

The common measurements as in the Spectrum application are listed. In addition, "IQ Analyzer" is provided under "Basic Measurements" to return to the default I/Q Analysis functions.

The time and frequency domain measurements and the required settings are described in detail in "Measurements" .

Multiple measurements

Only one measurement type can be configured per channel; however, several channels for time or frequency-based measurements on I/Q data can be configured in parallel on the R&S FSW. Thus, you can configure one channel for conventional I/Q Analysis, for example, and another for an SEM or power measurement on the same data. Then you can switch through the results easily by switching tabs, or monitor all results at the same time in the "MSRA/MSRT View".

Remote command:

CALCulate:​IQ:​MODE


Analysis

I/Q Analyzer > Analysis
Analysis

General result analysis settings concerning the trace, markers, lines etc. can be configured via the "Analysis" button in the "Overview". They are identical to the analysis functions in the Spectrum application except for the special marker functions, which are not available for I/Q data.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

The remote commands required to perform these tasks are described in "Analysis".

Analysis functions exclusive to I/Q data:
Contents
  • Trace Settings
  • Marker Usage
  • Zoom Functions
  • Analysis in MSRA/MSRT Mode


Trace Settings

I/Q Analyzer > Analysis > Trace Settings
Trace Settings

You can configure the settings for up to 6 individual traces.

For I/Q Vector evaluation mode, only 1 trace is available and the detector is not editable.

└ Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
└ Trace Mode
└ Detector
└ Hold
└ Average Mode
└ Predefined Trace Settings - Quick Config
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)


Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

I/Q Analyzer > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

Remote command:

Selected via numeric suffix of:TRACe<1...6> commands


Trace Mode

I/Q Analyzer > Analysis > Trace Settings > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Detector

I/Q Analyzer > Analysis > Trace Settings > Detector
Detector

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector" .

The trace detector is used to combine multiple FFT window results to create the final spectrum. (Note: in previous versions of the R&S FSW, the I/Q Analyzer always used the linear average detector.) If necessary, the trace detector is also used to reduce the number of calculated frequency points (defined by the FFT length) to the defined number of sweep points. By default, the Autopeak trace detector is used.

Note: Using a detector other than Auto Peak and fewer than 4096 sweep points may lead to wrong level results. For details see "Combining results - trace detector".

"Auto" | Selects the optimum detector for the selected trace and filter mode. This is the default setting.
"Type" | Defines the selected detector type. Note: If the EMI (R&S FSW-K54) measurement option is installed and the filter type "CISPR" is selected, additional detectors are available, even if EMI measurement is not active.
Remote command:

[SENSe:​][WINDow<n>:​]DETector<trace>[:​FUNCtion]

[SENSe:​][WINDow<n>:​]DETector<t>[:​FUNCtion]:​AUTO


Hold

I/Q Analyzer > Analysis > Trace Settings > Hold
Hold

If activated, traces in "Min Hold", "Max Hold" and "Average" mode are not reset after specific parameter changes have been made.

Normally, the measurement is started anew after parameter changes, before the measurement results are analyzed (e.g. using a marker). In all cases that require a new measurement after parameter changes, the trace is reset automatically to avoid false results (e.g. with span changes). For applications that require no reset after parameter changes, the automatic reset can be switched off.

The default setting is off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE:​HCONtinuous


Average Mode

I/Q Analyzer > Analysis > Trace Settings > Average Mode
Average Mode

Defines the mode with which the trace is averaged over several sweeps. A different averaging mode can be defined for each trace.

This setting is only applicable if trace mode "Average" is selected.

How many sweeps are averaged is defined by the "Sweep/Average Count".

For details see "How Trace Data is Averaged - the Averaging Mode" .

"Linear" | The power level values are converted into linear units prior to averaging. After the averaging, the data is converted back into its original unit.
"Logarithmic" | For logarithmic scaling, the values are averaged in dBm. For linear scaling, the behavior is the same as with linear averaging.
"Power" | Activates linear power averaging. The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit. Use this mode to average power values in Volts or Amperes correctly.
Remote command:

[SENSe:​]AVERage<n>:​TYPE


Predefined Trace Settings - Quick Config

I/Q Analyzer > Analysis > Trace Settings > Predefined Trace Settings - Quick Config
Predefined Trace Settings - Quick Config

Commonly required trace settings have been predefined and can be applied very quickly by selecting the appropriate button.

Function | Trace Settings
Preset All Traces | Trace 1: | Clear Write
 | Traces 2-6: | Blank
Set Trace Mode Max | Avg | Min | Trace 1: | Max Hold
 | Trace 2: | Average
 | Trace 3: | Min Hold
 | Traces 4-6: | Blank
Set Trace Mode Max | ClrWrite | Min | Trace 1: | Max Hold
 | Trace 2: | Clear Write
 | Trace 3: | Min Hold
 | Traces 4-6: | Blank


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

I/Q Analyzer > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Marker Usage

I/Q Analyzer > Analysis > Marker Usage
Marker Usage

The following marker settings and functions are available in the I/Q Analyzer application.

For "I/Q Vector" displays markers are not available.

In the I/Q Analyzer application, the resolution with which the frequency can be measured with a marker is always the filter bandwidth, which is derived from the defined sample rate (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

As of firmware version 1.60, marker settings are window-specific, since several diagrams can be displayed at the same time now.

Contents
  • Marker Settings
  • Marker Search Settings and Positioning Functions
  • Marker Peak List Configuration


Marker Settings

I/Q Analyzer > Analysis > Marker Usage > Marker Settings
Marker Settings

Marker settings can be configured via the MARKER key or in the "Marker" dialog box. To display the "Marker" dialog box, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.

The remote commands required to define these settings are described in "Setting Up Individual Markers".

The marker "Search" settings are described in "Marker Search Settings and Positioning Functions".

Contents
  • Individual Marker Setup
  • General Marker Settings


Individual Marker Setup

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup
Individual Marker Setup

Up to 17 markers or delta markers can be activated for each window simultaneously. Initial marker setup is performed using the "Marker" dialog box.

The markers are distributed among 3 tabs for a better overview. By default, the first marker is defined as a normal marker, whereas all others are defined as delta markers with reference to the first marker. All markers are assigned to trace 1, but only the first marker is active.

└ Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
└ Selected Marker
└ Marker State
└ Marker Position (X-value)
└ Marker Type
└ Reference Marker
└ Linking to Another Marker
└ Assigning the Marker to a Trace
└ Select Marker
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 16 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings".

Note: If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative

CALCulate<n>:​DELTamarker<m>:​Y?


Selected Marker

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Position (X-value)

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Marker Position (X-value)
Marker Position (X-value)

Defines the position (x-value) of the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X


Marker Type

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Linking to Another Marker

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Linking to Another Marker
Linking to Another Marker

Links the current marker to the marker selected from the list of active markers. If the x-axis value of the inital marker is changed, the linked marker follows on the same x-position. Linking is off by default.

Using this function you can set two markers on different traces to measure the difference (e.g. between a max hold trace and a min hold trace or between a measurement and a reference trace).

Remote command:

CALCulate<n>:​MARKer<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m>:​LINK


Assigning the Marker to a Trace

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

The marker can also be assigned to the currently active trace using the "Marker to Trace" softkey in the "Marker" menu.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


Select Marker

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > Select Marker
Select Marker

Opens a dialog box to select and activate or deactivate one or more markers quickly.

Remote command:

Marker selected via suffix <m> in remote commands.


All Markers Off

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > Individual Marker Setup > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > General Marker Settings
General Marker Settings

Some general marker settings allow you to influence the marker behavior for all markers.

These settings are located in the "Marker Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab. Then select the horizontal "Marker Settings" tab.
└ Marker Table Display
└ Marker Stepsize


Marker Table Display

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Marker Stepsize

I/Q Analyzer > Analysis > Marker Usage > Marker Settings > General Marker Settings > Marker Stepsize
Marker Stepsize

Defines the size of the steps that the marker position is moved using the rotary knob.

"Standard" | The marker position is moved from pixel to pixel on the display. This setting is most suitable to move the marker over a larger distance.
"Sweep Points" | The marker position is moved from one sweep point to the next. This setting is required for a very precise positioning if more sweep points are collected than the number of pixels that can be displayed on the screen. It is the default mode.
Remote command:

CALCulate:​MARKer:​X:​SSIZe


Marker Search Settings and Positioning Functions

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions
Marker Search Settings and Positioning Functions

Several functions are available to set the marker to a specific position very quickly and easily, or to use the current marker position to define another characteristic value. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

For more information on searching for signal peaks see "Searching for Signal Peaks" .

In I/Q Analyzer mode, the search settings for "Real/Imag (I/Q)" evaluation include an additional parameter, see "Branch for Peak Search".

The remote commands required to define these settings are described in "Positioning the Marker".

Contents
  • Marker Search Settings
  • Positioning Functions


Marker Search Settings

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings
Marker Search Settings

Markers are commonly used to determine peak values, i.e. maximum or minimum values, in the measured signal. Configuration settings allow you to influence the peak search results.

These settings are are available as softkeys in the "Marker To" menu, or in the "Search Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search Settings" tab.
└ Search Mode for Next Peak
└ Peak Excursion
└ Search Limits
└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits
└ Branch for Peak Search


Search Mode for Next Peak

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Peak Excursion

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Peak Excursion
Peak Excursion

Defines the minimum level value by which a signal must rise or fall so that it will be identified as a maximum or a minimum by the search functions.

Entries from 0 dB to 80 dB are allowed; the resolution is 0.1 dB. The default setting for the peak excursion is 6 dB.

For more information see "Searching for Signal Peaks" .

Remote command:

CALCulate<n>:​MARKer:​PEXCursion


Search Limits

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits
Search Limits

The search results can be restricted by limiting the search area or adding search conditions.

└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits


Search Limits (Left / Right)

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Search Limits (Left / Right)
Search Limits (Left / Right)

If activated, limit lines are defined and displayed for the search. Only results within the limited search range are considered.

For details on limit lines for searches see "Peak search limits" .

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​MARKer:​X:​SLIMits:​LEFT

CALCulate:​MARKer:​X:​SLIMits:​RIGHT


Search Threshold

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Search Threshold
Search Threshold

Defines an absolute threshold as an additional condition for the peak search. Only peaks that exceed the threshold are detected.

Remote command:

CALCulate:​THReshold


Using Zoom Limits

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Using Zoom Limits
Using Zoom Limits

If activated, the peak search is restricted to the active zoom area defined for a single zoom (see "Single Zoom").

Remote command:

CALCulate:​MARKer:​X:​SLIMits:​ZOOM[:​STATe]


Deactivating All Search Limits

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​THReshold:​STATe


Branch for Peak Search

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Marker Search Settings > Branch for Peak Search
Branch for Peak Search

Defines which data is used for marker search functions in I/Q data.

This function is only available for the display configuration "Real/Imag (I/Q)" (see "Real/Imag (I/Q)").

Note: The search settings apply to all markers, not only the currently selected one.

"Real" | Marker search functions are performed on the real trace of the I/Q measurement.
"Imag" | Marker search functions are performed on the imaginary trace of the I/Q measurement.
"Magnitude" | Marker search functions are performed on the magnitude of the I and Q data.
Remote command:

CALCulate<n>:​MARKer:​SEARch


Positioning Functions

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Positioning Functions
Positioning Functions

The following functions set the currently selected marker to the result of a peak search or set other characteristic values to the current marker value. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum
└ Center Frequency = Marker Frequency
└ Reference Level = Marker Level


Peak Search

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Center Frequency = Marker Frequency

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Positioning Functions > Center Frequency = Marker Frequency
Center Frequency = Marker Frequency

Sets the center frequency to the selected marker or delta marker frequency. A peak can thus be set as center frequency, for example to analyze it in detail with a smaller span.

This function is not available for zero span measurements.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​CENTer


Reference Level = Marker Level

I/Q Analyzer > Analysis > Marker Usage > Marker Search Settings and Positioning Functions > Positioning Functions > Reference Level = Marker Level
Reference Level = Marker Level

Sets the reference level to the selected marker level.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​REFerence


Marker Peak List Configuration

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration
Marker Peak List Configuration

To display the "Marker Peak List" dialog, do one of the following:

  • Press the MKR FUNC key, then select the "Marker Peak List" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Peak List" tab.
└ Peak List State
└ Sort Mode
└ Maximum Number of Peaks
└ Peak Excursion
└ Displaying Marker Numbers
└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits
└ Exporting the Peak List
└ Decimal Separator


Peak List State

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Peak List State
Peak List State

Activates/deactivates the marker peak list. If activated, the peak list is displayed and the peaks are indicated in the trace display.

For each listed peak the frequency/time ("X-value") and level ("Y-value") values are given.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​STAT


Sort Mode

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Sort Mode
Sort Mode

Defines whether the peak list is sorted according to the x-values or y-values. In either case the values are sorted in ascending order.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT


Maximum Number of Peaks

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Maximum Number of Peaks
Maximum Number of Peaks

Defines the maximum number of peaks to be determined and displayed.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​LIST:​SIZE


Displaying Marker Numbers

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Displaying Marker Numbers
Displaying Marker Numbers

By default, the marker numbers are indicated in the diagram so you can find the peaks from the list. However, for large numbers of peaks the marker numbers may decrease readability; in this case, deactivate the marker number display.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​ANNotation:​LABel[:​STATe]


Search Threshold

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Search Threshold
Search Threshold

Defines an absolute threshold as an additional condition for the peak search. Only peaks that exceed the threshold are detected.

Remote command:

CALCulate:​THReshold


Using Zoom Limits

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Using Zoom Limits
Using Zoom Limits

If activated, the peak search is restricted to the active zoom area defined for a single zoom (see "Single Zoom").

Remote command:

CALCulate:​MARKer:​X:​SLIMits:​ZOOM[:​STATe]


Deactivating All Search Limits

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​THReshold:​STATe


Exporting the Peak List

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Exporting the Peak List
Exporting the Peak List

The peak list can be exported to an ASCII file (.DAT) for analysis in an external application.

For details see "How to Export a Peak List" .

Remote command:

MMEMory:​STORe:​PEAK

FORMat:​DEXPort:​DSEParator

└ Decimal Separator


Decimal Separator

I/Q Analyzer > Analysis > Marker Usage > Marker Peak List Configuration > Exporting the Peak List > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Zoom Functions

I/Q Analyzer > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

I/Q Analyzer > Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

I/Q Analyzer > Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

I/Q Analyzer > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

I/Q Analyzer > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Analysis in MSRA/MSRT Mode

I/Q Analyzer > Analysis > Analysis in MSRA/MSRT Mode
Analysis in MSRA/MSRT Mode

The data that was captured by the MSRA or MSRT Master can be analyzed in the I/Q Analyzer application.

The analysis settings and functions available in MSRA/MSRT mode are those described for common Signal and Spectrum Analyzer mode.

See "Analysis".

Analysis line settings

In addition, an analysis line can be positioned. The analysis line is a common time marker for all MSRA/MSRT applications.

To hide or show and position the analysis line, a dialog box is available. To display the "Analysis Line" dialog box, tap the "AL" icon in the toolbar (only available in MSRA/MSRT mode). The current position of the analysis line is indicated on the icon.

└ Position
└ Show Line


Position

I/Q Analyzer > Analysis > Analysis in MSRA/MSRT Mode > Position
Position

Defines the position of the analysis line in the time domain. The position must lie within the measurement time of the multistandard measurement.

Remote command:

CALCulate:​MSRA:​ALINe[:​VALue]

CALCulate:​RTMS:​ALINe[:​VALue]


Show Line

I/Q Analyzer > Analysis > Analysis in MSRA/MSRT Mode > Show Line
Show Line

Hides or displays the analysis line in the time-based windows. By default, the line is displayed.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Remote command:

CALCulate:​MSRA:​ALINe:​SHOW

CALCulate:​RTMS:​ALINe:​SHOW


How to Work with I/Q Data

I/Q Analyzer > How to Work with I/Q Data
How to Work with I/Q Data

The following step-by-step procedures demonstrate in detail how to perform various tasks when working with I/Q data.

Contents
  • How to Perform Measurements in the I/Q Analyzer Application
  • How to Capture or Output I/Q Data via Optional Interfaces
  • How to Export and Import I/Q Data


How to Perform Measurements in the I/Q Analyzer Application

I/Q Analyzer > How to Work with I/Q Data > How to Perform Measurements in the I/Q Analyzer Application
How to Perform Measurements in the I/Q Analyzer Application

The following step-by-step instructions demonstrate how to capture I/Q data on the R&S FSW and how to analyze data in the I/Q Analyzer application.

How to perform a measurement in the time or frequency domain on I/Q data (in MSRA/MSRT mode only) is described in "How to perform a measurement in the time or frequency domain in MSRA mode" .

Contents
  • How to Capture Baseband (I/Q) Data as RF Input
  • How to Analyze Data in the I/Q Analyzer


How to Capture Baseband (I/Q) Data as RF Input

I/Q Analyzer > How to Work with I/Q Data > How to Perform Measurements in the I/Q Analyzer Application > How to Capture Baseband (I/Q) Data as RF Input
How to Capture Baseband (I/Q) Data as RF Input

By default, the I/Q Analyzer assumes the I/Q data is modulated on a carrier frequency and input via the RF INPUT connector on the R&S FSW.

  1. Press the MODE key on the front panel and select the "I/Q Analyzer" application.

  2. Select the "Overview" softkey to display the "Overview" for an I/Q Analyzer measurement.

  3. Select the "Input" button to select and configure the "RF Input" signal source.

  4. Select the "Amplitude" button to define the attenuation, reference level or other settings that affect the input signal's amplitude and scaling.

  5. Select the "Frequency" button to define the input signal's center frequency.

  6. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an IQ Power trigger to start capturing data only when a specific power is exceeded.

  7. Select the "Bandwidth" button and define the bandwidth parameters for data acquisition:

    • "Sample rate" or "Analysis Bandwidth:" the span of the input signal to be captured for analysis, or the rate at which samples are captured (both values are correlated)
    • Optionally, if R&S FSW-B160/-B320 is installed, the "Maximum Bandwidth", depending on whether you require a larger bandwidth or fewer spurious emissions.
    • "Measurement Time:" how long the data is to be captured
    • "Record Length": the number of samples to be captured (also defined by sample rate and measurement time)

  8. Select the "Display Config" button and select up to six displays that are of interest to you.

    Arrange them on the display to suit your preferences.

  9. Exit the SmartGrid mode.

  10. Start a new sweep with the defined settings.

    In MSRA/MSRT mode you may want to stop the continuous measurement mode by the Sequencer and perform a single data acquisition:

    1. Select the Sequencer icon ( [image]) from the toolbar.

    2. Set the Sequencer state to "OFF".

    3. Press the RUN SINGLE key.


How to Analyze Data in the I/Q Analyzer

I/Q Analyzer > How to Work with I/Q Data > How to Perform Measurements in the I/Q Analyzer Application > How to Analyze Data in the I/Q Analyzer
How to Analyze Data in the I/Q Analyzer

  1. Press the MODE key on the front panel and select the "I/Q Analyzer" application.

  2. Select the "Overview" softkey to display the "Overview" for an I/Q Analyzer measurement.

  3. Select the "Display Config" button and select up to six displays that are of interest to you.

    Arrange them on the display to suit your preferences.

  4. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  5. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the displays.

    • Configure a trace to display the average over a series of sweeps (on the "Trace" tab; if necessary, increase the "Average Count").
    • Configure markers and delta markers to determine deviations and offsets within the signal (on the "Marker" tab).


How to Capture or Output I/Q Data via Optional Interfaces

I/Q Analyzer > How to Work with I/Q Data > How to Capture or Output I/Q Data via Optional Interfaces
How to Capture or Output I/Q Data via Optional Interfaces

The following step-by-step instructions demonstrate how to capture I/Q data on the R&S FSW using the optional Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Contents
  • How to Capture Data via the Optional Digital Baseband Interface (R&S FSW-B17)
  • How to Capture Analog Baseband Input via the Optional Analog Baseband Interface (R&S FSW-B71)
  • How to Capture Data from the Optional Baseband Input Connectors (R&S FSW-B71) as RF Input
  • How to Output I/Q Data via the Optional Digital Baseband Interface (R&S FSW-B17)


How to Capture Data via the Optional Digital Baseband Interface (R&S FSW-B17)

I/Q Analyzer > How to Work with I/Q Data > How to Capture or Output I/Q Data via Optional Interfaces > How to Capture Data via the Optional Digital Baseband Interface (R&S FSW-B17)
How to Capture Data via the Optional Digital Baseband Interface (R&S FSW-B17)

Alternatively to capturing (analog) I/Q data from the standard RF Input connector on the front panel of the R&S FSW, digital I/Q data can be captured from the optional Digital Baseband Interface (R&S FSW-B17), if installed.

The digital input and output cannot be used simultaneously.

  1. Connect the device that provides digital input to the DIGITAL BASEBAND INPUT connector at the rear of the R&S FSW.

  2. Press the INPUT/OUTPUT key on the front panel of the R&S FSW.

  3. Select "Input Source Config" and switch to the "Digital IQ" tab to configure the Digital Baseband Interface.

    Information on the detected input device is shown under "Connected Instrument".

  4. Set the state of the "Digital IQ" signal source to "On".

  5. Define the "Sample Rate" as provided by the connected device, or select "Auto" mode to have it set automatically according to the detected device.

  6. Define the level and unit that corresponds to an I/Q sample with the magnitude "1" as the "Full scale level", or select "Auto" mode to have it set automatically according to the input from the detected device.

  7. Enable the "Adjust Reference Level to Full Scale Level" option to adjust the reference level to input changes continuously, or press the AMPT key to define the reference level manually. Select the "Amplitude Config" softkey to change the reference level offset or to set the level automatically only once.

  8. Select the "Frequency" button to define the input signal's center frequency.

  9. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example a Baseband Power trigger to start capturing data only when a specific input power is exceeded.

  10. Select the "Bandwidth" button and define the bandwidth parameters for data acquisition:

    • "Sample rate" (the rate at which samples are captured) or "Analysis Bandwidth" (the span of the input signal to be captured for analysis); both values are correlated
    • Optionally, enable "No Filter" to suppress the use of the digital decimation filter and increase the analysis bandwidth to the input sample rate from the connected device.
    • "Measurement Time:" how long the data is to be captured
    • "Record Length": the number of samples to be captured (also defined by sample rate and measurement time)

  11. Select the "Display Config" button and select up to six displays that are of interest to you.

    Arrange them on the display to suit your preferences.

  12. Exit the SmartGrid mode.

  13. Start a new sweep with the defined settings.


How to Capture Analog Baseband Input via the Optional Analog Baseband Interface (R&S FSW-B71)

I/Q Analyzer > How to Work with I/Q Data > How to Capture or Output I/Q Data via Optional Interfaces > How to Capture Analog Baseband Input via the Optional Analog Baseband Interface (R&S FSW-B71)
How to Capture Analog Baseband Input via the Optional Analog Baseband Interface (R&S FSW-B71)

Analog baseband signals can also be captured via the optional Analog Baseband Interface (R&S FSW-B71), if installed.

  1. Connect the device that provides analog baseband input to the BASEBAND INPUT connectors at the front of the R&S FSW.

    For single-ended input signals, use the I or Q connector, or both.

    For differential input signals, connect the positive input to the I and Q connectors, and the negative input to the Ī and Ǭ connectors.

  2. Press the INPUT/OUTPUT key on the front panel of the R&S FSW.

  3. Select "Input Source Config" and switch to the "Analog Baseband" tab to configure the Analog Baseband Interface.

    1. Set the state of the "Analog Baseband" signal source to "On".

    2. Select the "I/Q Mode" depending on the signal at the input connectors, or how you want to interpret it.

    3. If necessary, change the input configuration setting depending on whether a single-ended or differential signal is being input.

      Note that both differential and single-ended active probes are supported. However, since a probe only uses a single connector (either BASEBAND INPUT I or Q), the input configuration must be set to single-ended. The type of probe is indicated in the "Probes" subtab of the Input dialog box.

    4. If necessary, for example due to a mixed up connection or inverse data from the connected device, swap the I and Q values for correct analysis.

    5. If only one component of the input signal is of interest (I/Q mode: "I only/ Low IF I" or "Q only/ Low IF Q"), define how to interpret the signal: as modulated or real data. For modulated data, change the "Center Frequency" to use for down-conversion. Select a value between 10 Hz and +40 MHz (or 80 MHz with option R&S FSW-B71E).

  4. Press the AMPT key and select "Amplitude Config".

  5. Define the reference level for the input. If a probe is connected, consider the probe's attenuation when defining the reference level.

  6. Select the maximum power level you expect to input at the BASEBAND INPUT connector as the "Full scale level", or select "Auto" mode to have it set automatically according to the selected reference level.

  7. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example a Baseband Power trigger to start capturing data only when a specific input power is exceeded.

  8. Press the MEAS CONFIG key and select "Data Acquisition" to configure the signal capture.

    • "Sample rate" selected for analysis data or "Analysis Bandwidth" (the bandwidth range in which the signal remains unchanged by the digital decimation filter and thus remains undistorted; this range can be used for accurate analysis by the R&S FSW); both values are correlated
    • "Measurement Time:" how long the signal is to be captured
    • "Record Length": the number of samples to be captured (also defined by sample rate and measurement time)

  9. Select the "Display Config" button and select up to six displays that are of interest to you.

    To analyze the complex spectrum of the analog baseband signal, for instance, select the Spectrum result display (and the I/Q mode "I+jQ" in the input settings). The displayed span corresponds to the selected sample rate.

    Arrange the windows on the display to suit your preferences.

  10. Exit the SmartGrid mode.

  11. Start a new sweep with the defined settings.


How to Capture Data from the Optional Baseband Input Connectors (R&S FSW-B71) as RF Input

I/Q Analyzer > How to Work with I/Q Data > How to Capture or Output I/Q Data via Optional Interfaces > How to Capture Data from the Optional Baseband Input Connectors (R&S FSW-B71) as RF Input
How to Capture Data from the Optional Baseband Input Connectors (R&S FSW-B71) as RF Input

RF signals can also be input via the optional BASEBAND INPUT connectors, if the Analog Baseband Interface (option R&S FSW-B71) is installed. Thus, RF signals can also be input using an active R&S probe. The probe input can then be processed as common RF input.

  1. Connect the device (for example a probe) that provides analog baseband data modulated on a carrier frequency to the BASEBAND INPUT I connector at the front of the R&S FSW.

  2. Press the INPUT/OUTPUT key on the front panel of the R&S FSW.

  3. Select the "Input Source Config" button to configure the "Radio Frequency" signal source.

  4. Set the state of the "Radio Frequency" signal source to "On".

  5. As the "Input Connector", select "Baseband Input I".

  6. Select the "Amplitude" button to define the attenuation, reference level or other settings that affect the input signal's amplitude and scaling.

  7. Select the "Frequency" button to define the input signal's center frequency.

  8. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an IQ Power trigger to start capturing data only when a specific power is exceeded.

  9. Select the "Bandwidth" button and define the bandwidth parameters for data acquisition:

    • "Sample rate" or "Analysis Bandwidth:" the span of the input signal to be captured for analysis, or the rate at which samples are captured (both values are correlated)
    • Optionally, if R&S FSW-B160/-B320/-B500 is installed, the "Maximum Bandwidth", depending on whether you require a larger or smaller bandwidth.
    • "Measurement Time:" how long the data is to be captured
    • "Record Length": the number of samples to be captured (also defined by sample rate and measurement time)

  10. Select the "Display Config" button and select up to six displays that are of interest to you.

    Arrange them on the display to suit your preferences.

  11. Exit the SmartGrid mode.

  12. Start a new sweep with the defined settings.


How to Output I/Q Data via the Optional Digital Baseband Interface (R&S FSW-B17)

I/Q Analyzer > How to Work with I/Q Data > How to Capture or Output I/Q Data via Optional Interfaces > How to Output I/Q Data via the Optional Digital Baseband Interface (R&S FSW-B17)
How to Output I/Q Data via the Optional Digital Baseband Interface (R&S FSW-B17)

The I/Q data processed by the I/Q Analyzer can also be output to the optional Digital Baseband Interface (R&S FSW-B17), if installed.

The digital input and output cannot be used simultaneously.

  1. Connect the device to which digital output will be provided to the DIGITAL BASEBAND OUTPUT connector at the rear of the R&S FSW.

  2. Press the INPUT/OUTPUT key on the front panel of the R&S FSW.

  3. Select "Output Config" and switch to the "Digital IQ" tab to configure the Digital Baseband output.

    Information on the detected output device is shown under "Connected Instrument". The output settings only become available once a device has been detected.

  4. Set the state of the "Digital Baseband Output" to "On".

  5. If the maximum sample rate displayed for the detected output device is lower than the currently defined sample rate for the I/Q Analyzer, press the MEAS CONFIG key and select "Data Acquisition" to change the "Sample Rate" setting.

  6. Select the "Frequency" button to define the center frequency for the measurement.

  7. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an IQ Power trigger to start capturing data only when a specific power is exceeded.

  8. Select the "Display Config" button and select up to six displays that are of interest to you.

    Arrange them on the display to suit your preferences.

  9. Exit the SmartGrid mode.

  10. Start a new sweep with the defined settings.

    The captured data is written to the Digital Baseband Output connector continuously.


How to Export and Import I/Q Data

I/Q Analyzer > How to Work with I/Q Data > How to Export and Import I/Q Data
How to Export and Import I/Q Data

I/Q data can only be exported in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

Capturing and exporting I/Q data

  1. Press the PRESET key.

  2. Press the MODE key and select the "IQ Analyzer" or any other application that supports I/Q data.

  3. Configure the data acquisition.

  4. Press the RUN SINGLE key to perform a single sweep measurement.

  5. Select the [image] "Save" icon in the toolbar.

  6. Select the "I/Q Export" softkey.

  7. In the file selection dialog box, select a storage location and enter a file name.

  8. Select "Save".

    The captured data is stored to a file with the extension .iq.tar.

Importing I/Q data

  1. Press the MODE key and select the "IQ Analyzer" or any other application that supports I/Q data.

  2. If necessary, switch to single sweep mode by pressing the RUN SINGLE key.

  3. Select the [image] "Open" icon in the toolbar.

  4. Select the "I/Q Import" softkey.

  5. Select the storage location and the file name with the .iq.tar file extension.

  6. Select "Open".

    The stored data is loaded from the file and displayed in the current application.

Previewing the I/Q data in a web browser

The iq-tar file format allows you to preview the I/Q data in a web browser.

  1. Use an archive tool (e.g. WinZip® or PowerArchiver®) to unpack the iq-tar file into a folder.

  2. Locate the folder using Windows Explorer.

  3. Open your web browser.

  4. Drag the I/Q parameter XML file, e.g. example.xml, into your web browser.


Optimizing and Troubleshooting the Measurement

I/Q Analyzer > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement:

Error Messages

If errors occur during I/Q data acquisition or data output using the Digital Baseband Interface (R&S FSW-B17) , a message is displayed in the status bar. When data acquisition errors occur, a status bit in the STATus:QUESTionable:SYNC register is also set. Errors concerning the Digital Baseband Interface connection between instruments are indicated by a status bit in the STATus:QUESTionable:DIQ register. See "Querying the Status Registers".

The following tables describe the most common errors and possible solutions.

I/Q data acquisition errors using the Digital Baseband Interface (B17) and possible solutions

Message

Possible solutions

"Sample rate too high in respect to input sample rate!"

  • Reduce the sample rate
  • Increase the input sample rate

(See table "Restrictions for digital in- and output")

"Sample rate too low in respect to input sample rate!"

  • Increase the sample rate
  • Reduce the input sample rate

(See table "Restrictions for digital in- and output")

"Number of IQ Capture samples too high!"

  • Reduce the number of I/Q samples to capture
  • Decrease the sample rate or increase the input sample rate to reduce the ratio of sample rate / input sample rate

Keyword "DATA ERR"

  • Re-establish the Digital I/Q connection

NOTE: If this error is indicated repeatedly either the Digital I/Q LVDS connection cable or the receiving or transmitting device might be defect.

Keyword "PLL UNLOCKED"

  • Re-establish the Digital I/Q connection after the clock from the input device has been restored
I/Q data output errors using the Digital Baseband Interface (B17) and possible solutions

Message

Possible solutions

"Sample rate exceeds limit of connected instrument on Digital I/Q OUT port!"

  • Reduce the sample rate

Keyword: "FIFO OVLD"

The sample rate on the connected instrument is higher than the input sample rate setting on the R&S FSW.

  • Reduce the sample rate on the connected instrument
  • Increase the input sample rate setting on the R&S FSW


Remote Commands to Perform Measurements with I/Q Data

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data
Remote Commands to Perform Measurements with I/Q Data

The following commands are specific to performing measurements in the I/Q Analyzer application or using the optional Digital Baseband Interface (R&S FSW-B17) in a remote environment. The R&S FSW must already be set up for remote operation in a network as described in the base unit manual.

It is assumed that the R&S FSW has already been set up for remote control in a network as described in "How to Set Up a Network and Remote Control" .

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following tasks specific to the I/Q Analyzer application are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating I/Q Analyzer Measurements
  • Configuring I/Q Analyzer Measurements
  • Configuring the Result Display
  • Capturing Data and Performing Sweeps
  • I/Q Analysis
  • Retrieving Results
  • Importing and Exporting I/Q Data and Results
  • Querying the Status Registers
  • Programming Examples


Introduction

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Common Suffixes
Common Suffixes

The following common suffixes are used in remote commands specific to the I/Q Analyzer application:

Suffix | Value range | Description
<m> | 1..16 | Marker
<n> | 1..6 | Window
<t> | 1..6 | Trace


Activating I/Q Analyzer Measurements

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements
Activating I/Q Analyzer Measurements

I/Q Analyzer measurements require a special measurement channel on the R&S FSW. It can be activated using the common INSTrument:​CREate[:​NEW] or INSTrument:​CREate:​REPLace commands. In this case, some - but not all - parameters from the previously selected application are passed on to the I/Q Analyzer channel (see "Default Settings for I/Q Analyzer measurements". In order to retain all relevant parameters from the current application for the I/Q measurement, use the TRACe:​IQ[:​STATe] command to change the application of the current channel.

A measurement is started immediately with the default settings when the channel is activated.

Different remote modes available

In remote control, two different modes for the I/Q Analyzer measurements are available:

  • A quick mode for pure data acquisition
    This mode is activated by default with the TRACe:​IQ[:​STATe] command. The evaluation functions are not available; however, performance is slightly improved.
  • A more sophisticated mode for acquisition and analysis.
    This mode is activated when a new channel is opened for the I/Q Analyzer application (INST:CRE:NEW/ INST:CRE:REPL) or by an additional command (see TRACe:​IQ:​EVAL).
Switching the data basis for measurement

By default, the I/Q Analyzer captures and processes I/Q data. However, the I/Q Analyzer application (not Master) in MSRA mode can also perform measurements on the captured I/Q data in the time and frequency domain. In order to do so, the I/Q Analyzer performs an FFT sweep on the captured I/Q data, providing power vs frequency results, or uses the RBW filter to obtain power vs time (zero span) results. This data is then used for the common frequency or time domain measurements. In order to switch between these measurements, you must select the data basis before performing a measurement.

For a description of remote commands required to perform measurements in the time and frequency domain, see "Configuring and Performing Measurements" .

List of Commands
CALCulate:IQ:MODE
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]
TRACe:IQ:EVAL
TRACe:IQ[:STATe]


CALCulate:IQ:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > CALCulate:IQ:MODE
CALCulate:IQ:MODE <EvalMode>

This command defines whether the captured I/Q data is evaluated directly, or if it is converted (via FFT) to spectral or time data first.

It is currently only available for I/Q Analyzer applications in multistandrad mode (not the MSRA Master).

Parameters:
<EvalMode>
TDOMain

Evaluation in time domain (zero span).

FDOMain

Evaluation in frequency domain.

IQ

Evaluation using I/Q data.


INSTrument:CREate:DUPLicate

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect]).

This command is not available if the MSRA/MSRT Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation".

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType> | <ChannelName>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

Also see

  • INSTrument:​CREate[:​NEW]
  • "Programming Example: Performing a Sequence of Measurements"
Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel.

Example: INST SAN

Activates a measurement channel for the Spectrum application.

INST 'MySpectrum'

Selects the measurement channel named 'MySpectrum' (for example before executing further commands for that channel).

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: SCPI confirmed


SYSTem:PRESet:CHANnel[:EXECute]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


TRACe:IQ:EVAL

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > TRACe:IQ:EVAL
TRACe:IQ:EVAL <State>

This command turns I/Q data analysis on and off.

Before you can use this command, you have to turn on the I/Q data acquisition using INST:CRE:NEW IQ or INST:CRE:REPL, or using the TRACe:​IQ[:​STATe] command to replace the current measurement channel while retaining the settings.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: TRAC:IQ ON

Enables I/Q data acquisition

TRAC:IQ:EVAL ON

Enables the I/Q data analysis mode.


TRACe:IQ[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Activating I/Q Analyzer Measurements > TRACe:IQ[:STATe]
TRACe:IQ[:STATe] <State>

This command changes the application of the current measurement channel to I/Q Analyzer, activating the simple I/Q data acquisition mode (see "Different remote modes available").

Executing this command also has the following effects:

  • The sweep, amplitude, input and trigger settings from the previous application are retained
  • All measurements from the previous application (e.g. Spectrum) are turned off
  • All traces are set to "Blank" mode
  • The I/Q data analysis mode is turned off (TRAC:IQ:EVAL OFF, if previous application was also I/Q Analyzer)

Note: To turn trace display back on or to enable the evaluation functions of the I/Q Analyzer, execute the TRAC:IQ:EVAL ON command (see TRACe:​IQ:​EVAL).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: TRAC:IQ ON

Switches on I/Q data acquisition

Example:

See "Basic I/Q Analysis with Improved Performance".

Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (R&S FSW-B17)".


Configuring I/Q Analyzer Measurements

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements
Configuring I/Q Analyzer Measurements

The following commands configure the I/Q Analyzer measurements.

Contents
  • Configuring the Data Input and Output
  • Configuring the Vertical Axis (Amplitude, Scaling)
  • Frequency
  • Triggering
  • Configuring Data Acquisition
  • Adjusting Settings Automatically


Configuring the Data Input and Output

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output
Configuring the Data Input and Output
Contents
  • RF Input
  • Input from I/Q Data Files
  • Configuring Digital I/Q Input and Output
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Using External Mixers
  • Setting up Probes
  • External Generator Control
  • Working with Power Sensors
  • Configuring the Outputs


RF Input

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

The command works only if the overload condition has been eliminated first.

For details on the protection mechanism see "RF Input Protection".

Usage: Event


INPut:CONNector

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface".

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"
See "Unit"


INPut:SELect

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Tip: The I/Q data to be analyzed for I/Q Analyzer can not only be measured by the WLAN application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the analyzed I/Q data from the WLAN application can be exported for further analysis in external applications. See "Import/Export Functions".

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input".

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface".

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "Radio Frequency State"
See "IQ Input File State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Input from I/Q Data Files

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Input from I/Q Data Files
Input from I/Q Data Files

The input for measurements can be provided from I/Q data files.The commands required to configure the use of such files are described here.

Currently, this input source is only available in the R&S FSW Pulse application.

For details see "Basics on Input from I/Q Data Files".

Useful commands for retrieving results described elsewhere:
  • INPut:​SELect
Remote commands exclusive to input from I/Q data files:
List of Commands
INPut:FILE:PATH


INPut:FILE:PATH

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Input from I/Q Data Files > INPut:FILE:PATH
INPut:FILE:PATH <FileName>

This command selects the I/Q data file to be used as input for further measurements.

The I/Q data must have a specific format as described in "I/Q Data File Format (iq-tar)".

For details see "Basics on Input from I/Q Data Files".

Parameters:
<FileName> | String containing the path and name of the source file. The file extension is *.iq.tar.
Example: | INP:FILE:PATH 'C:\R_S\Instr\user\data.iq.tar' Uses I/Q data from the specified file as input.
Usage: | Setting only
Manual operation: | See "Select I/Q Data File"


Configuring Digital I/Q Input and Output

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Useful commands for digital I/Q data described elsewhere:
  • INP:SEL DIQ (see INPut:​SELect)
  • TRIGger[:​SEQuence]:​LEVel:​BBPower
  • TRACe:​IQ:​DIQFilter
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
OUTPut:DIQ
OUTPut:DIQ:CDEVice


INPut:DIQ:CDEVice

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information".

Return values:
<ConnState> | Defines whether a device is connected or not. 0 No device is connected. 1 A device is connected.
<DeviceName> | Device ID of the connected device
<SerialNumber> | Serial number of the connected device
<PortName> | Port name used by the connected device
<SampleRate> | Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)
<MaxTransferRate> | Maximum data transfer rate of the connected device in Hz
<ConnProtState> | State of the connection protocol which is used to identify the connected device. Not Started Has to be Started Started Passed Failed Done
<PRBSTestState> | State of the PRBS test. Not Started Has to be Started Started Passed Failed Done
<SampleRateType> | 0 Maximum sample rate is displayed 1 Current sample rate is displayed
<FullScaleLevel> | The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device); If not available, 9.97e37 is returned
Example: | INP:DIQ:CDEV? Result: 1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example: | See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".
Manual operation: | See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Note: the final user sample rate of the R&S FSW may differ and is defined using TRAC:IQ:SRAT (see TRACe:​IQ:​SRATe).

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Manual operation: See "Input Sample Rate"


OUTPut:DIQ

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > OUTPut:DIQ
OUTPut:DIQ <State>

This command turns continuous output of I/Q data to the optional Digital Baseband Interface (R&S FSW-B17) on and off.

Using the digital input and digital output simultaneously is not possible.

If digital baseband output is active, the sample rate is restricted to 100 MHz (200 MHz if enhanced mode is possible; max. 160 MHz bandwidth).

See also "Digital I/Q enhanced mode".

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:DIQ ON
Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Output via the Optional Digital Baseband Interface (R&S FSW-B17)".

Manual operation: See "Digital Baseband Output"


OUTPut:DIQ:CDEVice

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > OUTPut:DIQ:CDEVice
OUTPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q data output to the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information".

Return values:
<ConnState> | Defines whether a device is connected or not. 0 No device is connected. 1 A device is connected.
<DeviceName> | Device ID of the connected device
<SerialNumber> | Serial number of the connected device
<PortName> | Port name used by the connected device
<NotUsed> | to be ignored
<MaxTransferRate> | Maximum data transfer rate of the connected device in Hz
<ConnProtState> | State of the connection protocol which is used to identify the connected device. Not Started Has to be Started Started Passed Failed Done
<PRBSTestState> | State of the PRBS test. Not Started Has to be Started Started Passed Failed Done
<NotUsed> | to be ignored
<Placeholder> | for future use; currently "0"
Example: | OUTP:DIQ:CDEV? Result: 1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example: | See "Output via the Optional Digital Baseband Interface (R&S FSW-B17)".
Manual operation: | See "Output Settings Information" See "Connected Instrument"


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface".

For a programming example, see "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:FULLscale[:LEVel]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:TYPE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset".

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption".

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption".

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption".

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Using External Mixers

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers
Using External Mixers

The commands required to work with external mixers in a remote environment are described here. Note that these commands require the R&S FSW-B21 option to be installed and an external mixer to be connected to the front panel of the R&S FSW. In MSRA/MSRT mode, external mixers are not supported.

For details on working with external mixers see "Basics on External Mixers" .

Contents
  • Basic Settings
  • Mixer Settings
  • Conversion Loss Table Settings
  • Programming Example: Working with an External Mixer


Basic Settings

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Basic Settings
Basic Settings

The basic settings concern general usage of an external mixer.

List of Commands
[SENSe:]MIXer[:STATe]
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold


[SENSe:]MIXer[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer[:STATe]
[SENSe:]MIXer[:STATe] <State>

Activates or deactivates the use of a connected external mixer as input for the measurement. This command is only available if the R&S FSW-B21 option is installed and an external mixer is connected.

(See "How to Work with External Mixers" ).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX ON
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "External Mixer State"


[SENSe:]MIXer:BIAS:HIGH

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS:HIGH <BiasSetting>

This command defines the bias current for the high (second) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Manual operation: See "Bias Settings"


[SENSe:]MIXer:BIAS[:LOW]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:BIAS[:LOW] <BiasSetting>

This command defines the bias current for the low (first) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Bias Settings"


[SENSe:]MIXer:LOPower

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOPower <Level>

This command specifies the LO level of the external mixer's LO port.

Parameters:
<Level>
numeric value
Range: | 13.0 dBm to 17.0 dBm
Increment: | 0.1 dB
*RST: | 15.5 dBm
Example: MIX:LOP 16.0dBm
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "LO Level"


[SENSe:]MIXer:SIGNal

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:SIGNal
[SENSe:]MIXer:SIGNal <State>

This command specifies whether automatic signal detection is active or not.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Parameters:
<State>
OFF | ON | AUTO | ALL
OFF

No automatic signal detection is active.

ON

Automatic signal detection (Signal ID) is active.

AUTO

Automatic signal detection (Auto ID) is active.

ALL

Both automatic signal detection functions (Signal ID+Auto ID) are active.

*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Signal ID"
See "Auto ID"


[SENSe:]MIXer:THReshold

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:THReshold
[SENSe:]MIXer:THReshold <Value>

This command defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison (see [SENSe:​]MIXer:​SIGNal).

Parameters:
<Value>
<numeric value>
Range: | 0.1 dB to 100 dB
*RST: | 10 dB
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer"

Manual operation: See "Auto ID Threshold"


Mixer Settings

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings
Mixer Settings

The following commands are required to configure the band and specific mixer settings.

List of Commands
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]


[SENSe:]MIXer:FREQuency:HANDover

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:HANDover <Frequency>

This command defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency for each band can be selected freely within the overlapping frequency range.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Frequency> | numeric value
Example: | MIX ON Activates the external mixer. MIX:FREQ:HAND 78.0299GHz Sets the handover frequency to 78.0299 GHz.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Handover Freq."


[SENSe:]MIXer:FREQuency:STARt?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STARt?

This command queries the frequency at which the external mixer band starts.

Example: | MIX:FREQ:STAR? Queries the start frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:FREQuency:STOP?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:FREQuency:STOP?

This command queries the frequency at which the external mixer band stops.

Example: | MIX:FREQ:STOP? Queries the stop frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:HARMonic:BAND:PRESet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND:PRESet

This command restores the preset frequency ranges for the selected standard waveguide band.

Note:Changes to the band and mixer settings are maintained even after using the PRESET function. Use this command to restore the predefined band ranges.

Example: | MIX:HARM:BAND:PRES Presets the selected waveguide band.
Usage: | Event
Manual operation: | See "Preset Band"


[SENSe:]MIXer:HARMonic:BAND[:VALue]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:BAND[:VALue] <Band>

This command selects the external mixer band. The query returns the currently selected band.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Band> | KA | Q | U | V | E | W | F | D | G | Y | J | USER Standard waveguide band or user-defined band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Band"
Frequency ranges for pre-defined bands
Band | Frequency start [GHz] | Frequency stop [GHz]
KA (A) *) | 26.5 | 40.0
Q | 33.0 | 50.0
U | 40.0 | 60.0
V | 50.0 | 75.0
E | 60.0 | 90.0
W | 75.0 | 110.0
F | 90.0 | 140.0
D | 110.0 | 170.0
G | 140.0 | 220.0
J | 220.0 | 325.0
Y | 325.0 | 500.0
USER | 32.18 (default) | 68.22 (default)
*) The band formerly referred to as "A" is now named "KA".


[SENSe:]MIXer:HARMonic:HIGH:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH:STATe <State>

This command specifies whether a second (high) harmonic is to be used to cover the band's frequency range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX:HARM:HIGH:STAT ON
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Range 1/2"


[SENSe:]MIXer:HARMonic:HIGH[:VALue]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:HIGH[:VALue] <HarmOrder>

This command specifies the harmonic order to be used for the high (second) range.

Parameters:
<HarmOrder
numeric value
Range: 2 to 61 (USER band); for other bands: see band definition
Example: MIX:HARM:HIGH 2
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:HARMonic:TYPE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic:TYPE <OddEven>

This command specifies whether the harmonic order to be used should be odd, even, or both.

Which harmonics are supported depends on the mixer type.

Parameters:
<OddEven>
ODD | EVEN | EODD
*RST: EVEN
Example: MIX:HARM:TYPE ODD
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Type"


[SENSe:]MIXer:HARMonic[:LOW]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:HARMonic[:LOW] <HarmOrder>

This command specifies the harmonic order to be used for the low (first) range.

Parameters:
<HarmOrder>
numeric value
Range: | 2 to 61 (USER band); for other bands: see band definition
*RST: | 2 (for band F)
Example: MIX:HARM 3
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:LOSS:HIGH

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:HIGH <Average>

This command defines the average conversion loss to be used for the entire high (second) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS:HIGH 20dB
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe:HIGH

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH <FileName>

This command defines the file name of the conversion loss table to be used for the high (second) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL:HIGH 'MyCVLTable'
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe[:LOW]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS:TABLe[:LOW] <FileName>

This command defines the file name of the conversion loss table to be used for the low (first) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL 'mix_1_4' Specifies the conversion loss table mix_1_4.
Example: | See "Configuring a conversion loss table for a user-defined band"
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS[:LOW]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:LOSS[:LOW] <Average>

This command defines the average conversion loss to be used for the entire low (first) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS 20dB
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:PORTs

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:PORTs
[SENSe:]MIXer:PORTs <PortType>

This command specifies whether the mixer is a 2-port or 3-port type.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Mixer Type"


[SENSe:]MIXer:RFOVerrange[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:RFOVerrange[:STATe] <State>

If enabled, the band limits are extended beyond "RF Start" and "RF Stop" due to the capabilities of the used harmonics.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "RF Overrange"


Conversion Loss Table Settings

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings
Conversion Loss Table Settings

The following settings are required to configure and manage conversion loss tables.

List of Commands
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber


[SENSe:]CORRection:CVL:BAND

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BAND <Type>

This command defines the waveguide band for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Band>
K | A | KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Note: The band formerly referred to as "A" is now named "KA"; the input parameter "A" is still available and refers to the same band as "KA".

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

*RST: F (90 GHz - 140 GHz)
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BAND KA

Sets the band to KA (26.5 GHz - 40 GHz).

Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Band"


[SENSe:]CORRection:CVL:BIAS

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:BIAS <BiasSetting>

This command defines the bias setting to be used with the conversion loss table.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<BiasSetting>
numeric value
*RST: | 0.0 A
Default unit: | A
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BIAS 3A
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Write to <CVL table name>"
See "Bias"


[SENSe:]CORRection:CVL:CATAlog?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CATAlog?

This command queries all available conversion loss tables saved in the C:\r_s\instr\user\cvl\ directory on the instrument.

This command is only available with option B21 (External Mixer) installed.

Usage: Query only


[SENSe:]CORRection:CVL:CLEAr

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:CLEAr

This command deletes the selected conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:CLE
Usage: | Event
Manual operation: | See "Delete Table"


[SENSe:]CORRection:CVL:COMMent

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:COMMent <Text>

This command defines a comment for the conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Text> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:COMM 'Conversion loss table for FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Comment"


[SENSe:]CORRection:CVL:DATA

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:DATA <Freq>,<Level>

This command defines the reference values of the selected conversion loss tables. The values are entered as a set of frequency/level pairs. A maximum of 50 frequency/level pairs may be entered. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Freq> | numeric value The frequencies have to be sent in ascending order.
<Level> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:DATA 1MHZ,-30DB,2MHZ,-40DB
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Position/Value"


[SENSe:]CORRection:CVL:HARMonic

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:HARMonic <HarmOrder>

This command defines the harmonic order for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<HarmOrder>
numeric value
Range: 2 to 65
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:HARM 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]CORRection:CVL:MIXer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:MIXer <Type>

This command defines the mixer name in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Type> | string Name of mixer with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX 'FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer Name"


[SENSe:]CORRection:CVL:PORTs

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:PORTs <PortNo>

This command defines the mixer type in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:PORT 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Mixer Type"


[SENSe:]CORRection:CVL:SELect

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SELect <FileName>

This command selects the conversion loss table with the specified file name. If <file_name> is not available, a new conversion loss table is created.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<FileName> | '<File name>'
Example: | CORR:CVL:SEL 'LOSS_TAB_4'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "New Table" See "Edit Table" See "File Name"


[SENSe:]CORRection:CVL:SNUMber

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:CVL:SNUMber <SerialNo>

This command defines the serial number of the mixer for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<SerialNo> | Serial number with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX '123.4567'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer S/N"


Programming Example: Working with an External Mixer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Using External Mixers > Programming Example: Working with an External Mixer
Programming Example: Working with an External Mixer

This example demonstrates how to work with an external mixer in a remote environment. It is performed in the Spectrum application in the default layout configuration. Note that without a real input signal and connected mixer, this measurement will not return useful results.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//----------- Configuring basic mixer behavior -------------
//Set the LO level of the mixer's LO port to 15 dBm.
SENS:MIX:LOP 15dBm
//Set the bias current to -1 mA .
SENS:MIX:BIAS:LOW -1mA
//----------- Configuring the mixer and band settings -------------
//Use band "V" to full possible range extent for assigned harmonic (6).
SENS:MIX:HARM:BAND V
SENS:MIX:RFOV ON
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)
//Use a 3-port mixer type
SENS:MIX:PORT 3
//Split the frequency range into two ranges;
//range 1 covers 47.48 GHz GHz to 80 GHz; harmonic 6, average conv. loss of 20 dB
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:LOW  20dB
SENS:MIX:HARM:HIGH 8
SENS:MIX:LOSS:HIGH 30dB
//--------- Activating automatic signal identification functions -----------
//Activate both automatic signal identification functions.
SENS:MIX:SIGN ALL
//Use auto ID threshold of 8 dB.
SENS:MIX:THR 8dB

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data for the input signal without distortions
//(default screen configuration)
TRAC:DATA? TRACE3
Configuring a conversion loss table for a user-defined band
//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//--------------Configuring a new conversion loss table --------------
//Define cvl table for range 1 of band as described in previous example
// (extended V band)
SENS:CORR:CVL:SEL 'UserTable'
SENS:CORR:CVL:COMM 'User-defined conversion loss table for USER band'
SENS:CORR:CVL:BAND USER
SENS:CORR:CVL:HARM 6
SENS:CORR:CVL:BIAS -1mA
SENS:CORR:CVL:MIX 'FS_Z60'
SENS:CORR:CVL:SNUM '123.4567'
SENS:CORR:CVL:PORT 3
//Conversion loss is linear from 55 GHz to 75 GHz
SENS:CORR:CVL:DATA 55GHZ,-20DB,75GHZ,-30DB
//----------- Configuring the mixer and band settings -------------
//Use user-defined band and assign new cvl table.
SENS:MIX:HARM:BAND USER
//Define band by two ranges;
//range 1 covers 47.48 GHz to 80 GHz; harmonic 6, cvl table 'UserTable'
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:TABL:LOW 'UserTable'
SENS:MIX:HARM:HIGH 8

SENS:MIX:LOSS:HIGH 30dB
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data (default screen configuration)
TRAC:DATA? TRACe1


Setting up Probes

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


External Generator Control

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control
External Generator Control

External generator control commands are available if the R&S FSW External Generator Control option (R&S FSW-B10) is installed. For each measurement channel one external generator can be configured. To switch between different configurations define multiple measurement channels.

For more information on external generator control see "Basics on External Generator Control".

Contents
  • Measurement Configuration
  • Interface Configuration
  • Source Calibration
  • Programming Example for External Generator Control


Measurement Configuration

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration
Measurement Configuration

The following commands are required to activate external generator control and to configure a calibration measurement with an external tracking generator.

List of Commands
SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal[:STATe]
SOURce:POWer[:LEVel][:IMMediate]:OFFSet


SOURce:EXTernal:FREQuency

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency <Frequency>

This command defines a fixed source frequency for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Frequency>

Source frequency of the external generator.

*RST: 1100050000
Example:

SOUR:EXT:FREQ 10MHz

Manual operation: See "(Manual) Source Frequency"


SOURce:EXTernal:FREQuency:COUPling[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency:COUPling[:STATe] <State>

This command couples the frequency of the external generator output to the R&S FSW.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Default setting: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW; the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)

OFF | 0

The generator uses a single fixed frequency, defined by SOURce:​EXTernal:​FREQuency.

*RST: 1
Example: SOUR:EXT:FREQ:COUP ON
Example:

See "Programming Example for External Generator Control"

Manual operation: See "Source Frequency Coupling"


SOURce:EXTernal:FREQuency[:FACTor]:DENominator

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:DENominator <Value>

This command defines the denominator of the factor with which the analyzer frequency is multiplied in order to obtain the transmit frequency of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the multiplication factor such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Value>
<numeric value>
*RST: 1
Example: SOUR:EXT:FREQ:NUM 4"
"SOUR:EXT:FREQ:DEN 3"

Sets a multiplication factor of 4/3, i.e. the transmit frequency of the generator is 4/3 times the analyzer frequency.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:FREQuency[:FACTor]:NUMerator

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator <Value>

This command defines the numerator of the factor with which the analyzer frequency is multiplied in order to obtain the transmit frequency of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the multiplication factor such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Value>
<numeric value>
*RST: 1
Example: SOUR:EXT:FREQ:NUM 4"
"SOUR:EXT:FREQ:DEN 3"

Sets a multiplication factor of 4/3, i.e. the transmit frequency of the generator is 4/3 times the analyzer frequency.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:FREQuency:OFFSet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:FREQuency:OFFSet <Offset>

This command defines the frequency offset of the generator with reference to the analyzer frequency.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the offset such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Offset>
<numeric value>, specified in Hz, kHz, MHz or GHz, rounded to the nearest Hz
*RST: 0 Hz
Example: SOUR:EXT:FREQ:OFFS 10HZ

Sets an offset of the generator output frequency compared to the analyzer frequency of 10 Hz.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:POWer[:LEVel]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:POWer[:LEVel] <Level>

This command sets the output power of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<Level>
<numeric value>
*RST: -20 dBm
Example: SOUR:EXT:POW -30dBm

Sets the generator level to -30 dBm

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Source Power"


SOURce:EXTernal[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal[:STATe]
SOURce:EXTernal[:STATe] <State>

This command activates or deactivates the connected external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example for External Generator Control".

Manual operation: See "Source State"


SOURce:POWer[:LEVel][:IMMediate]:OFFSet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:POWer[:LEVel][:IMMediate]:OFFSet
SOURce:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

This command defines a level offset for the external generator level. Thus, for example, attenuators or amplifiers at the output of the external generator can be taken into account for the setting.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Offset>
Range: | -200 dB to +200 dB
*RST: | 0dB
Example: SOUR:POW:OFFS -10dB

Sets the level offset of the external generator to – 20 dBm.

Usage: SCPI confirmed
Manual operation: See "Source Offset"


Interface Configuration

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Interface Configuration
Interface Configuration

The following commands are required to configure the interface for the connection to the external generator.

List of Commands
SOURce:EXTernal:ROSCillator[:SOURce]
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess


SOURce:EXTernal:ROSCillator[:SOURce]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SOURce:EXTernal:ROSCillator[:SOURce]
SOURce:EXTernal:ROSCillator[:SOURce] <Source>

This command controls selection of the reference oscillator for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

If the external reference oscillator is selected, the reference signal must be connected to the rear panel of the instrument.

Parameters:
<Source>
INTernal

the internal reference is used

EXTernal

the external reference is used; if none is available, an error flag is displayed in the status bar

*RST: INT
Example: SOUR:EXT:ROSC EXT

Switches to external reference oscillator

Manual operation: See "Reference"


SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess <Number>

Changes the IEC/IEEE-bus address of the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Number>
Range: | 0 to 30
*RST: | 28
Example: SYST:COMM:GPIB:RDEV:GEN:ADDR 15
Example:

See "Programming Example for External Generator Control".

Manual operation: See "GPIB Address / TCP/IP Address"


SYSTem:COMMunicate:RDEVice:GENerator:INTerface

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:INTerface <Type>

Defines the interface used for the connection to the external generator.

Parameters:
<Type>
GPIB | TCPip
*RST: GPIB
Example: SYST:COMM:RDEV:GEN:INT TCP
Example:

See "Programming Example for External Generator Control".

Manual operation: See "Interface"


SYSTem:COMMunicate:RDEVice:GENerator:LINK

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:LINK <Type>

This command selects the link type of the external generator if the GPIB interface is used.

The difference between the two GPIB operating modes is the execution speed. While, during GPIB operation, each frequency to be set is transmitted to the generator separately, a whole frequency list can be programmed in one go if the TTL interface is also used. Frequency switching can then be performed per TTL handshake which results in considerable speed advantages.

Parameters:
<Type>
GPIB | TTL
GPIB

GPIB connection without TTL synchronization (for all generators of other manufacturers and some Rohde & Schwarz devices)

TTL

GPIB connection with TTL synchronization (if available; for most Rohde&Schwarz devices)

*RST: GPIB
Example: SYST:COMM:RDEV:GEN:LINK TTL

Selects GPIB + TTL interface for generator operation.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "TTL Handshake"


SYSTem:COMMunicate:RDEVice:GENerator:TYPE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:RDEVice:GENerator:TYPE <Type>

This command selects the type of external generator.

For a list of the available generator types see "Overview of Generators Supported by the R&S FSW-B10 Option".

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Name>
<Generator name as string value>
*RST: SMU02
Example: SYST:COMM:RDEV:GEN2:TYPE 'SME02'

Selects SME02 as generator 2

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Generator Type"


SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess <Address>

Configures the TCP/IP address for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Address>
TCP/IP address between 0.0.0.0 and 0.255.255.255
*RST: 0.0.0.0
Example: SYST:COMM:TCP:RDEV:GEN:ADDR 130.094.122.195
Manual operation: See "GPIB Address / TCP/IP Address"


Source Calibration

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Source Calibration
Source Calibration

The following commands are required to activate the calibration functions of the external tracking generator. However, they are only available if external generator control is active (see SOURce:​EXTernal[:​STATe]).

Remote commands exclusive to source calibration:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
[SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:METHod
[SENSe:]CORRection:RECall
[SENSe:]CORRection[:STATe]
[SENSe:]CORRection:TRANsducer:GENerator


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Source Calibration > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

The command defines the power value assigned to the reference position in the grid.

For external generator calibration measurements (requires External Generator Control option R&S FSW-B10), this command defines the power offset value assigned to the reference position.

Parameters:
<Value>
*RST: 0 dBm, coupled to reference level
Example: DISP:TRAC:Y:RVAL -20dBm

Sets the power value assigned to the reference position to -20 dBm

Manual operation: See "Reference Value"


[SENSe:]CORRection:COLLect[:ACQuire]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:COLLect[:ACQuire] <MeasType>

This command initiates a reference measurement (calibration). The reference measurement is the basis for the measurement normalization. The result depends on whether a reflection measurement or transmission measurement is performed (see [SENSe:​]CORRection:​METHod).

To obtain a correct reference measurement, a complete sweep with synchronization to the end of the sweep must have been carried out. This is only possible in the single sweep mode.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<MeasType> | THRough "TRANsmission" mode: calibration with direct connection between external generator and device input "REFLection" mode: calibration with short circuit at the input OPEN only allowed in "REFLection" mode: calibration with open input
Example: | INIT:CONT OFF Selects single sweep operation CORR:METH TRAN Selects a transmission measurement. CORR:COLL THR;*WAI Starts the measurement of reference data using direct connection between generator and device input and waits for the sweep end.
Example: | See "Programming Example for External Generator Control".
Usage: | Setting only SCPI confirmed
Manual operation: | See "Calibrate Reflection Short" See "Calibrate Reflection Open"


[SENSe:]CORRection:METHod

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:METHod
[SENSe:]CORRection:METHod

This command selects the type of measurement to be performed with the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:

REFLection

Selects reflection measurements.

TRANsmission

Selects transmission measurements.

*RST: TRANsmission
Example: CORR:METH TRAN

Sets the type of measurement to "transmission".

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Calibrate Transmission"
See "Calibrate Reflection Short"
See "Calibrate Reflection Open"


[SENSe:]CORRection:RECall

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:RECall
[SENSe:]CORRection:RECall

This command restores the measurement configuration used for calibration.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Example: | CORR:REC
Usage: | Event
Manual operation: | See "Recall"


[SENSe:]CORRection[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection[:STATe]
[SENSe:]CORRection[:STATe] <State>

This command turns correction of measurement results (normalization) on and off.

The command is available after you have created a reference trace for the selected measurement type with [SENSe:​]CORRection:​COLLect[:​ACQuire].

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CORR ON

Activates normalization.

Example:

See "Programming Example for External Generator Control".

Usage: SCPI confirmed
Manual operation: See "Source Calibration Normalize"


[SENSe:]CORRection:TRANsducer:GENerator

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:TRANsducer:GENerator
[SENSe:]CORRection:TRANsducer:GENerator <Name>

This command uses the normalized measurement data to generate a transducer factor with up to 1001 points. The trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under c:\r_s\instr\trd. The frequency points are allocated in equidistant steps between start and stop frequency.

The generated transducer factor can be further adapted using the commands described in "Working with Transducers" ).

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active and normalization is switched on.

Parameters:
<Name> | '<name>
Example: | CORR:TRAN:GEN 'SMU01' Creates the transducer file C:\r_s\instr\trd\SMU01.trd.
Usage: | SCPI confirmed
Manual operation: | See "Save As Trd Factor"


Programming Example for External Generator Control

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > External Generator Control > Programming Example for External Generator Control
Programming Example for External Generator Control

The following example demonstrates how to work with an external generator in a remote environment.

It assumes a signal generator of the type SMU04 is connected to the R&S FSW, including TTL synchronization, as described in "External Generator Connections".

//--------------Preparing the instrument -----------

//Reset the instrument
*RST

//Set the frequency span.
SENS:FREQ:STAR 10HZ
SENS:FREQ:STOP 1MHZ

//--------------Configuring the interface -----------

//Set the generator type to SMU04 with a frequency range of 100 kHz to 4GHz
SYST:COMM:RDEV:GEN:TYPE 'SMU04'

//Set the interface used to the GPIB address 28
SYST:COMM:RDEV:GEN:INT GPIB
SYST:COMM:GPIB:RDEV:GEN:ADDR 28

//Activate the use of TTL synchronization to optimize measurement speed
SYST:COMM:RDEV:GEN:LINK TTL

//Activate the use of the external reference frequency at 10 MHz on the generator
SOUR:EXT:ROSC EXT

//--------------Configuring the calibration measurement -----------

//Activate external generator control.
SOUR:EXT:STAT ON
//Set the generator output level to -10 dBm.
SOUR:EXT:POW -10DBM
//Set the frequency coupling to automatic
SOUR:EXT:FREQ:COUP:STAT ON

//--------------Configuring the generator frequency range -----------

//Define a series of frequencies (one for each sweep point) based on the current
//frequency at the RF input of the analyzer; the generator frequency is half the
//frequency of the analyzer, with an offset of 100 kHz;
// analyzer start:            10 Hz
// analyzer stop:             1 MHz
// analyzer span:             999.99 KHz
// generator frequency start: 100.005 KHz
// generator frequency stop:  600 KHz
// generator span:            499.995 KHz

SOUR:EXT:FREQ:FACT:NUM 1
SOUR:EXT:FREQ:FACT:DEN 2
SOUR:EXT:FREQ:OFFS 100KHZ

//--------------Performing the calibration measurement -----------

//Perform a transmission measurement with direct connection between the generator
//and the analyzer and wait till the end
SENS:CORR:METH TRAN
SENS:CORR:COLL:ACQ THR; *WAI

//--------------Retrieving the calibration trace results -----------

//Retrieve the measured frequencies (10 Hz - 600 kHz)
TRAC:DATA:X? TRACE1

//Retrieve the measured power levels; = 0 between 10 Hz and 100 kHz (below
//generator minimum frequency); nominal -5dBm as of 100 kHz;
TRAC:DATA? TRACE1

//--------------Normalizing the calibration trace results -----------

//Retrieve the normalized power levels (= power offsets from calibration results)
//Should be 0 for all sweep points directly after calibration
SENS:CORR:STAT ON
TRAC:DATA? TRACE1

//--------------Changing the display of the calibration results -----------
//Shift the reference line so the -5 dB level is displayed in the center
DISP:TRAC:Y:SCAL:RVAL -5DB
DISP:TRAC:Y:SCAL:RPOS 50PCT


Working with Power Sensors

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors
Working with Power Sensors

The following commands describe how to work with power sensors.

Contents
  • Configuring Power Sensors
  • Configuring Power Sensor Measurements
  • Triggering with Power Sensors


Configuring Power Sensors

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors
Configuring Power Sensors
List of Commands
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine


SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe] <State>

This command turns automatic assignment of a power sensor to the power sensor index on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: SYST:COMM:RDEV:PMET:CONF:AUTO OFF
Manual operation: See "Select"


SYSTem:COMMunicate:RDEVice:PMETer:COUNt?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?

This command queries the number of power sensors currently connected to the R&S FSW.

Parameters:
<NumberSensors> | Number of connected power sensors.
Example: | SYST:COMM:RDEV:PMET:COUN?
Usage: | Query only
Manual operation: | See "Select"


SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine <Placeholder>, <Type>, <Interface>, <SerialNo>

This command assigns the power sensor with the specified serial number to the selected power sensor index (configuration).

The query returns the power sensor type and serial number of the sensor assigned to the specified index.

Suffix: |
<p> | 1...4 Power sensor index
Setting parameters:
<Placeholder> | Currently not evaluated
<SerialNo> | Serial number of a connected power sensor
Query parameters:
<Type> | The power sensor type, e.g. "NRP-Z81".
<Interface> | Currently not evaluated
Return values:
<Placeholder> | Currently not used
<Type> | Detected power sensor type, e.g. "NRP-Z81".
<Interface> | Interface the power sensor is connected to; always "USB"
<SerialNo> | Serial number of the power sensor assigned to the specified index
Example: | SYST:COMM:RDEV:PMET2:DEF '','NRP-Z81','','123456' Assigns the power sensor with the serial number '123456' to the configuration "Power Sensor 2". SYST:COMM:RDEV:PMET2:DEF? Queries the sensor assigned to "Power Sensor 2". Result: '','NRP-Z81','USB','123456' The NRP-Z81 power sensor with the serial number '123456' is assigned to the "Power Sensor 2".
Manual operation: | See "Select"


Configuring Power Sensor Measurements

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements
Configuring Power Sensor Measurements
List of Commands
CALibration:PMETer<p>:ZERO:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative:STATe
FETCh:PMETer<p>?
READ:PMETer<p>?
[SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe]
UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer:RATio


CALibration:PMETer<p>:ZERO:AUTO ONCE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALibration:PMETer<p>:ZERO:AUTO ONCE
CALibration:PMETer<p>:ZERO:AUTO ONCE

This commands starts to zero the power sensor.

Note that you have to disconnect the signals from the power sensor input before you start to zero the power sensor. Otherwise, results are invalid.

Suffix: |
<p> | 1...4 Power sensor index
Parameters:
ONCE |
Example: | CAL:PMET2:ZERO:AUTO ONCE;*WAI Starts zeroing the power sensor 2 and delays the execution of further commands until zeroing is concluded.
Usage: | Event
Manual operation: | See "Zeroing Power Sensor"


CALCulate<n>:PMETer<p>:RELative[:MAGNitude]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude] <RefValue>

This command defines the reference value for relative measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<RefValue>
Range: | -200 dBm to 200 dBm
*RST: | 0
Example: CALC:PMET2:REL -30

Sets the reference value for relative measurements to -30 dBm for power sensor 2.

Manual operation: See "Reference Value"


CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE

This command sets the current measurement result as the reference level for relative measurements.

Suffix: |
<p> | 1...4 Power sensor index
Parameters:
ONCE |
Example: | CALC:PMET2:REL:AUTO ONCE Takes the current measurement value as reference value for relative measurements for power sensor 2.
Usage: | Event
Manual operation: | See "Setting the Reference Level from the Measurement (Meas->Ref)"


CALCulate<n>:PMETer<p>:RELative:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative:STATe
CALCulate<n>:PMETer<p>:RELative:STATe <State>

This command turns relative power sensor measurements on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:PMET2:REL:STAT ON

Activates the relative display of the measured value for power sensor 2.


FETCh:PMETer<p>?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > FETCh:PMETer<p>?
FETCh:PMETer<p>?

This command queries the results of power sensor measurements.

Suffix: |
<p> | 1...4 Power sensor index
Return values:
<Level> | Power level that has been measured by a power sensor. The unit is either dBm (absolute measurements) or dB (relative measurements).
Usage: | Query only


READ:PMETer<p>?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > READ:PMETer<p>?
READ:PMETer<p>?

This command initiates a power sensor measurement and queries the results.

Suffix: |
<p> | 1...4 Power sensor index
Usage: | Query only


[SENSe:]PMETer<p>:DCYCle[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:DCYCle[:STATe] <State>

This command turns the duty cycle correction on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:DCYC:STAT ON
Manual operation: See "Duty Cycle"


[SENSe:]PMETer<p>:DCYCle:VALue

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:DCYCle:VALue <Percentage>

This command defines the duty cycle for the correction of pulse signals.

The power sensor uses the duty cycle in combination with the mean power to calculate the power of the pulse.

Suffix:
<p>
1...4

Power sensor

Parameters:
<Percentage>
Range: | 0.001 to 99.999
*RST: | 99.999
Default unit: | %
Example: PMET2:DCYC:STAT ON

Activates the duty cycle correction.

PMET2:DCYC:VAL 0.5

Sets the correction value to 0.5%.

Manual operation: See "Duty Cycle"


[SENSe:]PMETer<p>:FREQuency

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency <Frequency>

This command defines the frequency of the power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Frequency>

The available value range is specified in the data sheet of the power sensor in use.

*RST: 50 MHz
Example: PMET2:FREQ 1GHZ

Sets the frequency of the power sensor to 1 GHz.

Manual operation: See "Frequency Manual"


[SENSe:]PMETer<p>:FREQuency:LINK

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:FREQuency:LINK <Coupling>

This command selects the frequency coupling for power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Coupling>
CENTer

Couples the frequency to the center frequency of the analyzer

MARKer1

Couples the frequency to the position of marker 1

OFF

Switches the frequency coupling off

*RST: CENTer
Example: PMET2:FREQ:LINK CENT

Couples the frequency to the center frequency of the analyzer

Manual operation: See "Frequency Coupling"


[SENSe:]PMETer<p>:MTIMe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe <Duration>

This command selects the duration of power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Duration>
SHORt | NORMal | LONG
*RST: NORMal
Example: PMET2:MTIM SHOR

Sets a short measurement duration for measurements of stationary high power signals for the selected power sensor.

Manual operation: See "Meas Time/Average"


[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt <NumberReadings>

This command sets the number of power readings included in the averaging process of power sensor measurements.

Extended averaging yields more stable results for power sensor measurements, especially for measurements on signals with a low power, because it minimizes the effects of noise.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<NumberReadings>

An average count of 0 or 1 performs one power reading.

Range: | 0 to 256
Increment: | binary steps (1, 2, 4, 8, ...)
Example: PMET2:MTIM:AVER ON

Activates manual averaging.

PMET2:MTIM:AVER:COUN 8

Sets the number of readings to 8.

Manual operation: See "Average Count (Number of Readings)"


[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe] <State>

This command turns averaging for power sensor measurements on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:MTIM:AVER ON

Activates manual averaging.

Manual operation: See "Meas Time/Average"


[SENSe:]PMETer<p>:ROFFset[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe] <State>

This command includes or excludes the reference level offset of the analyzer for power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | 1

Includes the reference level offset in the results.

OFF | 0

Ignores the reference level offset.

*RST: 1
Example:

PMET2:ROFF OFF

Takes no offset into account for the measured power.

Manual operation: See "Use Ref Lev Offset"


[SENSe:]PMETer<p>[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>[:STATe]
[SENSe:]PMETer<p>[:STATe] <State>

This command turns a power sensor on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET1 ON

Switches the power sensor measurements on.

Manual operation: See "State"
See "Select"


[SENSe:]PMETer<p>:UPDate[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:UPDate[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe] <State>

This command turns continuous update of power sensor measurements on and off.

If on, the results are update even if a single sweep is complete.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET1:UPD ON

The data from power sensor 1 is updated continuously.

Manual operation: See "Continuous Value Update"


UNIT<n>:PMETer<p>:POWer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer <Unit>

This command selects the unit for absolute power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Unit>
DBM | WATT | W
*RST: DBM
Example: UNIT:PMET:POW DBM
Manual operation: See "Unit/Scale"


UNIT<n>:PMETer<p>:POWer:RATio

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > UNIT<n>:PMETer<p>:POWer:RATio
UNIT<n>:PMETer<p>:POWer:RATio <Unit>

This command selects the unit for relative power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Unit>
DB | PCT
*RST: DB
Example: UNIT:PMET:POW:RAT DB
Manual operation: See "Unit/Scale"


Triggering with Power Sensors

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors
Triggering with Power Sensors
List of Commands
[SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger[:STATe]


[SENSe:]PMETer<p>:TRIGger:DTIMe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:DTIMe <Time>

This command defines the time period that the input signal has to stay below the IF power trigger level before the measurement starts.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Time>
Range: | 0 s to 1 s
Increment: | 100 ns
*RST: | 100 µs
Example: PMET2:TRIG:DTIMe 0.001


[SENSe:]PMETer<p>:TRIGger:HOLDoff

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HOLDoff <Holdoff>

This command defines the trigger holdoff for external power triggers.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Holdoff>

Time period that has to pass between the trigger event and the start of the measurement, in case another trigger event occurs.

Range: | 0 s to 1 s
Increment: | 100 ns
*RST: | 0 s
Example: PMET2:TRIG:HOLD 0.1

Sets the holdoff time of the trigger to 100 ms

Manual operation: See "Trigger Holdoff"


[SENSe:]PMETer<p>:TRIGger:HYSTeresis

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis for external power triggers.

The hysteresis in dB is the value the input signal must stay below the IF power trigger level in order to allow a trigger to start the measurement.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
Increment: | 1 dB
*RST: | 0 dB
Example: PMET2:TRIG:HYST 10

Sets the hysteresis of the trigger to 10 dB.

Manual operation: See "Hysteresis"


[SENSe:]PMETer<p>:TRIGger:LEVel

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:LEVel <Level>

This command defines the trigger level for external power triggers.

This command requires the use of an R&S NRP-Z81 power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Level>
-20 to +20 dBm
Range: | -20 dBm to 20 dBm
*RST: | -10 dBm
Example: PMET2:TRIG:LEV -10 dBm

Sets the level of the trigger

Manual operation: See "External Trigger Level"


[SENSe:]PMETer<p>:TRIGger:SLOPe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger:SLOPe <Edge>

This command selects the trigger condition for external power triggers.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Edge>
POSitive

The measurement starts in case the trigger signal shows a positive edge.

NEGative

The measurement starts in case the trigger signal shows a negative edge.

*RST: POSitive
Example: PMET2:TRIG:SLOP NEG
Manual operation: See "Slope"


[SENSe:]PMETer<p>:TRIGger[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger[:STATe]
[SENSe:]PMETer<p>:TRIGger[:STATe] <State>

This command turns the external power trigger on and off.

This command requires the use of an R&S NRP-Z81 power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:TRIG ON

Switches the external power trigger on

Manual operation: See "Using the power sensor as an external trigger"


Configuring the Outputs

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF[:SOURce]
OUTPut:IF:IFFRequency
OUTPut:IF:SBANd?


DIAGnostic:SERVice:NSOurce

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

For details see "Input from Noise Sources".

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF[:SOURce]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF[:SOURce]
OUTPut:IF[:SOURce] <Source>

Defines the type of signal available at the IF/VIDEO/DEMOD or IF OUT connector on the rear panel of the R&S FSW.

For restrictions and more information see "IF and Video Signal Output".

Parameters:
<Source>
IF

The measured IF value is available at the IF/VIDEO/DEMOD output connector.

The frequency at which the IF value is provided is defined using the OUTPut:​IF:​IFFRequency command.

IF2

The measured IF value is available at the IF OUT output connector at a frequency of 2 GHz and with a bandwidth of 2 GHz.

This parameter is only available for instrument models R&S FSW43/50/67.

VIDeo

The displayed video signal (i.e. the filtered and detected IF signal, 200mV) is available at the IF/VIDEO/DEMOD output connector.

This setting is required to provide demodulated audio frequencies at the output.

*RST: IF
Example: OUTP:IF VID

Selects the video signal for the IF/VIDEO/DEMOD output connector.

Manual operation: See "IF/VIDEO/DEMOD Output"


OUTPut:IF:IFFRequency

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

If the IF WIDE OUTPUT connector is used (TRACe:IQ:WBANd ON, see TRACe:​IQ:​WBANd[:​STATe]), this command is available as a query only. It returns the used IF output frequency which is defined automatically by the application according to the center frequency.

For more information see "IF and Video Signal Output".

Parameters:
<Frequency>
*RST: 50.0 MHz
Manual operation: See "IF (Wide) Out Frequency"


OUTPut:IF:SBANd?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:SBANd?
OUTPut:IF:SBANd?

This command queries the sideband provided at the IF OUT connector compared to the sideband of the RF signal. The sideband depends on the current center frequency.

This command is available only if the output is configured for IF2 (see OUTPut:​IF[:​SOURce]).

For more information and prerequisites see "IF 2 GHz Output".

Return values:
<SideBand> | NORMal The sideband at the output is identical to the RF signal. INVerted The sideband at the output is the inverted RF signal sideband.
Example: | OUTP:IF IF2 Activates output at the IF OUTPUT (2 GHZ) connector. OUTP:IF:SBAN? Queries the sideband provided at the connector.
Usage: | Query only
Manual operation: | See "IF/VIDEO/DEMOD Output"


Configuring the Vertical Axis (Amplitude, Scaling)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling)
Configuring the Vertical Axis (Amplitude, Scaling)

The following commands are required to configure the amplitude and vertical axis settings in a remote environment.

Contents
  • Amplitude Settings
  • Configuring the Attenuation
  • Configuring a Preamplifier
  • Scaling the Y-Axis


Amplitude Settings

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings
Amplitude Settings
Useful commands for amplitude configuration described elsewhere:
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude configuration:
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:UNIT:POWer
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet


CALCulate<n>:MARKer<m>:FUNCtion:REFerence

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:FUNCtion:REFerence

This command matches the reference level to the power level of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:REF Sets the reference level to the level of marker 2.
Usage: | Event
Manual operation: | See "Reference Level = Marker Level"


CALCulate<n>:UNIT:POWer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:UNIT:POWer
CALCulate<n>:UNIT:POWer <Unit>

This command selects the unit of the y-axis.

The unit applies to all measurement windows.

Parameters:
<Unit>
DBM | V | A | W | DBPW | WATT | DBUV | DBMV | VOLT | DBUA | AMPere
*RST: dBm
Example: CALC:UNIT:POW DBM

Sets the power unit to dBm.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Unit"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


Configuring the Attenuation

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring a Preamplifier

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier
Configuring a Preamplifier
List of Commands
INPut:GAIN:STATe
INPut:GAIN[:VALue]


INPut:GAIN:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Scaling the Y-Axis

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis
Scaling the Y-Axis
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y:SPACing


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Range"
See "Y-Axis Max"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE <Mode>

This command selects the type of scaling of the y-axis.

When the display update during remote control is off, this command has no immediate effect.

Parameters:
<Mode>
ABSolute

absolute scaling of the y-axis

RELative

relative scaling of the y-axis

*RST: ABSolute
Example: DISP:TRAC:Y:MODE REL
Manual operation: See "Scaling"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

For measurements with the external generator (R&S FSW-B10) the command defines the position of the reference value.

Parameters:
<Position>

0 PCT corresponds to the lower display border, 100% corresponds to the upper display border.

*RST: 100 PCT = frequency display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Position"
See "Ref Level Position"


DISPlay[:WINDow<n>]:TRACe:Y:SPACing

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing <ScalingType>

This command selects the scaling of the y-axis.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling in %.

LDB

Linear scaling in the specified unit.

PERCent

Linear scaling in %.

*RST: LOGarithmic
Example: DISP:TRAC:Y:SPAC LIN

Selects linear scaling in %.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Scaling"


Frequency

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Frequency
Frequency
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:CENTer
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


CALCulate<n>:MARKer<m>:FUNCtion:CENTer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Frequency > CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:FUNCtion:CENTer

This command matches the center frequency to the frequency of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:CENT Sets the center frequency to the frequency of marker 2.
Usage: | Event
Manual operation: | See "Center Frequency = Marker Frequency"


[SENSe:]FREQuency:CENTer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:OFFSet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Note: In MSRA/MSRT mode, the setting command is only available for the MSRA/MSRT Master. For MSRA/MSRT applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Triggering

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering
Triggering

The following remote commands are required to configure a triggered measurement in a remote environment. More details are described for manual operation in "Trigger Settings".

*OPC should be used after requesting data. This will hold off any subsequent changes to the selected trigger source, until after the sweep is completed and the data is returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output
  • Configuring I/Q Gating


Configuring the Triggering Conditions

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:BBPower:HOLDoff

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:DTIMe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>

For measurements in the frequency domain, the range is 0 s to 30 s.

For measurements in the time domain, the range is the negative sweep time to 30 s.

*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q data measurements.

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

In the I/Q Analyzer application only EXTernal1 is supported.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IFPower

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

For compatibility reasons, this command is also available for the "baseband power" trigger source when using the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


TRIGger[:SEQuence]:LEVel:IQPower

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance".

Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:RFPower

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:SLOPe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For all trigger sources except time you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

IFPower

Second intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17). For input from the Analog Baseband Interface (R&S FSW-B71), this parameter is interpreted as BBPower for compatibility reasons.

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

TIME

Time interval

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

PSEN

External power sensor

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance".

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Using the power sensor as an external trigger"
See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "Video"
See "IF Power/BB Power"
See "I/Q Power"
See "Digital I/Q"
See "RF Power"
See "Power Sensor"
See "Time"


TRIGger[:SEQuence]:TIME:RINTerval

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.

Manual operation: See "Trigger Level (Repetition interval)"


Configuring the Trigger Output

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Configuring I/Q Gating

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring I/Q Gating
Configuring I/Q Gating

Usually in spectrum analysis, measurements are based on a certain length of time called the gate area. With I/Q gating, you can define the gate area using the gate length, the distance between the capture periods and the number of periods. The gate length and the distance between the capture periods are specified in samples.

I/Q gating is only available using remote commands; manual configuration is not possible.

Using I/Q gating, the gate area can be defined using the following methods:

  • Edge triggered capturing
    After a trigger signal, the gate period is defined by a gate length and a gate distance. All data in the gate period is captured until the required number of samples has been captured.
  • Level triggered capturing
    After a trigger signal, all data is captured in which the gate signal is set to 1, which means it has exceeded a level. In this case, the gate signal can be generated by the IFP trigger, for example: each time the IFP level is exceeded, the IFP trigger signal is set to 1 and the samples in this area are captured as gate samples.

The number of complex samples to be captured prior to the trigger event can be selected (see TRACe:​IQ:​SET) for all available trigger sources, except for "Free Run".

List of Commands
TRACe:IQ:EGATe
TRACe:IQ:EGATe:GAP
TRACe:IQ:EGATe:LENGth
TRACe:IQ:EGATe:NOFgateperiods
TRACe:IQ:EGATe:TYPE


TRACe:IQ:EGATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring I/Q Gating > TRACe:IQ:EGATe
TRACe:IQ:EGATe <State>

This command turns gated measurements with the I/Q analyzer on and off.

Before you can use the command you have to turn on the I/Q analyzer and select an external or IF power trigger source.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: TRAC:IQ:EGAT ON
Example:

See "Basic I/Q Analysis with Improved Performance".


TRACe:IQ:EGATe:GAP

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring I/Q Gating > TRACe:IQ:EGATe:GAP
TRACe:IQ:EGATe:GAP <Samples>

This command defines the interval between several gate periods for gated measurements with the I/Q analyzer.

Parameters:
<Samples>
<numeric value>

Max = (440 MS * sample rate/200MHz) -1

pretrigger samples defined by TRACe:​IQ:​SET;

sample rate defined by TRACe:​IQ:​SRATe)

Range: | 1…Max (samples)
*RST: | 1
Example: TRAC:IQ:EGAT:GAP 2
Example:

See "Basic I/Q Analysis with Improved Performance".


TRACe:IQ:EGATe:LENGth

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring I/Q Gating > TRACe:IQ:EGATe:LENGth
TRACe:IQ:EGATe:LENGth <GateLength>

This command defines the gate length for gated measurements with the I/Q analyzer.

Defines the gate length in samples in edge mode. For details see "Configuring I/Q Gating".

Parameters:
<GateLength>
<numeric value>

Max = (440 MS * sample rate/200MHz) -1

pretrigger samples defined by TRACe:​IQ:​SET;

sample rate defined by TRACe:​IQ:​SRATe)

Range: | 1…Max (samples)
*RST: | 100
Example: TRAC:IQ:EGAT:LENG 2000
Example:

See "Basic I/Q Analysis with Improved Performance".


TRACe:IQ:EGATe:NOFgateperiods

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring I/Q Gating > TRACe:IQ:EGATe:NOFgateperiods
TRACe:IQ:EGATe:NOFgateperiods <Number>

This command defines the number of gate periods after the trigger signal for gated measurements with the I/Q analyzer.

Parameters:
<Number>
Range: | 1 to 1023
*RST: | 1
Example: TRAC:IQ:EGAT:NOF 2
Example:

See "Basic I/Q Analysis with Improved Performance".


TRACe:IQ:EGATe:TYPE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Triggering > Configuring I/Q Gating > TRACe:IQ:EGATe:TYPE
TRACe:IQ:EGATe:TYPE <Type>

This command selects the gate mode for gated measurements with the I/Q analyzer.

Note: The IF power trigger holdoff time is ignored if you are using the "Level" gate mode in combination with an IF Power trigger.

Parameters:
<Type>
LEVel
EDGE
*RST: EDGE
Example: TRAC:IQ:EGAT:TYPE LEV
Example:

See "Basic I/Q Analysis with Improved Performance".


Configuring Data Acquisition

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition
Configuring Data Acquisition

The following commands are required to capture data in the I/Q Analyzer.

MSRA/MSRT operating mode

Note that in MSRA/MSRT operating mode, configuring data acquisition is only possible for the MSRA/MSRT Master channel. In I/Q Analyzer application channels, these commands define the analysis interval. Be sure to select the correct measurement channel before using these commands.

For more commands related to the MSRA operating mode see "Configuring an Analysis Interval and Line (MSRA mode only)".

For more commands related to the MSRT operating mode see "Configuring an Analysis Interval and Line (MSRT mode only)".

Useful commands for I/Q data acquisition described elsewhere
  • [SENSe:​]SWEep:​COUNt
  • [SENSe:​]SWEep:​POINts
  • [SENSe:​]SWEep:​TIME
Remote commands exclusive to I/Q data acquisition
List of Commands
[SENSe:]IQ:BANDwidth|BWIDth:MODE
[SENSe:]IQ:BANDwidth|BWIDth:RESolution
[SENSe:]IQ:FFT:ALGorithm
[SENSe:]IQ:FFT:LENGth
[SENSe:]IQ:FFT:WINDow:LENGth
[SENSe:]IQ:FFT:WINDow:OVERlap
[SENSe:]IQ:FFT:WINDow:TYPE
[SENSe:]SWAPiq
TRACe:IQ:BWIDth
TRACe:IQ:DIQFilter
TRACe:IQ:RLENgth
TRACe:IQ:SET
TRACe:IQ:SRATe
TRACe:IQ:TPISample?
TRACe:IQ:WBANd[:STATe]
TRACe:IQ:WBANd:MBWIDTH


[SENSe:]IQ:BANDwidth|BWIDth:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]IQ:BANDwidth|BWIDth:MODE
[SENSe:]IQ:BANDwidth|BWIDth:MODE <Mode>

This command defines how the resolution bandwidth is determined.

Parameters:
<Mode>
AUTO | MANual | FFT
AUTO

(Default) The RBW is determined automatically depending on the sample rate and record length.

MANual

The user-defined RBW is used and the (FFT) window length (and possibly the sample rate) are adapted accordingly. The RBW is defined using the [SENSe:​]IQ:​BANDwidth|BWIDth:​RESolution command.

FFT

The RBW is determined by the FFT parameters.

*RST: AUTO
Example: IQ:BAND:MODE MAN

Switches to manual RBW mode.

IQ:BAND:RES 120000

Sets the RBW to 120 kHz.

Usage: SCPI confirmed
Manual operation: See "RBW"


[SENSe:]IQ:BANDwidth|BWIDth:RESolution

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]IQ:BANDwidth|BWIDth:RESolution
[SENSe:]IQ:BANDwidth|BWIDth:RESolution <Bandwidth>

This command defines the resolution bandwidth manually if [SENSe:​]IQ:​BANDwidth|BWIDth:​MODE is set to MAN.

Defines the resolution bandwidth. The available RBW values depend on the sample rate and record length.

For details see "Frequency Resolution of FFT Results - RBW".

Parameters:
<Bandwidth>
refer to data sheet
*RST: RBW: AUTO mode is used
Example: IQ:BAND:MODE MAN

Switches to manual RBW mode.

IQ:BAND:RES 120000

Sets the RBW to 120 kHz.

Usage: SCPI confirmed
Manual operation: See "RBW"


[SENSe:]IQ:FFT:ALGorithm

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:ALGorithm
[SENSe:]IQ:FFT:ALGorithm <Method>

Defines the FFT calculation method.

For more information see "Basics on FFT".

Parameters:
<Method>
SINGle

One FFT is calculated for the entire record length; if the FFT length is larger than the record length (see [SENSe:​]IQ:​FFT:​LENGth and TRACe:​IQ:​RLENgth), zeros are appended to the captured data.

AVERage

Several overlapping FFTs are calculated for each record; the results are averaged to determine the final FFT result for the record.

The user-defined window length and window overlap are used (see [SENSe:​]IQ:​FFT:​WINDow:​LENGth and [SENSe:​]IQ:​FFT:​WINDow:​OVERlap).

*RST: AVER
Example: IQ:FFT:ALG SING
Usage: SCPI confirmed
Manual operation: See "Transformation Algorithm"


[SENSe:]IQ:FFT:LENGth

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:LENGth
[SENSe:]IQ:FFT:LENGth <NoOfBins>

Defines the number of frequency points determined by each FFT calculation. The more points are used, the higher the resolution in the spectrum becomes, but the longer the calculation takes.

Parameters:
<NoOfBins>
integer value
Range: | 3 to 524288
*RST: | 4096
Example: IQ:FFT:LENG 2048
Usage: SCPI confirmed
Manual operation: See "FFT Length"


[SENSe:]IQ:FFT:WINDow:LENGth

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:WINDow:LENGth
[SENSe:]IQ:FFT:WINDow:LENGth <NoOfFFT>

Defines the number of samples to be included in a single FFT window when multiple FFT windows are used.

Parameters:
<NoOfFFT>
integer value
Range: | 3 to 1001
*RST: | 1001
Example: IQ:FFT:WIND:LENG 500
Usage: SCPI confirmed
Manual operation: See "Window Length"


[SENSe:]IQ:FFT:WINDow:OVERlap

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:WINDow:OVERlap
[SENSe:]IQ:FFT:WINDow:OVERlap <Rate>

Defines the part of a single FFT window that is re-calculated by the next FFT calculation.

Parameters:
<Rate>
double value

Percentage rate

Range: | 0 to 1
*RST: | 0.75
Example: IQ:FFT:WIND:OVER 0.5

Half of each window overlaps the previous window in FFT calculation.

Usage: SCPI confirmed
Manual operation: See "Window Overlap"


[SENSe:]IQ:FFT:WINDow:TYPE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]IQ:FFT:WINDow:TYPE
[SENSe:]IQ:FFT:WINDow:TYPE <Function>

In the I/Q Analyzer you can select one of several FFT window types.

Parameters:
<Function>
BLACkharris

Blackman-Harris

FLATtop

Flattop

GAUSsian

Gauss

RECTangular

Rectangular

P5

5-Term

*RST: FLAT
Example: IQ:FFT:WIND:TYPE GAUS
Usage: SCPI confirmed
Manual operation: See "Window Function"


[SENSe:]SWAPiq

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > [SENSe:]SWAPiq
[SENSe:]SWAPiq <State>

This command defines whether or not the recorded IQ pairs should be swapped (I<->Q) before being processed. Swapping I and Q inverts the sideband.

This is useful if the DUT interchanged the I and Q parts of the signal; then the R&S FSW can do the same to compensate for it.

For GSM measurements: Try this function if the TSC can not be found.

Parameters:
<State>
ON

I and Q signals are interchanged

Inverted sideband, Q+j*I

OFF

I and Q signals are not interchanged

Normal sideband, I+j*Q

*RST: OFF
Manual operation: See "Swap I/Q"


TRACe:IQ:BWIDth

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:BWIDth
TRACe:IQ:BWIDth

This command defines or queries the bandwidth of the resampling filter.

The bandwidth of the resampling filter depends on the sample rate.

Parameters:
<Bandwidth> | For details on the maximum bandwidth see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".
Example: | See "I/Q Analysis with Graphical Evaluation".
Example: | See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".
Example: | See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".
Manual operation: | See "Analysis Bandwidth"


TRACe:IQ:DIQFilter

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:DIQFilter
TRACe:IQ:DIQFilter <State>

This command is only available when using the Digital Baseband Interface (R&S FSW-B17).

By default, a decimation filter is used during data acquisition to reduce the sample rate to the value defined using TRACe:​IQ:​SRATe.

If the filter is bypassed, the sample rate is identical to the input sample rate configured for the Digital I/Q input source (see INPut:​DIQ:​SRATe).

Parameters:
<State>
ON | OFF
ON

The digital I/Q filter bypass is on, i.e. no filter or resampler is used during I/Q data acquisition.

OFF

The filter bypass is off, i.e. decimation filter and resampler are used during I/Q data acquisition.

*RST: OFF
Manual operation: See "Omitting the Digital Decimation Filter (No Filter)"


TRACe:IQ:RLENgth

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:RLENgth
TRACe:IQ:RLENgth <NoOfSamples>

This command sets the record length for the acquired I/Q data.

Increasing the record length also increases the measurement time.

Note: Alternatively, you can define the measurement time using the SENS:SWE:TIME command.

Parameters:
<NoOfSamples>

Number of samples to record.

See "Maximum record length for RF input".

For digital input via the Digital Baseband Interface (R&S FSW-B17) the valid number of samples is described in "Sample Rates and Bandwidths for Digital I/Q Data".

*RST: 1001
Example: TRAC:IQ:RLEN 256
Example:

See "I/Q Analysis with Graphical Evaluation".

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "Record Length"


TRACe:IQ:SET

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:SET
TRACe:IQ:SET NORM, 0, <SampleRate>, <TriggerMode>, <TriggerSlope>, <PretriggerSamp>, <NumberSamples>

This command sets up the R&S FSW for I/Q measurements.

If you do not use this command to set up I/Q measurements, the R&S FSW will use its current settings for I/Q measurements.

If the I/Q Analyzer has not been turned on previously, the command also switches to the I/Q Analyzer.

For more information on triggering measurements see "Trigger Settings". You can set the trigger level with TRIGger[:​SEQuence]:​LEVel:​IFPower. For details on trigger parameters see "Triggering".

Note: If you use the default settings with TRACe:​IQ:​DATA??, the following minimum buffer sizes for the response data are recommended:

ASCII format: 10 kBytes

4

Binary format: 2 kBytes

Parameters:
NORM

This value is always NORM.

0

This value is always 0.

<SampleRate>

Sample rate for the data acquisition.

Range: | 100 Hz to 10 GHz, continuously adjustable
*RST: | 32000000
<TriggerMode>

Selection of the trigger source used for the measurement.

IMMediate | EXTernal | EXT2 | EXT3 | IFPower

For IMM mode, gating is automatically deactivated.

*RST: IMM
<TriggerSlope>

Used trigger slope.

POSitive | NEGative
*RST: POS
<PretriggerSamp>

Defines the trigger offset in terms of pretrigger samples. Negative values correspond to a trigger delay.

This value also defines the interval between the trigger signal and the gate edge in samples.

Range: | -461373339 to 461373339
*RST: | 0
<NumberSamples>

Number of measurement values to record (including the pretrigger samples).

See "Maximum record length for RF input".

For digital input via the Digital Baseband Interface (R&S FSW-B17) the valid number of samples is described in "Sample Rates and Bandwidths for Digital I/Q Data".

*RST: 1001
Example: TRAC:IQ:SET NORM,0,32MHz,EXT,POS,0,2048

Reads 2048 I/Q-values starting at the trigger point.

sample rate = 32 MHz

trigger = External

slope = Positive

TRAC:IQ:SET NORM,0,4 MHz,EXT,POS,1024,512

Reads 512 I/Q-values from 1024 measurement points before the trigger point.

filter type = NORMAL

sample rate = 4 MHz

trigger = External

slope = Positive

Example:

See "Basic I/Q Analysis with Improved Performance".

Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (R&S FSW-B17)".

Manual operation: See "Record Length"


TRACe:IQ:SRATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:SRATe
TRACe:IQ:SRATe <SampleRate>

This command sets the final user sample rate for the acquired I/Q data. Thus, the user sample rate can be modified without affecting the actual data capturing settings on the R&S FSW.

Note: The smaller the user sample rate, the smaller the usable I/Q bandwidth, see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Parameters:
<SampleRate>

The valid sample rates are described in "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Range: | 100 Hz to 10 GHz continuously adjustable;
*RST: | 32 MHz
Example:

See "I/Q Analysis with Graphical Evaluation".

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Manual operation: See "Sample Rate"


TRACe:IQ:TPISample?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:TPISample?
TRACe:IQ:TPISample?

This command queries the time offset between the sample start and the trigger event (trigger point in sample = TPIS). Since the R&S FSW usually samples with a much higher sample rate than the specific application actually requires, the trigger point determined internally is much more precise than the one determined from the (downsampled) data in the application. Thus, the TPIS indicates the offset between the sample start and the actual trigger event.

This value can only be determined in triggered measurements using external or IFPower triggers, otherwise the value is 0.

This command is not available if the Digital Baseband Interface (R&S FSW-B17) is active and not for bandwidths > 80 MHz.

Example: | TRAC:IQ:TPIS? Result for a sample rate of 1 MHz: between 0 and 1/1 MHz, i.e. between 0 and 1 μs (the duration of 1 sample).
Usage: | Query only
Manual operation: | See "Trigger Offset"


TRACe:IQ:WBANd[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:WBANd[:STATe]
TRACe:IQ:WBANd[:STATe] <State>

This command determines whether the wideband provided by bandwidth extension options is used or not (if installed).

Parameters:
<State>
ON | OFF
ON

If enabled, installed bandwidth extension options can be used. They are activated for bandwidths > 80 MHz, if the bandwidth is not restricted by the TRACe:​IQ:​WBANd:​MBWIDTH command. Otherwise, the currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

This parameter corresponds to the "Auto" setting in manual operation (with TRACe:​IQ:​WBANd:​MBWIDTH 320 MHZ).

OFF

The bandwidth extension options R&S FSW-B500/-B320/-B160 are deactivated; the maximum analysis bandwidth is restricted to 80 MHz.

This parameter corresponds to the "80 MHz" setting in manual operation.

*RST: ON
Manual operation: See "Maximum Bandwidth"


TRACe:IQ:WBANd:MBWIDTH

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Configuring Data Acquisition > TRACe:IQ:WBANd:MBWIDTH
TRACe:IQ:WBANd:MBWIDTH <Limit>

Restricts the maximum analysis bandwidth.

Parameters:
<Limit>
80 MHz

Restricts the analysis bandwidth to a maximum of 80 MHz.

The bandwidth extension option R&S FSW-B160/-B320/-B500 is deactivated.

TRACe:​IQ:​WBANd[:​STATe] is set to OFF.

160 MHz

Restricts the analysis bandwidth to a maximum of 160 MHz. The bandwidth extension option R&S FSW-B320 is deactivated.

(Not available or required if bandwidth extension option R&S FSW-B500 is installed.)

TRACe:​IQ:​WBANd[:​STATe] is set to ON.

500 MHz | 320 MHz | MAX

All installed bandwidth extension options are activated. The currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

TRACe:​IQ:​WBANd[:​STATe] is set to ON.

*RST: | maximum available
Default unit: | Hz
Manual operation: See "Maximum Bandwidth"


Adjusting Settings Automatically

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically
Adjusting Settings Automatically

The commands required to adjust settings automatically in a remote environment are described here. The tasks for manual operation are described in "Adjusting Settings Automatically".

MSRA operating mode

In MSRA operating mode, settings related to data acquisition (measurement time, hysteresis) can only be adjusted automatically in the MSRA Master, not in the MSRA applications.

List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:ALL

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Reference level
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:CONFigure:TRIG

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:CONFigure:TRIG <State>

Defines the behaviour of the measurement when adjusting a setting automatically (using SENS:ADJ:LEV ON, for example).

See "Adjusting settings automatically during triggered measurements".

Parameters:
<State>
ON | 1

The measurement for automatic adjustment waits for the trigger.

OFF | 0

The measurement for automatic adjustment is performed immediately, without waiting for a trigger.

*RST: 1


[SENSe:]ADJust:FREQuency

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:FREQuency
[SENSe:]ADJust:FREQuency

This command sets the center frequency to the highest signal level in the current frequency range.

Example: | ADJ:FREQ
Usage: | Event
Manual operation: | See "Adjusting the Center Frequency Automatically (Auto Freq)"


[SENSe:]ADJust:LEVel

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring I/Q Analyzer Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Configuring the Result Display

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display
Configuring the Result Display

The commands required to configure the screen display in a remote environment are described here.

Contents
  • General Window Commands
  • Working with Windows in the Display


General Window Commands

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Magnitude"
See "Spectrum"
See "I/Q-Vector"
See "Real/Imag (I/Q)"
See "Marker Table"
See "Marker Peak List"
<WindowType> parameter values for IQ Analyzer application
Parameter value | Window type
FREQ | Spectrum
MAGN | Magnitude
MTABle | Marker table
PEAKlist | Marker peak list
RIMAG | Real/Imag (I/Q)
VECT | I/Q Vector


LAYout:CATalog[:WINDow]?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Capturing Data and Performing Sweeps

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps
Capturing Data and Performing Sweeps
Different measurement procedures

Two different procedures to capture I/Q data remotely are available:

  • Measurement and result query with one command (see TRACe:​IQ:​DATA?)
    This method causes the least delay between measurement and output of the result data, but it requires the control computer to wait actively for the response data.
  • Setting up the instrument, starting the measurement via INIT and querying the result list at the end of the measurement (see TRACe:​IQ:​DATA:​MEMory?)
    With this method, the control computer can be used for other activities during the measurement. However, the additional time needed for synchronization via service request must be taken into account.
MSRA/MSRT operating mode

Note that in MSRA/MSRT operating mode, capturing data is only possible for the MSRA Master channel. In I/Q Analyzer application channels, the sweep configuration commands define the analysis interval. Be sure to select the correct measurement channel before using these commands.

List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:POINts
[SENSe:]SWEep:TIME
SYSTem:SEQuencer


ABORt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


INITiate:SEQuencer:REFResh[:ALL]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


[SENSe:]SWEep:COUNt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:COUNt:CURRent?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > [SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:CURRent?

This query returns the current number of started sweeps or measurements. This command is only available if a sweep count value is defined and the instrument is in single sweep mode.

Example: | SWE:COUNt 64 Sets sweep count to 64 INIT:CONT OFF Switches to single sweep mode INIT Starts a sweep (without waiting for the sweep end!) SWE:COUN:CURR? Queries the number of started sweeps
Usage: | Query only


[SENSe:]SWEep:POINts

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > [SENSe:]SWEep:POINts
[SENSe:]SWEep:POINts <SweepPoints>

This command defines the number of measurement points analyzed during a sweep.

Parameters:
<SweepPoints>
Range: | 101 to 100001
*RST: | 1001
Example: SWE:POIN 251
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep Points"


[SENSe:]SWEep:TIME

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > [SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME <Time>

This command defines the sweep (or: data capture) time.

Parameters:
<Time>
refer to data sheet
*RST: depends on current settings (determined automatically)
Example: SWE:TIME 10s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Meas Time"


SYSTem:SEQuencer

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Capturing Data and Performing Sweeps > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


I/Q Analysis

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis
I/Q Analysis

General result analysis settings concerning the trace, markers, etc. can be configured using the following commands. They are identical to the analysis functions in the Spectrum application except for the special marker functions.

Contents
  • Configuring Standard Traces
  • Using Markers
  • Zooming into the Display
  • Configuring an Analysis Interval and Line (MSRA mode only)
  • Configuring an Analysis Interval and Line (MSRT mode only)


Configuring Standard Traces

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces
Configuring Standard Traces
Useful commands for trace configuration described elsewhere
  • DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]
Remote commands exclusive to trace configuration
List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
[SENSe:]AVERage<n>:TYPE
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
TRACe<n>:COPY
[SENSe:]AVERage:COUNt
TRACe:IQ:AVERage:COUNt
[SENSe:]AVERage<n>[:STATe<t>]
TRACe:IQ:AVERage[:STATe]


DISPlay[:WINDow<n>]:TRACe<t>:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous <State>

This command turns an automatic reset of a trace on and off after a parameter has changed.

The reset works for trace modes min hold, max hold and average.

Note that the command has no effect if critical parameters like the span have been changed to avoid invalid measurement results

Parameters:
<State>
ON

The automatic reset is off.

OFF

The automatic reset is on.

*RST: OFF
Example: DISP:WIND:TRAC3:MODE:HCON ON

Switches off the reset function.

Manual operation: See "Hold"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


[SENSe:]AVERage<n>:TYPE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > [SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>:TYPE <Mode>

This command selects the trace averaging mode.

Parameters:
<Mode>
VIDeo

The logarithmic power values are averaged.

LINear

The power values are averaged before they are converted to logarithmic values.

POWer

The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit.

*RST: VIDeo
Example: AVER:TYPE LIN

Switches to linear average calculation.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Average Mode"


[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion] <Detector>

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector" .

Parameters:
<Detector>
APEak

Autopeak

NEGative

Negative peak

POSitive

Positive peak

QPEak

Quasipeak (CISPR filter only)

SAMPle

First value detected per trace point

RMS

RMS value

AVERage

Average

CAVerage

CISPR Average (CISPR filter only)

CRMS

CISPR RMS (CISPR filter only)

*RST: APEak (I/Q Analyzer: RMS)

For more information see "Mapping Samples to Sweep Points with the Trace Detector" .

Example: DET POS

Sets the detector to "positive peak".

Example:

See "Programming Example: EMI Measurement" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Detector"


[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO <State>

This command couples and decouples the detector to the trace mode.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DET:AUTO OFF

The selection of the detector is not coupled to the trace mode.

Manual operation: See "Detector"


TRACe<n>:COPY

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > TRACe<n>:COPY
TRACe<n>:COPY <TraceNumber>, <TraceNumber>

This command copies data from one trace to another.

Parameters:
<TraceNumber>, <TraceNumber>
TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6

The first parameter is the destination trace, the second parameter is the source.

Example: TRAC:COPY TRACe1,TRACe2

Copies the data from trace 2 to trace 1.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


[SENSe:]AVERage:COUNt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>
TRACe:IQ:AVERage:COUNt <NumberSets>

This command defines the number of I/Q data sets that the averaging is based on.

Parameters:
<NumberSets>
Range: | 0 to 32767
*RST: | 0
Example: TRAC:IQ ON

Switches on acquisition of I/Q data.

TRAC:IQ:AVER ON

Enables averaging of the I/Q measurement data

TRAC:IQ:AVER:COUN 10

Selects averaging over 10 data sets

TRAC:IQ:DATA?

Starts the measurement and reads out the averaged data.

Example:

See "I/Q Analysis with Graphical Evaluation".

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".


[SENSe:]AVERage<n>[:STATe<t>]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring Standard Traces > [SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>[:STATe<t>] <State>
TRACe:IQ:AVERage[:STATe] <State>

This command turns averaging of the I/Q data on and off.

Before you can use the command you have to turn the I/Q data acquisition on with TRACe:​IQ[:​STATe].

If averaging is on, the maximum amount of I/Q data that can be recorded is 512kS (524288 samples).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: TRAC:IQ ON

Switches on acquisition of I/Q data.

TRAC:IQ:AVER ON

Enables averaging of the I/Q measurement data.

TRAC:IQ:AVER:COUN 10

Selects averaging over 10 data sets.

TRAC:IQ:DATA?

Starts the measurement and reads out the averaged data.

Example:

See "I/Q Analysis with Graphical Evaluation".

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".


Using Markers

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers
Using Markers

The following commands are available for marker settings and functions in the I/Q Analyzer application.

For "I/Q Vector" displays markers are not available.

Contents
  • Setting Up Individual Markers
  • General Marker Settings
  • Configuring and Performing a Marker Search
  • Positioning the Marker
  • Marker Peak Lists


Setting Up Individual Markers

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers
Setting Up Individual Markers

The following commands define the position of markers in the diagram.

List of Commands
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X


CALCulate<n>:DELTamarker:AOFF

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:LINK

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:LINK <State>

This command links delta marker <m> to marker 1.

If you change the horizontal position (x-value) of marker 1, delta marker <m> changes its horizontal position to the same value.

Tip: to link any marker to a different marker than marker 1, use the CALCulate<n>:​DELTamarker<m1>:​LINK:​TO:​MARKer<m2> or CALCulate<n>:​MARKer<m1>:​LINK:​TO:​MARKer<m2> commands.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2:LINK ON
Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2> <State>

This command links delta marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, delta marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT4:LINK:TO:MARK2 ON

Links the delta marker 4 to the marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker:MODE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker:MODE <Mode>

This command defines whether the position of a delta marker is provided as an absolute value or relative to a reference marker. Note that when the position of a delta marker is queried, the result is always an absolute value (see CALCulate<n>:​DELTamarker<m>:​X)!

Parameters:
<Mode>
ABSolute

Delta marker position in absolute terms.

RELative

Delta marker position in relation to a reference marker.

*RST: RELative
Example: CALC:DELT:MODE ABS

Absolute delta marker position.


CALCulate<n>:DELTamarker<m>:MREF

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

The reference may be another marker or the fixed reference.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference. FIXed Selects the fixed reference as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Marker Position (X-value)"


CALCulate<n>:MARKer<m>:AOFF

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2> <State>

This command links normal marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK4:LINK:TO:MARK2 ON

Links marker 4 to marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:MARKer<m>[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> |
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker Peak List"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker Position (X-value)"


General Marker Settings

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > General Marker Settings
General Marker Settings

The following commands control general marker functionality.

See also "Fixed Reference Marker Settings"

Remote commands exclusive to general marker functionality
List of Commands
DISPlay:MTABle
CALCulate:MARKer:X:SSIZe


DISPlay:MTABle

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


CALCulate:MARKer:X:SSIZe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > General Marker Settings > CALCulate:MARKer:X:SSIZe
CALCulate:MARKer:X:SSIZe <StepSize>

This command selects the marker step size mode.

The step size defines the distance the marker moves when you move it with the rotary knob. It therefore takes effect in manual operation only.

Parameters:
<StepSize>
STANdard

the marker moves from one pixel to the next

POINts

the marker moves from one sweep point to the next

*RST: POINts
Example: CALC:MARK:X:SSIZ STAN

Sets the marker step size to one pixel.

Manual operation: See "Marker Stepsize"


Configuring and Performing a Marker Search

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search
Configuring and Performing a Marker Search

The following commands control the marker search.

List of Commands
CALCulate:MARKer:LOEXclude
CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:SEARch
CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:THReshold
CALCulate:THReshold:STATe


CALCulate:MARKer:LOEXclude

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:LOEXclude
CALCulate:MARKer:LOEXclude <State>

This command turns the suppression of the local oscillator during automatic marker positioning on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:MARK:LOEX ON


CALCulate<n>:MARKer:PEXCursion

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:PEXCursion <Excursion>

This command defines the peak excursion.

The peak excursion sets the requirements for a peak to be detected during a peak search.

The unit depends on the measurement.

Application/Result display | Unit
Spectrum | dB
Manual operation: See "Peak Excursion"


CALCulate<n>:MARKer:SEARch

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate<n>:MARKer:SEARch
CALCulate<n>:MARKer:SEARch <MarkRealImag>

This command selects the trace type a marker search is performed on.

Parameters:
<MarkRealImag>
REAL

Marker search functions are performed on the real trace of the "I/Q" measurement.

IMAG

Marker search functions are performed on the imaginary trace of the "I/Q" measurement.

MAGN

Marker search functions are performed on the magnitude of the I and Q data.

*RST: REAL
Example: CALC4:MARK:SEAR IMAG
Example:

See "I/Q Analysis with Graphical Evaluation".

Manual operation: See "Branch for Peak Search"


CALCulate:MARKer:X:SLIMits[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SLIMits[:STATe] <State>

This command turns marker search limits on and off.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:X:SLIM ON

Switches on search limitation.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"
See "Deactivating All Search Limits"


CALCulate:MARKer:X:SLIMits:LEFT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:LEFT <SearchLimit>

This command defines the left limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<SearchLimit>

The value range depends on the frequency range or sweep time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: left diagram border
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:LEFT 10MHz

Sets the left limit of the search range to 10 MHz.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"


CALCulate:MARKer:X:SLIMits:RIGHT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:RIGHT <SearchLimit>

This command defines the right limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<Limit>

The value range depends on the frequency range or sweep time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: right diagram border
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:RIGH 20MHz

Sets the right limit of the search range to 20 MHz.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"


CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe] <State>

This command adjusts the marker search range to the zoom area.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:X:SLIM:ZOOM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:RIGH 20MHz

Sets the right limit of the search range to 20 MHz.

Manual operation: See "Using Zoom Limits"


CALCulate:THReshold

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate:THReshold
CALCulate:THReshold <Level>

This command defines a threshold level for the marker peak search.

Parameters:
<Level>
Numeric value. The value range and unit are variable.
*RST: -120 dBm
Example: CALC:THR -82DBM

Sets the threshold value to -82 dBm.

Manual operation: See "Search Threshold"


CALCulate:THReshold:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Configuring and Performing a Marker Search > CALCulate:THReshold:STATe
CALCulate:THReshold:STATe <State>

This command turns a threshold for the marker peak search on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:THR:STAT ON

Switches on the threshold line.

Manual operation: See "Deactivating All Search Limits"


Positioning the Marker

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker
Positioning the Marker

This chapter contains remote commands necessary to position the marker on a trace.

Contents
  • Positioning Normal Markers
  • Positioning Delta Markers


Positioning Normal Markers

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers
Positioning Normal Markers

The following commands position markers on the trace.

List of Commands
CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:MAXimum:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:AUTO <State>

This command turns an automatic marker peak search for a trace maximum on and off. The R&S FSW performs the peak search after each sweep.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:MAX:AUTO ON

Activates the automatic peak search function for marker 1 at the end of each particular sweep.


CALCulate<n>:MARKer<m>:MAXimum:LEFT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:AUTO

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:AUTO <State>

This command turns an automatic marker peak search for a trace minimum on and off. The R&S FSW performs the peak search after each sweep.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:MIN:AUTO ON

Activates the automatic minimum value search function for marker 1 at the end of each particular sweep.


CALCulate<n>:MARKer<m>:MINimum:LEFT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Positioning Delta Markers

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers
Positioning Delta Markers

The following commands position delta markers on the trace.

List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Marker Peak Lists

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists
Marker Peak Lists
Useful commands for peak lists described elsewhere
  • CALCulate<n>:​MARKer:​PEXCursion
  • MMEMory:​STORe:​PEAK
Remote commands exclusive to peak lists
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe] <State>

This command turns labels for peaks found during a peak search on and off.

The labels correspond to the marker number in the marker peak list.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:MARK:FUNC:FPE:ANN:LAB:STAT OFF

Removes the peak labels from the diagram

Manual operation: See "Displaying Marker Numbers"


CALCulate:MARKer:FUNCtion:FPEaks:COUNt?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?

This command queries the number of peaks that have been found during a peak search.

The actual number of peaks that have been found may differ from the number of peaks you have set to be found because of the peak excursion.

Return values:
<NumberOfPeaks> |
Example: | CALC:MARK:FUNC:FPE:COUN? Queries the number of peaks.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate] <Peaks>

This command initiates a peak search.

Parameters:
<Peaks>

This parameter defines the number of peaks to find during the search.

Note that the actual number of peaks found during the search also depends on the peak excursion you have set with CALCulate<n>:​MARKer:​PEXCursion.

Range: 1 to 200
Example: CALC:MARK:PEXC 5

Defines a peak excursion of 5 dB, i.e. peaks must be at least 5 dB apart to be detected as a peak.

CALC:MARK:FUNC:FPE 10

Initiates a search for 10 peaks on the current trace.


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE <MaxNoPeaks>

This command defines the maximum number of peaks that the R&S FSW looks for during a peak search.

Parameters:
<MaxNoPeaks>

Maximum number of peaks to be determined.

Range: | 1 to 200
*RST: | 50
Example: CALC:MARK:FUNC:FPE:LIST:SIZE 10

The marker peak list will contain a maximum of 10 peaks.

Manual operation: See "Maximum Number of Peaks"


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT <SortMode>

This command selects the order in which the results of a peak search are returned.

Parameters:
<SortMode>
X

Sorts the peaks according to increasing position on the x-axis.

Y

Sorts the peaks according to decreasing position on the y-axis.

*RST: X
Example: CALC:MARK:FUNC:FPE:SORT Y

Sets the sort mode to decreasing y values

Manual operation: See "Sort Mode"


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT <State>

This command turns a peak search on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:FPE:STAT ON

Activates marker peak search

Manual operation: See "Peak List State"


CALCulate:MARKer:FUNCtion:FPEeaks:X?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:X?

This command queries the position of the peaks on the x-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the x-axis. The unit depends on the measurement.
Usage: | Query only


CALCulate:MARKer:FUNCtion:FPEeaks:Y?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Using Markers > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?

This command queries the position of the peaks on the y-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the y-axis. The unit depends on the measurement.
Usage: | Query only


Zooming into the Display

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Configuring an Analysis Interval and Line (MSRA mode only)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRA mode only)
Configuring an Analysis Interval and Line (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRA applications.

For the I/Q Analyzer application, the commands to define tha analysis interval are the same as those used to define the actual data acquisition (see "Configuring Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

Useful commands for configuring the analysis interval described elsewhere:
  • TRACe:​IQ:​SRATe
  • TRACe:​IQ:​BWIDth
  • TRACe:​IQ:​RLENgth
  • [SENSe:​]SWEep:​TIME
Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
INITiate:REFResh
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:MSRA:ALINe[:VALue]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:MSRA:WINDow<n>:IVAL?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


INITiate:REFResh

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA/MSRT mode, not the MSRA/MSRT Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

The application channel must be selected before this command can be executed (see INSTrument[:​SELect]).

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event


[SENSe:]MSRA:CAPTure:OFFSet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Configuring an Analysis Interval and Line (MSRT mode only)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRT mode only)
Configuring an Analysis Interval and Line (MSRT mode only)

In MSRT operating mode, only the MSRT Master actually captures data; the MSRT applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRT applications.

For the I/Q Analyzer application, the commands to define the analysis interval are the same as those used to define the actual data acquisition (see "Configuring Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the I/Q Analyzer.

Useful commands related to MSRT mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRT applications

The following commands are only available for MSRT application channels:

List of Commands
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
[SENSe:]RTMS:CAPTure:OFFSet


CALCulate:RTMS:ALINe:SHOW

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRT applications and the MSRT Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:RTMS:ALINe[:VALue]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRT applications and the MSRT Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time (pretrigger + posttrigger) of the MSRT measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:RTMS:WINDow<n>:IVAL?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:RTMS:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRT View or MSRT Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]RTMS:CAPTure:OFFSet

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > I/Q Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > [SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]RTMS:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRT mode, not for the MSRT Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | - [pretrigger time] to min (posttrigger time; sweep time)
*RST: | 0
Manual operation: See "Capture Offset"


Retrieving Results

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results
Retrieving Results

The following commands can be used to retrieve the results of the I/Q Analyzer measurement.

Storing large amounts of I/Q data
When storing large amounts of I/Q data to a file, consider the following tips to improve performance:
  • If capturing and storing the I/Q data is the main goal of the measurement and evaluation functions are not required, use the basic I/Q data acquisition mode (see TRACe:​IQ[:​STATe]).
  • Use a HiSlip or raw socket connection to export the data from the R&S FSW to a PC.
  • Export the data in binary format rather than ASCII format (see "Formats for Returned Values: ASCII Format and Binary Format").
  • Use the "Compatible" or "IQPair" data mode (see "Reference: Format Description for I/Q Data Files").
  • If only an extract of the available data is relevant, use the TRACe<n>[:​DATA]:​MEMory? command to store only the required section of data.
Contents
  • Retrieving Captured I/Q Data
  • Retrieving I/Q Trace Data
  • Retrieving Marker and Peak Search Results


Retrieving Captured I/Q Data

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Captured I/Q Data
Retrieving Captured I/Q Data

The captured I/Q data is output in the form of a list, three different formats can be selected for this list (see TRACe:​IQ:​DATA:​FORMat).

For details on formats refer to "Reference: Format Description for I/Q Data Files".

List of Commands
TRACe:IQ:DATA?
TRACe:IQ:DATA:FORMat
TRACe:IQ:DATA:MEMory?


TRACe:IQ:DATA?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Captured I/Q Data > TRACe:IQ:DATA?
TRACe:IQ:DATA?

This command queries the captured data from measurements with the I/Q Analyzer.

To get the results, the command also initiates a measurement with the current settings of the R&S FSW.

Note: Using the command with the *RST values for the TRACe:​IQ:​SET command, the following minimum buffer sizes for the response data are recommended: ASCII format 10 kBytes, binary format: 2 kBytes

Return values:
<Results>

Measured voltage for I and Q component for each sample that has been captured during the measurement.

For analog baseband input in real baseband mode, the results for the irrelevant component are all 0.

For more information see "I/Q Processing Modes".

The number of samples depends on TRACe:​IQ:​SET. In ASCII format, the number of results is 2* the number of samples.

The data format depends on FORMat[:​DATA].

Default unit: V
Example: TRAC:IQ:STAT ON

Enables acquisition of I/Q data

TRAC:IQ:SET NORM,10MHz,32MHz,EXT,POS,0,4096

Measurement configuration:

Sample Rate = 32 MHz

Trigger Source = External

Trigger Slope = Positive

Pretrigger Samples = 0

Number of Samples = 4096

FORMat REAL,32

Selects format of response data

TRAC:IQ:DATA?

Starts measurement and reads results

Example:

See "Basic I/Q Analysis with Improved Performance".

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Usage: Query only


TRACe:IQ:DATA:FORMat

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Captured I/Q Data > TRACe:IQ:DATA:FORMat
TRACe:IQ:DATA:FORMat <Format>

This command selects the order of the I/Q data.

For details see "Reference: Format Description for I/Q Data Files".

Parameters:
<Format>
COMPatible | IQBLock | IQPair
COMPatible

I and Q values are separated and collected in blocks: A block (512k) of I values is followed by a block (512k) of Q values, followed by a block of I values, followed by a block of Q values etc.

(I,I,I,I,Q,Q,Q,Q,I,I,I,I,Q,Q,Q,Q...)

IQBLock

First all I-values are listed, then the Q-values

(I,I,I,I,I,I,...Q,Q,Q,Q,Q,Q)

IQPair

One pair of I/Q values after the other is listed

(I,Q,I,Q,I,Q...).

*RST: IQBL
Example:

See "I/Q Analysis with Graphical Evaluation".

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".


TRACe:IQ:DATA:MEMory?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Captured I/Q Data > TRACe:IQ:DATA:MEMory?
TRACe:IQ:DATA:MEMory? [<OffsetSamples>,<NoOfSamples>]

This command queries the I/Q data currently stored in the memory of the R&S FSW.

By default, the command returns all I/Q data in the memory. You can, however, narrow down the amount of data that the command returns using the optional parameters.

By default, the amount of available data depends on TRACe:​IQ:​SET.

Parameters:
<OffsetSamples>

Selects an offset at which the output of data should start in relation to the first data. If omitted, all captured samples are output, starting with the first sample.

Range: | 0 to <# of samples> – 1, with <# of samples> being the maximum number of captured values
*RST: | 0
<NoOfSamples>

Number of samples you want to query, beginning at the offset you have defined. If omitted, all captured samples (starting at offset) are output.

Range: | 1 to <# of samples> - <offset samples> with <# of samples> maximum number of captured values
*RST: | <# of samples>
Return values:
<IQData>

Measured value pair (I,Q) for each sample that has been recorded.

The data format depends on FORMat[:​DATA].

Default unit: V
Example: TRAC:IQ:STAT ON

Enables acquisition of I/Q data

TRAC:IQ:SET NORM,10MHz,32MHz,EXT,POS,100,4096

Measurement configuration:

Sample Rate = 32 MHz

Trigger Source = External

Trigger Slope = Positive

Pretrigger Samples = 100

Number of Samples = 4096

INIT;*WAI

Starts measurement and wait for sync

FORMat REAL,32

Determines output format

To read the results:

TRAC:IQ:DATA:MEM?

Reads all 4096 I/Q data

TRAC:IQ:DATA:MEM? 0,2048

Reads 2048 I/Q data starting at the beginning of data acquisition

TRAC:IQ:DATA:MEM? 2048,1024

Reads 1024 I/Q data from half of the recorded data

TRAC:IQ:DATA:MEM? 100,512

Reads 512 I/Q data starting at the trigger point (<Pretrigger Samples> was 100)

Example:

See "I/Q Analysis with Graphical Evaluation".

Example:

See "Basic I/Q Analysis with Improved Performance".

Usage: Query only


Retrieving I/Q Trace Data

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving I/Q Trace Data
Retrieving I/Q Trace Data

In addition to the raw captured I/Q data, the results from I/Q analysis as shown in the result displays can also be retrieved.

List of Commands
FORMat[:DATA]
FORMat:DEXPort:DSEParator
TRACe<n>[:DATA]?
TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:X?


FORMat[:DATA]

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving I/Q Trace Data > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Usage: SCPI confirmed


FORMat:DEXPort:DSEParator

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving I/Q Trace Data > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Exporting the Peak List"
See "Decimal Separator"


TRACe<n>[:DATA]?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving I/Q Trace Data > TRACe<n>[:DATA]?
TRACe<n>[:DATA]?? <ResultType>

This command queries current trace data and measurement results.

The data format depends on FORMat[:​DATA].

Query parameters:
<ResultType>

Selects the type of result to be returned.

TRACE1 | ... | TRACE6

Returns the trace data for the corresponding trace.

Return values:
<TraceData>

Returns the sweep point values as shown in the result display.

If you are measuring with the auto peak detector, the command returns positive peak values only.

For the Magnitude and Spectrum result displays in the I/Q Analyzer application, this command returns the magnitude of the I and Q values (I+jQ) for each sweep point (=1001 values).

For the Real/Imag (I/Q) result display, the command returns first the real parts for each trace point, then the imaginary parts (I1,...,I1001, Q1,...,Q1001).

For the I/Q Vector result display, the I and Q values for each trace point are returned (1001 pairs of I and Q values).

For analog baseband input in real baseband processing mode (I or Q only), only the positive spectrum is returned. The values for the missing component in the Real/Imag (I/Q) and the I/Q vector result displays are all 0.

Example: TRAC? TRACE3

Queries the data of trace 3.

Example:

See "Programming Example: Performing a Basic Frequency Sweep"

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)".

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)".

Example:

See "Example: SEM Measurement" .

Example:

See "Programming Example" .

Usage: SCPI confirmed
Manual operation: See "Magnitude"
See "Spectrum"
See "I/Q-Vector"
See "Real/Imag (I/Q)"


TRACe<n>[:DATA]:MEMory?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving I/Q Trace Data > TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:MEMory? <Trace>,<OffsSwPoint>,<NoOfSwPoints>

This command queries the previously captured trace data for the specified trace from the memory. As an offset and number of sweep points to be retrieved can be specified, the trace data can be retrieved in smaller portions, making the command faster than the TRAC:DATA? command. This is useful if only specific parts of the trace data are of interest.

If no parameters are specified with the command, the entire trace data is retrieved; in this case, the command is identical to TRAC:DATA? TRACE1

Query parameters:
<Trace> | TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6
<OffsSwPoint> | The offset in sweep points related to the start of the measurement at which data retrieval is to start.
<NoOfSwPoints> | Number of sweep points to be retrieved from the trace.
Example: | TRAC:DATA:MEM? TRACE1,25,100 Retrieves 100 sweep points from trace 1, starting at sweep point 25.
Usage: | Query only


TRACe<n>[:DATA]:X?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving I/Q Trace Data > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <TraceNumber>

This command queries the horizontal trace data for each sweep point in the specified window, for example the frequency in frequency domain or the time in time domain measurements.

This is especially useful for traces with non-equidistant x-values, e.g. for SEM or Spurious Emissions measurements.

Query parameters:
<TraceNumber> | Trace number. TRACE1 | ... | TRACE6
Example: | TRAC3:X? TRACE1 Returns the x-values for trace 1 in window 3.
Usage: | Query only


Retrieving Marker and Peak Search Results

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Marker and Peak Search Results
Retrieving Marker and Peak Search Results

The following commands are required to retrieve the results of markers and peak searches.

List of Commands
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:MARKer<m>:Y?
MMEMory:STORe:LIST


CALCulate:MARKer:FUNCtion:FPEeaks:X?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Marker and Peak Search Results > CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:X?

This command queries the position of the peaks on the x-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the x-axis. The unit depends on the measurement.
Usage: | Query only


CALCulate:MARKer:FUNCtion:FPEeaks:Y?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Marker and Peak Search Results > CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?

This command queries the position of the peaks on the y-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the y-axis. The unit depends on the measurement.
Usage: | Query only


CALCulate<n>:DELTamarker<m>:Y?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Marker and Peak Search Results > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:MARKer<m>:Y?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Marker and Peak Search Results > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position. The unit is variable and depends on the one you have currently set. In the Real/Imag (I/Q) result display of the I/Q Analyzer, the command returns the real part first, then the imaginary part.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2. In I/Q Analyzer application, for "Real/Imag (I/Q)", for example: 1.852719887E-011,0
Usage: | Query only
Manual operation: | See "Marker Table" See "Marker Peak List" See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


MMEMory:STORe:LIST

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Retrieving Results > Retrieving Marker and Peak Search Results > MMEMory:STORe:LIST
MMEMory:STORe:LIST <FileName>

This command exports the SEM and spurious emission list evaluation to a file.

The file format is *.dat.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:LIST 'test' Stores the current list evaluation results in the test.dat file.


Importing and Exporting I/Q Data and Results

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Importing and Exporting I/Q Data and Results
Importing and Exporting I/Q Data and Results

Alternatively to capturing I/Q data by the I/Q Analyzer itself, stored I/Q data from previous measurements or other applications can be imported to the I/Q Analyzer. Furthermore, I/Q data processed in the I/Q Analyzer can be stored to a file for further evaluation in other applications.

I/Q data can only be exported in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

List of Commands
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe


MMEMory:LOAD:IQ:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Importing and Exporting I/Q Data and Results > MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:IQ:STATe 1,<FileName>

This command restores I/Q data from a file.

The file extension is *.iq.tar.

Parameters:
<FileName> | String containing the path and name of the source file.
Example: | MMEM:LOAD:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Loads IQ data from the specified file.
Usage: | Setting only
Manual operation: | See "I/Q Import"


MMEMory:STORe:IQ:COMMent

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:COMMent <Comment>

This command adds a comment to a file that contains I/Q data.

Parameters:
<Comment> | String containing the comment.
Example: | MMEM:STOR:IQ:COMM 'Device test 1b' Creates a description for the export file. MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores I/Q data and the comment to the specified file.
Manual operation: | See "I/Q Export"


MMEMory:STORe:IQ:STATe

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:STATe
MMEMory:STORe:IQ:STATe 1, <FileName>

This command writes the captured I/Q data to a file.

The file extension is *.iq.tar. By default, the contents of the file are in 32-bit floating point format.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
1 |
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores the captured I/Q data to the specified file.
Manual operation: | See "I/Q Export"


Querying the Status Registers

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers
Querying the Status Registers

The R&S FSW-I/Q Analyzer uses the standard status registers of the R&S FSW.

The following status registers of the R&S FSW status reporting system are used by the Digital Baseband Interface (R&S FSW-B17). The commands required to query the status registers specific to the Digital Baseband Interface (R&S FSW-B17) are described with the registers.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

Status registers used by the Digital Baseband Interface (R&S FSW-B17)
Contents
  • STATus:QUEStionable:SYNC Register
  • STATus:QUEStionable:DIQ Register


STATus:QUEStionable:SYNC Register

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:SYNC Register
STATus:QUEStionable:SYNC Register

This register contains information about the state of the I/Q data acquisition. This register is used with option Digital Baseband Interface (R&S FSW-B17).

The status of the STATus:QUESTionable:SYNC register is indicated in bit 11 of the STATus:QUESTionable register.

You can read out the state of the register with STATus:​QUEStionable:​SYNC:​CONDition? and STATus:​QUEStionable:​SYNC[:​EVENt]?.

Bit No. | Meaning
0-7 | not used
8 | I/Q data acquisition error This bit is set if an error occurs during I/Q data acquisition because the input sample rates or number of samples between the signal source and the R&S FSW do not match. See also "Error Messages".
9-14 | not used
15 | This bit is always set to 0.
List of Commands
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?


STATus:QUEStionable:SYNC:CONDition?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:CONDition? <ChannelName>

This command reads out the CONDition section of the status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:SYNC:ENABle

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:NTRansition

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:PTRansition

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC:PTRansition <BitDefinition>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC[:EVENt]?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:SYNC Register > STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:SYNC[:EVENt]? <ChannelName>

This command reads out the EVENt section of the status register.

The command also deletes the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:DIQ Register

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:DIQ Register
STATus:QUEStionable:DIQ Register

This register contains information about the state of the digital I/Q input and output. This register is available with option Digital Baseband Interface (R&S FSW-B17)Digital Baseband Interface (R&S FSW-B17).

The status of the STATus:QUESTionable:DIQ register is indicated in bit 14 of the STATus:QUESTionable register.

You can read out the state of the register with STATus:​QUEStionable:​DIQ:​CONDition? and STATus:​QUEStionable:​DIQ[:​EVENt]?.

For more information on the Digital Baseband Interface (R&S FSW-B17) see " Processing Data from the Digital Baseband Interface (R&S FSW-B17)".

Bit No.

Meaning

0

Digital I/Q Input Device connected

This bit is set if a device is recognized and connected to the Digital Baseband Interface of the analyzer.

1

Digital I/Q Input Connection Protocol in progress

This bit is set while the connection between analyzer and digital baseband data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

2

Digital I/Q Input Connection Protocol error

This bit is set if an error occurred during establishing of the connect between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

3

Digital I/Q Input PLL unlocked

This bit is set if the PLL of the Digital I/Q input is out of lock due to missing or unstable clock provided by the connected Digital I/Q TX device. To solve the problem the Digital I/Q connection has to be newly initialized after the clock has been restored.

4

Digital I/Q Input DATA Error

This bit is set if the data from the Digital I/Q input module is erroneous. Possible reasons:

  • Bit errors in the data transmission. The bit will only be set if an error occurred at the current measurement.
  • Protocol or data header errors. May occurred at data synchronization problems or vast transmission errors. The bit will be set constantly and all data will be erroneous. To solve the problem the Digital I/Q connection has to be newly initialized.

NOTE: If this error is indicated repeatedly either the Digital I/Q LVDS connection cable or the receiving or transmitting device might be defect.

5

not used

6

Digital I/Q Input FIFO Overload

This bit is set if the sample rate on the connected instrument is higher than the input sample rate setting on the R&S FSW. Possible solution:

  • Reduce the sample rate on the connected instrument
  • Increase the input sample rate setting on the R&S FSW

7

not used

8

Digital I/Q Output Device connected

This bit is set if a device is recognized and connected to the Digital I/Q Output.

9

Digital I/Q Output Connection Protocol in progress

This bit is set while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

10

Digital I/Q Output Connection Protocol error

This bit is set if an error occurred while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

11

Digital I/Q Output FIFO Overload

This bit is set if an overload of the Digital I/Q Output FIFO occurred. This happens if the output data rate is higher than the maximal data rate of the connected instrument. Reduce the sample rate to solve the problem.

12-14

not used

15

This bit is always set to 0.

List of Commands
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?


STATus:QUEStionable:DIQ:CONDition?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:CONDition? <ChannelName>

This command reads out the CONDition section of the STATus:QUEStionable:DIQ:CONDition status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ:COND?
Usage: | Query only


STATus:QUEStionable:DIQ:ENABle

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<SumBit>
Range: 0 to 65535
Usage: SCPI confirmed


STATus:QUEStionable:DIQ:NTRansition

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ:PTRansition

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ:PTRansition <BitDefinition>,<ChannelName>

This command controls the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ[:EVENt]?

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Querying the Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]? <ChannelName>

This command queries the contents of the "EVENt" section of the STATus:QUEStionable:DIQ register for IQ measurements.

Readout deletes the contents of the "EVENt" section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ?
Usage: | Query only


Programming Examples

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Programming Examples
Programming Examples

The following programming examples demonstrate how to capture I/Q data and perform I/Q data analysis using the I/Q Analyzer in a remote environment.

Optional interfaces for I/Q data input are also demonstrated in the I/Q Analyzer.

Contents
  • I/Q Analysis with Graphical Evaluation
  • Basic I/Q Analysis with Improved Performance
  • Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)
  • Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (R&S FSW-B17)
  • Output via the Optional Digital Baseband Interface (R&S FSW-B17)
  • Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)


I/Q Analysis with Graphical Evaluation

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Programming Examples > I/Q Analysis with Graphical Evaluation
I/Q Analysis with Graphical Evaluation

This example demonstrates how to configure and perform a basic I/Q data acquisition and analyze the data using the I/Q Analyzer in a remote environment.

//--------------Activating the I/Q Analyzer application ---------------------
*RST
//Reset the instrument
INST:CRE IQ,'IQANALYZER'
//Creates a new measurement channel named 'IQANALYZER'.
INIT:CONT OFF
//Switches to single sweep mode

//--------------Configuring Data Acquisition-------------
TRAC:IQ:SRAT 32MHZ
//Defines the sample rate.
TRAC:IQ:RLEN 1000
//Sets the record length (number of samples to capture) to 1000 samples.
TRAC:IQ:BWID?
//Queries the bandwidth of the resampling filter, determined by the sample rate
FORM:DATA REAL,32
//Formats the data as 32-byte real values.
TRAC:IQ:DATA:FORM IQP
//Lists all I values first, then all Q values in the trace results.

//--------------Configuring the Trace--------------------
TRAC:IQ:AVER ON
//Defines averaging for the I/Q trace.
TRAC:IQ:AVER:COUN 10
//Defines an average over 10 sweeps.

DISP:TRAC1:MODE WRIT
DISP:TRAC2:MODE MAXH
DISP:TRAC3:MODE MINH
//Changes the trace modes.

//--------------Performing the Measurement---------------------
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results----------------------------

TRAC:DATA? TRACE1
TRAC:DATA? TRACE2
TRAC:DATA? TRACE3
//Returns the magnitude for each sweep point

LAY:REPL:WIND '1',RIMAG
//Changes the result display to Real/Imag (I/Q)

CALC:MARK:SEAR MAGN
//Configures searches to search both I and Q branches.
CALC:MARK:Y?
//Queries the result of the peak search on both branches.

TRAC:IQ:DATA:MEM? 0,500
//Returns the first 500 samples of the stored I/Q data for the measurement.
//For each sample, first the I-value, then the Q-value is listed.

TRAC:IQ:DATA:MEM? 500,500
//Returns the second half of the 1000 captured sample values.


Basic I/Q Analysis with Improved Performance

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Programming Examples > Basic I/Q Analysis with Improved Performance
Basic I/Q Analysis with Improved Performance

This example demonstrates how to configure and perform a basic I/Q data acquisition and analyze the data using the I/Q Analyzer in a remote environment.

//--------------Activating the I/Q Analyzer application ---------------------
*RST
//Reset the instrument

INIT:CONT OFF
//Switches to single sweep mode
TRACE:IQ ON
//Switches the operating mode of the current measurement channel to I/Q Analyzer
//while retaining the relevant parameters from the Spectrum mode.

//--------------Configuring Data Acquisition-------------
TRACE:IQ:SET NORM,0,32000000,IQP,POS,0,1000
//Configures the sample rate as 32 MHz, IQP trigger, positive trigger slope,
//no pretrigger samples, 1000 samples to capture
FORM REAL,32
//The data is formatted as real values.

//--------------Configuring I/Q Gating--------------------------
TRAC:IQ:EGAT ON
//Turns on gated measurement.
TRAC:IQ:EGAT:TYPE LEV
//Select the level gate type.
TRAC:IQ:EGAT:LENG 20
//Sets the gate length to 20 samples.
TRAC:IQ:EGAT:GAP 20
//Sets the interval between gate periods to 20 samples.
TRAC:IQ:EGAT:NOF 2
//Sets the number of gate periods after the trigger signal to 2.
TRIG:SOUR IQP
//Defines the magnitude of the sampled I/Q data to be used as a trigger.
TRIG:LEV:IQP -30dbm
//Sets the trigger level.

//---------------Performing the Measurement and Retrieving Results--------------
TRAC:IQ:DATA?; *WAI;
//Performs a measurement and returns the RF input voltage at each sample point
//(first 1000 I-values, then 1000 Q-values).

TRAC:IQ:DATA:MEM? 0,500
//Returns the first 500 samples of the stored trace data for the measurement.
//For each sample, first the I-value, then the Q-value is listed.

TRAC:IQ:DATA:MEM? 500,500
//Returns the second half of the 1000 captured sample values.


Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Programming Examples > Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)
Data Acquisition via the Optional Digital Baseband Interface (R&S FSW-B17)

This example demonstrates how to capture I/Q data via the optional Digital Baseband Interface (R&S FSW-B17) using the I/Q Analyzer in a remote environment.

//--------------Activating the I/Q Analyzer application ---------------------
*RST
//Reset the instrument
INST:CRE IQ,'IQANALYZER'
//Creates a new measurement channel named 'IQANALYZER'.
INIT:CONT OFF
//Switches to single sweep mode

//--------------Activating the Digital Baseband Interface-------------
INP:SEL DIQ
//Selects the digital baseband interface as the input source
INP:DIQ:CDEV?
//Queries the detected information for the connected instrument
INP:DIQ:SRAT:AUTO ON
//Sets the input sample rate to the rate of the connected instrument automatically
INP:DIQ:RANG:UPP 2 V
//Sets the level for value "1" to 2 V.
INP:DIQ:RANG:COUP ON
//Adjusts the reference level to the full scale level automatically (after every change)

//--------------Configuring Data Acquisition-------------
TRIG:SOUR BBP
TRIG:SEQ:LEV:BBP -20
//Trigger on baseband power of -20 dBm.
TRAC:IQ:SRAT 32MHZ
//Defines the sample rate.
TRAC:IQ:RLEN 1000
//Sets the record length (number of samples to capture) to 1000 samples.
TRAC:IQ:BWID?
//Queries the bandwidth of the resampling filter, determined by the sample rate.
FORM:DATA REAL,32
//Formats the data as 32-byte real values.
TRAC:IQ:DATA:FORM IQP
//Lists all I values first, then all Q values in the trace results.

//--------------Configuring the Trace--------------------
TRAC:IQ:AVER ON
//Defines averaging for the I/Q trace.
TRAC:IQ:AVER:COUN 10
//Defines an average over 10 sweeps.

DISP:TRAC1:MODE WRIT
DISP:TRAC2:MODE MAXH
DISP:TRAC3:MODE MINH
//Changes the trace modes.

//--------------Performing the Measurement---------------------
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results----------------------------

TRAC:DATA? TRACE1
TRAC:DATA? TRACE2
TRAC:DATA? TRACE3
//Returns the magnitude for each sweep point


Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (R&S FSW-B17)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Programming Examples > Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (R&S FSW-B17)
Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (R&S FSW-B17)

In the following example, an RF signal is measured at the RF input and then output as digital I/Q data via the Digital Baseband Interface, which requires R&S FSW option B17.

The following signal is to be measured:

Signal parameters for programming example
carrier frequency | 5 GHz
peak power | -10 dBm
bandwidth | 22 MHz

Note: For a bandwidth of 22 MHz, a sampe rate of 27.5 MHz is required.

Required I/Q data acquisition parameters for TRAC:IQ:SET command
Filter type | Normal
Sample Rate | 27.5 MHz
Trigger Source | External
Trigger Slope | Positive
Pretrigger Samples | 0
Number of Samples | 1000
//----------Preparing the instrument------------------------
*RST
//Sets the instrument to a defined default status

//------------Configuring the measurement-----------------------------

FREQ:CENT 5GHz
//Sets the center frequency to 5 GHz
DISP:TRAC1:Y:RLEV -10dBm
//Sets the reference level to -10 dBm
TRACE:IQ:STATE ON
//Enables acquisition of I/Q data
TRAC:IQ:SET NORM,50MHz,27.5MHz,EXT,POS,0,1000
//Configures the measurement. Only the sample rate and trigger source settings
//are relevant to the digital baseband interface. The other parameters can be set
//to their default values as listed above.
OUTPUT:DIQ ON
//Enables digital I/Q data output interface

//------------Performing the measurement-----------------------------

INIT:IMM
//    Starts data acquisition and transmission to the output connector


Output via the Optional Digital Baseband Interface (R&S FSW-B17)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Programming Examples > Output via the Optional Digital Baseband Interface (R&S FSW-B17)
Output via the Optional Digital Baseband Interface (R&S FSW-B17)

This example demonstrates how to output I/Q data to a connected instrument via the optional Digital Baseband Interface (R&S FSW-B17) using the I/Q Analyzer in a remote environment. The data to output is taken from the measurement described in "I/Q Analysis with Graphical Evaluation".

//--------------Activating the I/Q Analyzer application ---------------------
*RST
//Reset the instrument
INST:CRE IQ,'IQANALYZER'
//Creates a new measurement channel named 'IQANALYZER'.
INIT:CONT OFF
//Switches to single sweep mode

//--------------Configuring Data Acquisition-------------
TRAC:IQ:SRAT 32MHZ
//Defines the sample rate.
TRAC:IQ:RLEN 1000
//Sets the record length (number of samples to capture) to 1000 samples.
TRAC:IQ:BWID?
//Queries the bandwidth of the resampling filter, determined by the sample rate.
FORM:DATA REAL,32
//Formats the data as 32-byte real values.
TRAC:IQ:DATA:FORM IQP
//Lists all I values first, then all Q values in the trace results.

//--------------Configuring the Traces--------------------
TRAC:IQ:AVER ON
//Defines averaging for the I/Q trace.
TRAC:IQ:AVER:COUN 10
//Defines an average over 10 sweeps.

DISP:TRAC1:MODE WRIT
DISP:TRAC2:MODE MAXH
DISP:TRAC3:MODE MINH
//Changes the trace modes.

//--------------Configuring output--------------------
OUTP:DIQ ON
OUTP:DIQ:CDEV?
//Activates the digital baseband interface for output and queries the
//detected information of the connected instrument

//--------------Performing the Measurement---------------------
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.
//The results are simultaneously sent to the output connector.


Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)

I/Q Analyzer > Remote Commands to Perform Measurements with I/Q Data > Programming Examples > Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)
Data Acquisition via the Optional Analog Baseband Interface (R&S FSW-B71)

This example demonstrates how to capture I/Q data via the optional Analog Baseband Interface (R&S FSW-B71) using the I/Q Analyzer in a remote environment. As an input signal, a differential probe is assumed to be connected to the R&S FSW.

//--------------Activating the I/Q Analyzer application ---------------------
*RST
//Reset the instrument
INST:CRE IQ,'IQANALYZER'
//Creates a new measurement channel named 'IQANALYZER'.
INIT:CONT OFF
//Switches to single sweep mode

//--------------Activating the Analog Baseband Interface-------------
INP:SEL AIQ
//Selects the analog baseband interface as the input source
INP:IQ:TYPE I
//Only the signal on I input is analyzed (I only mode)
INP:IQ:BAL ON
//Differential input signal
INP:IQ:FULL:AUTO OFF
INP:IQ:FULL:LEV 2V
//Peak voltage at connector is set manually to the maximum of 2V
FREQ:CENT 1MHz
//Shift center frequency to 1 MHz (Low IF I)

//--------------Configuring Data Acquisition-------------
TRIG:SOUR BBP
TRIG:SEQ:LEV:BBP -20
//Trigger on baseband power of -20 dBm.
TRAC:IQ:SRAT 32MHZ
//Defines the sample rate.
TRAC:IQ:RLEN 1000
//Sets the record length (number of samples to capture) to 1000 samples.
TRAC:IQ:BWID?
//Queries the bandwidth of the resampling filter, determined by the sample rate.

//--------------Adding result displays--------------------
LAY:ADD? '1',RIGH,FREQ
//Spectrum display in window 2, to the right of Magnitude results
LAY:ADD? '1',BEL,RIMAG
//Real I display in window 3, below Magnitude results

//--------------Configuring the Trace--------------------
TRAC:IQ:AVER ON
//Defines averaging for the magnitude trace of I component.
TRAC:IQ:AVER:COUN 10
//Defines an average over 10 sweeps.

DISP:TRAC1:MODE WRIT
DISP:TRAC2:MODE MAXH
DISP:TRAC3:MODE MINH
//Changes the trace modes.

//--------------Performing the Measurement---------------------
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results----------------------------
TRAC:IQ:DATA:FORM IQBL
TRAC:IQ:DATA?
//Retrieves the captured I samples (1000 values), followed by the captured
//Q samples (1000 values); Q samples are all 0 because of I/Q mode: Low IF
TRAC2:DATA? TRACE1
//Returns the power levels for each sample (y-values from Spectrum display)
TRAC2:DATA:X? TRACE1
//Returns the frequency for each sample (x-values from Spectrum display)


Annex: Reference

I/Q Analyzer > Annex: Reference
Annex: Reference
Contents
  • Description of the LVDS Connector
  • Formats for Returned Values: ASCII Format and Binary Format
  • Reference: Format Description for I/Q Data Files
  • I/Q Data File Format (iq-tar)


Description of the LVDS Connector

I/Q Analyzer > Annex: Reference > Description of the LVDS Connector
Description of the LVDS Connector

The R&S Digital Baseband Interface is a proprietary LVDS serial interface. For adaption to industrial standard interfaces use the R&S EX-IQ-BOX (see the "R&S EX-IQ-BOX - External Signal Interface Module Manual").

The LVDS Connector is a 26 pin female 0.050" Mini D Ribbon connector (e.g.: 3M 102XX-1210VE series).

For the connection, use the cables provided with the R&S EX-IQ-BOX or an R&S®SMU-Z6 cable (order no.: 1415.0201.02).

LVDS connector on the R&S FSW rear panel, connector front view

The table "LVDS connector pin description" shows the multiplexed data at the output of the LVDS transmitter.

LVDS connector pin description
Pin | Signal | Level | Description
1 |  |  | reserved for future use
2 | GND | 0V | Ground, shield of pair 1-14, for future use
3 | SDAT0_P | LVDS | Serial data channel 0 positive pin; carries the bits VALID, ENABLE, MARKER_1 (GP4), Reserve_1 (GP2), RE_0, RE_1
4 | SDAT1_P | LVDS | Serial data channel 1 positive pin; carries the bits RE_2, RE_3, RE_4, RE_5, RE_6, RE_7
5 | SDAT2_P | LVDS | Serial data channel 2 positive pin; carries the bits RE_8, RE_9, RE_10, RE_11, RE_12, RE_13
6 | CLK1_P | LVDS | Clock 1 positive pin; clock for transmission on LVDS link
7 | S_CLK | TTL | (for future use)
8 | +5VD | +5.0V | Supply voltage (for future use)
9 | SDAT3_P | LVDS | Serial data channel 3 positive pin; carries the bits RE_14, RE_15, RE_16, RE_17, RE_18, RE_19
10 | SDAT4_P | LVDS | Serial data channel 4 positive pin; carries the bits TRIGGER_1 (GP0), TRIGGER_2 (GP1), MARKER_2 (GP5), Reserve_2 (GP3), IM_0, IM_1
11 | SDAT5_P | LVDS | Serial data channel 5 positive pin; carries the bits IM_2, IM_3, IM_4, IM_5, IM_6, IM_7
12 | SDAT6_P | LVDS | Serial data channel 6 positive pin; carries the bits IM_8, IM_9, IM_10, IM_11, IM_12, IM_13
13 | SDAT7_P | LVDS | Serial data channel 7 positive pin; carries the bits IM_14, IM_15, IM_16, IM_17, IM_18, IM_19
14 |  |  | reserved for future use
15 | SDAT0_M | LVDS | Serial data channel 0 negative pin
16 | SDAT1_M | LVDS | Serial data channel 1 negative pin
17 | SDAT2_M | LVDS | Serial data channel 2 negative pin
18 | CLK1_M | LVDS | Clock 1 negative pin
19 | DGND | 0V | Power ground; ground return for 5V supply voltage (for future use)
20 | S_DATA | TTL | (for future use)
21 | SDAT3_M | LVDS | Serial data channel 3 negative pin
22 | SDAT4_M | LVDS | Serial data channel 4 negative pin
23 | SDAT5_M | LVDS | Serial data channel 5 negative pin
24 | SDAT6_M | LVDS | Serial data channel 6 negative pin
25 | SDAT7_M | LVDS | Serial data channel 7 negative pin
26 | GND | 0V | LVDS ground; shielding of transmission lines and shielding of cable


Formats for Returned Values: ASCII Format and Binary Format

I/Q Analyzer > Annex: Reference > Formats for Returned Values: ASCII Format and Binary Format
Formats for Returned Values: ASCII Format and Binary Format

When trace data is retrieved using the TRAC:DATA or TRAC:IQ:DATA command, the data is returned in the format defined using the FORMat[:​DATA]. The possible formats are described here.

  • ASCII Format (FORMat ASCII):
    The data is stored as a list of comma separated values (CSV) of the measured values in floating point format.
  • Binary Format (FORMat REAL,32):
    The data is stored as binary data (Definite Length Block Data according to IEEE 488.2), each measurement value being formatted in 32 Bit IEEE 754 Floating-Point-Format.
    The schema of the result string is as follows:
    #41024<value1><value2>…<value n> with
#4 | number of digits (= 4 in the example) of the following number of data bytes
1024 | number of following data bytes (= 1024 in the example)
<Value> | 4-byte floating point value

Reading out data in binary format is quicker than in ASCII format. Thus, binary format is recommended for large amounts of data.


Reference: Format Description for I/Q Data Files

I/Q Analyzer > Annex: Reference > Reference: Format Description for I/Q Data Files
Reference: Format Description for I/Q Data Files

This section describes how I/Q data is transferred to the memory during remote control (see TRACe:​IQ:​DATA:​FORMat command).

For details on the format of the individual values, see "Formats for Returned Values: ASCII Format and Binary Format".

For details on the format of I/Q export files (using the "I/Q Export" function), see "I/Q Data File Format (iq-tar)".

I/Q data formats

Note: 512k corresponds to 524288 samples

For maximum performance, the formats "Compatible" or "IQPair" should be used. Furthermore, for large amounts of data, the data should be in binary format to improve performance.

In binary format, the number of I- and Q-data can be calculated as follows:

For the format "QBLock", the offset of Q-data in the output buffer can be calculated as follows:

with "LengthIndicatorDigits" being the number of digits of the length indicator including the #. In the example above (#41024…), this results in a value of 6 for "LengthIndicatorDigits" and the offset for the Q-data results in 512 + 6 = 518.


I/Q Data File Format (iq-tar)

I/Q Analyzer > Annex: Reference > I/Q Data File Format (iq-tar)
I/Q Data File Format (iq-tar)

I/Q data is packed in a file with the extension .iq.tar. An iq-tar file contains I/Q data in binary format together with meta information that describes the nature and the source of data, e.g. the sample rate. The objective of the iq-tar file format is to separate I/Q data from the meta information while still having both inside one file. In addition, the file format allows you to preview the I/Q data in a web browser, and allows you to include user-specific data.

The iq-tar container packs several files into a single .tar archive file. Files in .tar format can be unpacked using standard archive tools (see http://en.wikipedia.org/wiki/Comparison_of_file_archivers) available for most operating systems. The advantage of .tar files is that the archived files inside the .tar file are not changed (not compressed) and thus it is possible to read the I/Q data directly within the archive without the need to unpack (untar) the .tar file first.

Sample iq-tar files

If you have the optional R&S FSW VSA application (R&S FSW-K70), some sample iq-tar files are provided in the C:/R_S/Instr/user/vsa/DemoSignals directory on the R&S FSW.

Contained files
An iq-tar file must contain the following files:
  • I/Q parameter XML file, e.g. xyz.xml
    Contains meta information about the I/Q data (e.g. sample rate). The filename can be defined freely, but there must be only one single I/Q parameter XML file inside an iq-tar file.
  • I/Q data binary file, e.g. xyz.complex.float32
    Contains the binary I/Q data of all channels. There must be only one single I/Q data binary file inside an iq-tar file.
Optionally, an iq-tar file can contain the following file:
  • I/Q preview XSLT file, e.g. open_IqTar_xml_file_in_web_browser.xslt
    Contains a stylesheet to display the I/Q parameter XML file and a preview of the I/Q data in a web browser.
    A sample stylesheet is available at http://www.rohde-schwarz.com/file/open_IqTar_xml_file_in_web_browser.xslt.
Contents
  • I/Q Parameter XML File Specification
  • I/Q Data Binary File


I/Q Parameter XML File Specification

I/Q Analyzer > Annex: Reference > I/Q Data File Format (iq-tar) > I/Q Parameter XML File Specification
I/Q Parameter XML File Specification

The content of the I/Q parameter XML file must comply with the XML schema RsIqTar.xsd available at: http://www.rohde-schwarz.com/file/RsIqTar.xsd.

In particular, the order of the XML elements must be respected, i.e. iq-tar uses an "ordered XML schema". For your own implementation of the iq-tar file format make sure to validate your XML file against the given schema.

The following example shows an I/Q parameter XML file. The XML elements and attributes are explained in the following sections.

Sample I/Q parameter XML file: xyz.xml
<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl"
href="open_IqTar_xml_file_in_web_browser.xslt"?>
<RS_IQ_TAR_FileFormat fileFormatVersion="1"
xsi:noNamespaceSchemaLocation="RsIqTar.xsd"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <Name>FSV-K10</Name>
  <Comment>Here is a comment</Comment>
  <DateTime>2011-01-24T14:02:49</DateTime>
  <Samples>68751</Samples>
  <Clock unit="Hz">6.5e+006</Clock>
  <Format>complex</Format>
  <DataType>float32</DataType>
  <ScalingFactor unit="V">1</ScalingFactor>
  <NumberOfChannels>1</NumberOfChannels>
<DataFilename>xyz.complex.float32</DataFilename>
<UserData>
  <UserDefinedElement>Example</UserDefinedElement>
</UserData>
  <PreviewData>...</PreviewData>
</RS_IQ_TAR_FileFormat>

Element

Description

RS_IQ_TAR_FileFormat

The root element of the XML file. It must contain the attribute fileFormatVersion that contains the number of the file format definition. Currently, fileFormatVersion "2" is used.

Name

Optional: describes the device or application that created the file.

Comment

Optional: contains text that further describes the contents of the file.

DateTime

Contains the date and time of the creation of the file. Its type is xs:dateTime (see RsIqTar.xsd).

Samples

Contains the number of samples of the I/Q data. For multi-channel signals all channels have the same number of samples. One sample can be:

  • A complex number represented as a pair of I and Q values
  • A complex number represented as a pair of magnitude and phase values
  • A real number represented as a single real value

See also Format element.

Clock

Contains the clock frequency in Hz, i.e. the sample rate of the I/Q data. A signal generator typically outputs the I/Q data at a rate that equals the clock frequency. If the I/Q data was captured with a signal analyzer, the signal analyzer used the clock frequency as the sample rate. The attribute unit must be set to "Hz".

Format

Specifies how the binary data is saved in the I/Q data binary file (see DataFilename element). Every sample must be in the same format. The format can be one of the following:

  • complex: Complex number in cartesian format, i.e. I and Q values interleaved. I and Q are unitless
  • real: Real number (unitless)
  • polar: Complex number in polar format, i.e. magnitude (unitless) and phase (rad) values interleaved. Requires DataType = float32 or float64

DataType

Specifies the binary format used for samples in the I/Q data binary file (see DataFilename element and "I/Q Data Binary File"). The following data types are allowed:

  • int8: 8 bit signed integer data
  • int16: 16 bit signed integer data
  • int32: 32 bit signed integer data
  • float32: 32 bit floating point data (IEEE 754)
  • float64: 64 bit floating point data (IEEE 754)

ScalingFactor

Optional: describes how the binary data can be transformed into values in the unit Volt. The binary I/Q data itself has no unit. To get an I/Q sample in the unit Volt the saved samples have to be multiplied by the value of the ScalingFactor. For polar data only the magnitude value has to be multiplied. For multi-channel signals the ScalingFactor must be applied to all channels.

The attribute unit must be set to "V".

The ScalingFactor must be > 0. If the ScalingFactor element is not defined, a value of 1 V is assumed.

NumberOfChannels

Optional: specifies the number of channels, e.g. of a MIMO signal, contained in the I/Q data binary file. For multi-channels, the I/Q samples of the channels are expected to be interleaved within the I/Q data file (see "I/Q Data Binary File"). If the NumberOfChannels element is not defined, one channel is assumed.

DataFilename

Contains the filename of the I/Q data binary file that is part of the iq-tar file.

It is recommended that the filename uses the following convention:

<xyz>.<Format>.<Channels>ch.<Type>
  • <xyz> = a valid Windows file name
  • <Format> = complex, polar or real (see Format element)
  • <Channels> = Number of channels (see NumberOfChannels element)
  • <Type> = float32, float64, int8, int16, int32 or int64 (see DataType element)
Examples:
  • xyz.complex.1ch.float32
  • xyz.polar.1ch.float64
  • xyz.real.1ch.int16
  • xyz.complex.16ch.int8

UserData

Optional: contains user, application or device-specific XML data which is not part of the iq-tar specification. This element can be used to store additional information, e.g. the hardware configuration. User data must be valid XML content.

PreviewData

Optional: contains further XML elements that provide a preview of the I/Q data. The preview data is determined by the routine that saves an iq-tar file (e.g. R&S FSW). For the definition of this element refer to the RsIqTar.xsd schema. Note that the preview can be only displayed by current web browsers that have JavaScript enabled and if the XSLT stylesheet open_IqTar_xml_file_in_web_browser.xslt is available.

Example: ScalingFactor

Data stored as int16 and a desired full scale voltage of 1 V

ScalingFactor = 1 V / maximum int16 value = 1 V / 215 = 3.0517578125e-5 V

Scaling Factor | Numerical value | Numerical value x ScalingFactor
Minimum (negative) int16 value | - 215 = - 32768 | -1 V
Maximum (positive) int16 value | 215-1= 32767 | 0.999969482421875 V
Example: PreviewData in XML
<PreviewData>
    <ArrayOfChannel length="1">
      <Channel>
        <PowerVsTime>
          <Min>
            <ArrayOfFloat length="256">
              <float>-134</float>
              <float>-142</float>
              ...
              <float>-140</float>
            </ArrayOfFloat>
          </Min>
          <Max>
            <ArrayOfFloat length="256">
              <float>-70</float>
              <float>-71</float>
              ...
              <float>-69</float>
            </ArrayOfFloat>
          </Max>
        </PowerVsTime>
        <Spectrum>
          <Min>
            <ArrayOfFloat length="256">
              <float>-133</float>
              <float>-111</float>
              ...
              <float>-111</float>
            </ArrayOfFloat>
          </Min>
          <Max>
            <ArrayOfFloat length="256">
              <float>-67</float>
              <float>-69</float>
              ...
              <float>-70</float>
              <float>-69</float>
            </ArrayOfFloat>
          </Max>
        </Spectrum>
        <IQ>
          <Histogram width="64" height="64">0123456789...0</Histogram>
        </IQ>
      </Channel>
    </ArrayOfChannel>
  </PreviewData>


I/Q Data Binary File

I/Q Analyzer > Annex: Reference > I/Q Data File Format (iq-tar) > I/Q Data Binary File
I/Q Data Binary File

The I/Q data is saved in binary format according to the format and data type specified in the XML file (see Format element and DataType element). To allow reading and writing of streamed I/Q data, all data is interleaved, i.e. complex values are interleaved pairs of I and Q values and multi-channel signals contain interleaved (complex) samples for channel 0, channel 1, channel 2 etc. If the NumberOfChannels element is not defined, one channel is presumed.

Example: Element order for real data (1 channel)
I[0],                         // Real sample 0
I[1],                         // Real sample 1
I[2],                         // Real sample 2
...
Example: Element order for complex cartesian data (1 channel)
I[0], Q[0],                   // Real and imaginary part of complex sample 0
I[1], Q[1],                   // Real and imaginary part of complex sample 1
I[2], Q[2],                   // Real and imaginary part of complex sample 2
...
Example: Element order for complex polar data (1 channel)
Mag[0], Phi[0],               // Magnitude and phase part of complex sample 0
Mag[1], Phi[1],               // Magnitude and phase part of complex sample 1
Mag[2], Phi[2],               // Magnitude and phase part of complex sample 2
...
Example: Element order for complex cartesian data (3 channels)

Complex data: I[channel no][time index], Q[channel no][time index]

I[0][0], Q[0][0],            // Channel 0, Complex sample 0
I[1][0], Q[1][0],            // Channel 1, Complex sample 0
I[2][0], Q[2][0],            // Channel 2, Complex sample 0

I[0][1], Q[0][1],            // Channel 0, Complex sample 1
I[1][1], Q[1][1],            // Channel 1, Complex sample 1
I[2][1], Q[2][1],            // Channel 2, Complex sample 1

I[0][2], Q[0][2],            // Channel 0, Complex sample 2
I[1][2], Q[1][2],            // Channel 1, Complex sample 2
I[2][2], Q[2][2],            // Channel 2, Complex sample 2
...
Example: Element order for complex cartesian data (1 channel)

This example demonstrates how to store complex cartesian data in float32 format using MATLAB®.

% Save vector of complex cartesian I/Q data, i.e. iqiqiq...
N = 100
iq = randn(1,N)+1j*randn(1,N)
fid = fopen('xyz.complex.float32','w');
for k=1:length(iq)
  fwrite(fid,single(real(iq(k))),'float32');
  fwrite(fid,single(imag(iq(k))),'float32');
end
fclose(fid)


List of Remote Commands (I/Q Analyzer+I/Q Input Interfaces (B17+B71))

I/Q Analyzer > List of Remote Commands (I/Q Analyzer+I/Q Input Interfaces (B17+B71))
List of Remote Commands (I/Q Analyzer+I/Q Input Interfaces (B17+B71))
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:METHod
[SENSe:]CORRection:RECall
[SENSe:]CORRection:TRANsducer:GENerator
[SENSe:]CORRection[:STATe]
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]IQ:BANDwidth|BWIDth:MODE
[SENSe:]IQ:BANDwidth|BWIDth:RESolution
[SENSe:]IQ:FFT:ALGorithm
[SENSe:]IQ:FFT:LENGth
[SENSe:]IQ:FFT:WINDow:LENGth
[SENSe:]IQ:FFT:WINDow:OVERlap
[SENSe:]IQ:FFT:WINDow:TYPE
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe]
[SENSe:]PMETer<p>[:STATe]
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]SWAPiq
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:POINts
[SENSe:]SWEep:TIME
ABORt
CALCulate:IQ:MODE
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:LOEXclude
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SSIZe
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:THReshold
CALCulate:THReshold:STATe
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:SEARch
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:PMETer<p>:RELative:STATe
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:UNIT:POWer
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
CALibration:PMETer<p>:ZERO:AUTO ONCE
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FETCh:PMETer<p>?
FORMat:DEXPort:DSEParator
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILE:PATH
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe
MMEMory:STORe:LIST
OUTPut:DIQ
OUTPut:DIQ:CDEVice
OUTPut:IF:IFFRequency
OUTPut:IF:SBANd?
OUTPut:IF[:SOURce]
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
READ:PMETer<p>?
SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:ROSCillator[:SOURce]
SOURce:EXTernal[:STATe]
SOURce:POWer[:LEVel][:IMMediate]:OFFSet
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe:IQ:AVERage:COUNt
TRACe:IQ:AVERage[:STATe]
TRACe:IQ:BWIDth
TRACe:IQ:DATA:FORMat
TRACe:IQ:DATA:MEMory?
TRACe:IQ:DATA?
TRACe:IQ:DIQFilter
TRACe:IQ:EGATe
TRACe:IQ:EGATe:GAP
TRACe:IQ:EGATe:LENGth
TRACe:IQ:EGATe:NOFgateperiods
TRACe:IQ:EGATe:TYPE
TRACe:IQ:EVAL
TRACe:IQ:RLENgth
TRACe:IQ:SET
TRACe:IQ:SRATe
TRACe:IQ:TPISample?
TRACe:IQ:WBANd:MBWIDTH
TRACe:IQ:WBANd[:STATe]
TRACe:IQ[:STATe]
TRACe<n>:COPY
TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval
UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer:RATio


Legal Notice

R&S®FSW I/Q Analyzer and I/Q Input
Interfaces

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.